LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Dial-up connection not functioning...Slackware 14 (http://www.linuxquestions.org/questions/slackware-14/dial-up-connection-not-functioning-slackware-14-a-4175434886/)

Laxman_prodigy 10-31-2012 07:05 AM

Dial-up connection not functioning...Slackware 14
 
Hey guys..

I'm trying to get my Usb modem work in slackware 14. I have a MTS Mblaze usb modem that I'm trying to get working. The network manager is detecting the card and all valid information like username and passwords. But I'm unable to establish any connection yet. It's failing everytime. As for now I've no clue what might be the issue and I'm not that good enough on network troubleshooting. I'm using the default network manager that ships with slackware 14. I've heard that kppp works well with dial-up connections but I'm not getting any links to downloading and installing it. So What could I possibly do? Any help would be appreciated.

BTW I'm using Kde.

amani 10-31-2012 09:15 AM

wvdial should be sufficient.

Bourbon 11-01-2012 05:04 AM

Hi Laxman,

KPPP is already on Slackware, you get it under All applications>Internet; try it but if it is not establishing the dial-up connection, I suspect that you need to make pppoe configuration.
Check if the packet rp-pppoe is already installed or if you need it and configure.
I don't know your modem but if it is going to establish a 3G connection, you can use a wonderful script, Sakis3G, you get it here:
http://www.sakis3g.org/

Best Regards

markush 11-01-2012 05:59 AM

I had a similar problem a few month ago, here's the thread: http://www.linuxquestions.org/questi...em-4175420175/
You will find many information there. I've not yet managed wvdial to build, but the comgt package was very helpful it is available on slackbuilds.org .

Long story short: it is possible to connect to the internet via UMTS-modem with the pppoe-package only!

Markus

slowpaxi 11-02-2012 04:02 AM

Quote:

Originally Posted by Bourbon (Post 4819555)
Hi Laxman,

KPPP is already on Slackware, you get it under All applications>Internet; try it but if it is not establishing the dial-up connection, I suspect that you need to make pppoe configuration.
Check if the packet rp-pppoe is already installed or if you need it and configure.
I don't know your modem but if it is going to establish a 3G connection, you can use a wonderful script, Sakis3G, you get it here:
http://www.sakis3g.org/

Best Regards

I'm confirmig this. I managed to fix a good connection on a 3G network on an alcatel X500 USB modem installing usb_modeswitch and sakis3g script, wich I recommend too, though unable to report the positive issue to their user forum still in mantainance mode. This permitted me to let sleep the windows rescue installation after moving to another country. Imagine my satisfaction! After establishing it, the ppp0 connection can be shared using dnsmasq over ethernet such as in this ArchWiki, for instance. Best luck everybody!


All times are GMT -5. The time now is 03:35 PM.