LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   dhcpcd wireless problems. dhcpcd wlan0 removes essid entry in iwconfig. (http://www.linuxquestions.org/questions/slackware-14/dhcpcd-wireless-problems-dhcpcd-wlan0-removes-essid-entry-in-iwconfig-665157/)

Romanus81 08-25-2008 12:56 AM

dhcpcd wireless problems. dhcpcd wlan0 removes essid entry in iwconfig.
 
I have an msi wind laptop, and it uses Realtek's rtl8180 driver. My first problem was getting the drivers to work and recognize the wlan0 interface. The solution was to upgrade to the 2.6.26.3 kernel which included the rtl8180 driver (r8180). iwconfig finally recognized wlan0, and I tried typing in the essid and wep key, and IWconfig recognizes the change:
Code:

wlan0  802.11b/g ESSID:"ESSID"
        Mode:Managed Acess Point: Not Associated Bit Rate: 11 Mb/s
        Retry: on  RTS thr:off  Fragment thr: off
        Encryption key:1234-5678-90 Security mode: open
        Power management: off
        Link Quality=0/100 Signal level=0 dBm  Noise Level=0 dBm
        Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
        Tx excessive retries:0 Invalid misc:0 Missed beacon:0

"dhcpcd wlan0" does nothing but wait for about 10 or 15 seconds and then return to the command line, no internet connection, and my essid dissapears, s that the first two lines now read.
Code:

wlan0  802.11b/g Mode:Managed Acess Point: Not Associated
        Bit Rate: 11 Mb/s

And all is normal as before.

"/etc/rc.d/rc.inet1 wlan0_up" gives me
Code:


Error for wireless request "set Nickname" (8B1C) :
No carrier detected on wlan0. Reducing DHCP timeout to 10 seconds.
dhcpcd: MAC adress = 00:1d:92:c6:db:84

dhcpcd -d gives me
Code:

dhcpcd: MAC adress = 00:1d:92:c6:db:84
And every time I try dhcpcd, dmesg gives me this:
Code:

rtl8180: Setting up SW wep key
rtl8180: Setting up SW wep key
rtl8180: bringing up iface
rtl8180: card successfully reset
rtl8180: WIRELESS_MODE_G

ADDRCONF(NETDEV_UP): wlan0: link is not ready.

I managed to get this working in ubuntu, but ubuntu is just so different after using slackware I don't think I can use it.
Help please!

pinniped 08-25-2008 01:15 AM

Try a manual setup first; I'll assume that the device must be 'down' while being configured:

ifconfig wlan0 down
iwconfig wlan0 essid "Your EsSiD" mode managed key s:Your_WEP_password
ifconfig wlan0 up
dhclient wlan0

If wlan0 needs to be configured while 'up' then:
ifconfig wlan0 up
iwconfig wlan0 essid "Your EsSiD" mode managed key s:Your_WEP_password
dhclient wlan0

Romanus81 08-25-2008 02:47 PM

Well, I got it to work with Wicd, not too happy about it, it seems to be a bit hackish and I would have preferred native support without additional programs but whatever works is good enough.
Is it then ok for me to chmod -x the /etc/rc.inet1 file and have wicd do it all?

Romanus81 08-25-2008 10:34 PM

ah! I thought by dhclient you meant whatever I use for dhcp, but I typed in the command exactly and it works! I can't thank you enough for this!


All times are GMT -5. The time now is 09:03 AM.