LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   dhcpcd problems (http://www.linuxquestions.org/questions/slackware-14/dhcpcd-problems-812525/)

slugman 06-06-2010 02:21 PM

dhcpcd problems
 
Hey fellow slackers! Im in a bit of a conundrum that is agrivating the hell out of me, hopefully one of you slacks can lend a hand!

Lets see, it all started when my interwebs went out. Thankfully the lad nextdoor is a cool mofo and has let us use the interwebs until me and my poor roomate can afford to pay our isp.

Now heres the thing, I can use wpa_supplicant to connect to the wep network, no problem (well, mostly). But, for some flippin' reason, dhcpcd can't get an address? Auto defaults to 169?

Does anyone have any suggestions I may try to get this to work? I don't want to distrupt my neighbors settings to much by disabling dhcp and have everyone go static (was already denied).

the f'd up thing is, my roomy's window 7 compy can get an address, just fine (where i'm posting from..).. argh.

(Or, does anyone have any experience using rc.inet1.conf to statically assign yourself an adress w/ a working dhcp server? I assumed dhcp server must be disabled to get this to work..)

This is on slack 13.0. I'll have to go to my friends to dl the new 13.1 iso

Any help is appreciated!
- Slug

linq 06-06-2010 02:33 PM

Quote:

Originally Posted by slugman (Post 3994588)
But, for some flippin' reason, dhcpcd can't get an address? Auto defaults to 169?

169 ... usually signifies the media is not connected.

Do you specify interface ? Should be something like

dhcpcd wlan0

"dhcpcd uses the network interface eth0 unless an explicit name is specified."

slugman 06-06-2010 02:37 PM

linq, yea dude, i start the command via:
> dhcpcd wlan0

and no go ):

slugman 06-06-2010 02:38 PM

and btw, I KNOW my card is connected to the access point because, I am using wpa_supplicant, and I get the [auth] completed to bssid <mac address here> message

linq 06-06-2010 02:51 PM

Quote:

Originally Posted by slugman (Post 3994612)
and btw, I KNOW my card is connected to the access point because, I am using wpa_supplicant, and I get the [auth] completed to bssid <mac address here> message

Are you sure that dhcpd is not restricted to specified macs ?

slugman 06-06-2010 02:58 PM

lol, i thought what if the chap didn't like just me?

well, it would be nice if he was using a slack server w/ dhcpd, but he's using a links wrt 54gs something or other. (im logged in right now) and yea, no mac address filter is enabled. Note: I also disabled Frame Burst and set the Transmission rate to 54mpbs... still no go

):

slugman 06-06-2010 03:29 PM

wtf
 
okay guys. i've come up with a temporary solution, but it illustrates something that i would like to determine the answer to.

Basically, i've bridged the wifi connection from my roomy's window7 lappy um, directly to our router. and this works great!

I can get dhcpcd to grab an ip from my router with no problems.

but why the f*** can't my box grab an ip w/ dhcpcd, from my neighbors router, directly? Especially when my roomy's window7 laptop can grab an ip from it just fine? and now i have to horse around with this window7 horse shit.

we pretty much have the same linksys router and settings enabled, so wtf. if there are any networking 802.11 gurus out here who know what they are doing and can shed some light, please enlighten us!!

gezley 06-06-2010 04:49 PM

Quote:

Originally Posted by slugman (Post 3994659)
okay guys. i've come up with a temporary solution, but it illustrates something that i would like to determine the answer to.

Basically, i've bridged the wifi connection from my roomy's window7 lappy um, directly to our router. and this works great!

I can get dhcpcd to grab an ip from my router with no problems.

but why the f*** can't my box grab an ip w/ dhcpcd, from my neighbors router, directly? Especially when my roomy's window7 laptop can grab an ip from it just fine? and now i have to horse around with this window7 horse shit.

we pretty much have the same linksys router and settings enabled, so wtf. if there are any networking 802.11 gurus out here who know what they are doing and can shed some light, please enlighten us!!

Have you set up a firewall on the Slackware machine? If so, check it's not blocking UDP ports 67-69.

I don't understand why you don't want to set up a static address. If it's just for you and your roommate it will hardly inconvenience your neighbour? I also don't understand how you're logged in to your neighbour's Linksys router if you have a 169.xxx.xxx.xxx address?

slugman 06-06-2010 05:13 PM

@ gezley:

no firewalll, no iptable chains are set.

Also, Like I mentioned in my original post, I was using my roomates windows 7 laptop to post on the forum and check the router settings. (you'll notice the window7 logo on the posts i made from my roomates lappy--whereas, this post has tux).

I tried setting the address via static assignment by editing rc.inet1.conf, in the wlan0 section.. ipaddress, netmask, and gateway, but for some reason i kept getting network unreachable error. also, I would attempt to assign the address via > ifconfig wlan0 192.168.x.x, but that didn't work either..

question, if the router has "DCHP" server enabled, would static assignments still work? would the DHCP server have to be disabled in order for this to work?

gezley 06-06-2010 06:37 PM

Quote:

Originally Posted by slugman (Post 3994733)
@ gezley:

no firewalll, no iptable chains are set.

Also, Like I mentioned in my original post, I was using my roomates windows 7 laptop to post on the forum and check the router settings. (you'll notice the window7 logo on the posts i made from my roomates lappy--whereas, this post has tux).

OK - mea culpa, I missed that completely.

Quote:

I tried setting the address via static assignment by editing rc.inet1.conf, in the wlan0 section.. ipaddress, netmask, and gateway, but for some reason i kept getting network unreachable error. also, I would attempt to assign the address via > ifconfig wlan0 192.168.x.x, but that didn't work either..

question, if the router has "DCHP" server enabled, would static assignments still work? would the DHCP server have to be disabled in order for this to work?
Yes of course you can set a static IP address. Just make sure it's somewhere in the mid-range so you don't have a conflict. That's pretty much guesswork. Choose something like 192.168.1.137. And don't forget to set your DNS server in /etc/resolv.conf. But I have a feeling it's something to do with encryption or MAC filtering.

linq 06-07-2010 02:14 AM

Quote:

Originally Posted by slugman (Post 3994733)

I tried setting the address via static assignment by editing rc.inet1.conf, in the wlan0 section.. ipaddress, netmask, and gateway, but for some reason i kept getting network unreachable error. also, I would attempt to assign the address via > ifconfig wlan0 192.168.x.x, but that didn't work either..

question, if the router has "DCHP" server enabled, would static assignments still work? would the DHCP server have to be disabled in order for this to work?

Of course it will ^). If you tried to set static IP and it doesn't work, why blame dhcpcd ? What network unreachable with static IP ?.
Could you provide more details than just "didn't work" ? Like some router and your station logs ?

slugman 06-10-2010 12:46 AM

Ok guys, I think I've gotten a little closer to the root problem. Basically, I got dhcpcd to work with my nieghbor's router, and static assignment using ifconfig command. What I forgot to pay attention to was, believe it or not, the fact that I was using KDE's suspend to ram feature. I've noticed some odd behavior with this before, and have come to the conclusion that its one of those buggy features that we can only hope continued development will eventually straighten out. I made a post on Jeremy's new site, Linuxexchange.org in regards to this matter. (The problem here is quite different however; after using suspend to ram feauture I lose all virtual consoles except for the active x windows/ tty7, however even tty7 disappears when I use init 0 command.

So to summarize, I made sure to completely shut down my box via init 0, and restart my machine with a clean boot. Worked like a charm.

I am not completely up to date, as I mentioned above I'm using 13.0 and have yet to upgrade to 13.1rc. Once I have some good time to update my machines (I really should just setup a pxe server again like I did w/ 12.2, but alas I only have so much time), I'll upgrade my lan (i have 4 boxes on Slack.. everything else just sucks). Hopefully, 13.1rc brings some improvements. I'll definetely make sure to post my results.

In regards to using rc.inet1.conf, I'll wasn't quite successful although I am sure that is due to configuration issues (read pebkac). This will require some more testing on my part, but if I have any troubles, I'll ensure to create a new thread since that is a different topic.

XGizzmo 06-10-2010 06:07 AM

Some wireless cards don't suspend well, like the intel 3945 card I have in this laptop.
To work around the problem you can have pm-utils unload the module, when you resume it
will load the module again and at least in my case work as expected.

You unload a module via pm-utils by creating a config file located in /etc/pm/config.d

Mine is called iwl3945 (name it whatever you like) it contains 1 line.
SUSPEND_MODULES="iwl3945"

BTW newer kernels (2.6.33+) have power management disabled for this module because of
this type of problem.


All times are GMT -5. The time now is 01:19 AM.