LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 09-18-2005, 06:07 PM   #1
relpats_eht
Member
 
Registered: Mar 2004
Distribution: Gentoo
Posts: 41

Rep: Reputation: 15
dhcpcd problems


i did a fresh intall of slack 10.2 today, and now i can't get my net to work

my card is running, but no ip is being set, and the access point is not the mac addr of my router (though it is the correct essid). also, it is using eth1 (isn't it supposed to use wlan0?) i know there was a step i missed in installing, i just can't remember what (made modules, installed modules, ran modules, restarted)

im pretty sure the problem is with dhcpcd, boot hangs for quite a time running that, as does the console, until it times out.

Any help would be appreciated.
 
Old 09-18-2005, 07:26 PM   #2
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
Some wireless drivers use eth1, some wireless drivers use wlan0. If iwconfig is not showing the correct MAC for your access point, then dhcp isn't the problem. DHCP comes after associating with the access point. Does iwconfig show an association with the proper access point?
 
Old 09-18-2005, 07:51 PM   #3
relpats_eht
Member
 
Registered: Mar 2004
Distribution: Gentoo
Posts: 41

Original Poster
Rep: Reputation: 15
no, the problem was dhcp. i forgot to set eht1 to use dhcp in rc.inet1.conf, all is well now.
 
Old 09-18-2005, 08:07 PM   #4
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
Very odd. Maybe the two mac addresses are mixed by your driver then?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Boot problems... dhcpcd? danthehat Linux - Software 0 08-03-2005 03:10 PM
LTSP dhcpcd port problems Artanicus Linux - Networking 1 07-31-2005 07:19 AM
dhcpcd problems drobe011 Slackware 1 07-09-2005 10:32 PM
dhcpcd / dhclient problems tomap Linux - Wireless Networking 1 11-01-2004 04:49 PM
Suse dhcpcd problems ihristov Suse/Novell 8 10-29-2004 01:51 AM


All times are GMT -5. The time now is 04:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration