LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-28-2004, 01:16 PM   #1
meyert
LQ Newbie
 
Registered: Aug 2003
Posts: 2

Rep: Reputation: 0
dhcpcd, no network cable plugged in


Hidili hodili.

I am using dhcpcd for my eth0 device. but when booting the system and no network cable is plugged in, then the dhcpcd client still tries to do a broadcast and a discover or vice versa.

Is there a way to change this behavior?

Because while dhcpcd is doing this, time goes by... :-)

with kind regards
Thomas
 
Old 04-28-2004, 01:33 PM   #2
ringwraith
Senior Member
 
Registered: Sep 2003
Location: Indiana
Distribution: Slackware-current
Posts: 1,244

Rep: Reputation: 47
Disable dhcp? Why are you unplugging your network cable when you boot anyway?
 
Old 04-28-2004, 05:27 PM   #3
coffeedrinker
Member
 
Registered: Sep 2003
Posts: 173

Rep: Reputation: 30
I have a laptop and don't usually have the network cable plugged in (usually go with the wireless pcmcia card).

What I did to get this passage of time down is:

-change the line in /etc/rc.d/rc.M
/etc/rc.d/rc.inet1
to
/etc/rc.d/rc.inet1 &
(that makes it do the network stuff in the background)

I also dropped the time from 10 seconds to 8 by changing the /etc/rc.d/rc.inet1 line:

/sbin/dhcpcd -t 8 -h ${DHCP_HOSTNAME[$1]} -d eth${1}
 
Old 04-28-2004, 08:34 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,978
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Guess it largely depends on what your distro is how to
go about this, what I'm doing is to append a variable
LOCATION=<xxx> from lilo (with three different menu
entries for work, home, no_net) that will be evaluated
from /etc/rc.d/rc.inet1 (in mycase) ... if it's no-net inet1
just exits after setting up lo, if it's home it goes dhcp,
if it's work it comes up with a static IP.


Cheers,
Tink
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
if( ethernet-cable-is-plugged-in ) { ... mrtwice Linux - Networking 13 10-08-2006 02:57 PM
plugged in lan cable, still "not connected'' message shows New@Mandrake Linux - Networking 5 10-14-2004 11:56 AM
What happens when a network cable is plugged in ? balajipriya Linux - Networking 1 08-12-2004 09:10 AM
Automatically Connect when cable is plugged in?? NovaBurst Fedora 2 02-18-2004 09:15 AM
RH freezes when network card is plugged in pilot1 Linux - Networking 4 12-17-2002 01:17 PM


All times are GMT -5. The time now is 09:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration