Go Job Hunting at the LQ Job Marketplace
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


LinkBack Search this Thread
Old 10-08-2012, 07:37 PM   #1
Registered: Nov 2006
Distribution: Slackware
Posts: 292

Rep: Reputation: 39
DHCP slows down boot time - using wifi

I have a basic network setup which does not use a static ip address, I guess that was automatically assigning via DHCP. It slows down my boot time as it tries to detect DHCP which doesn't exists at boot time since I setup NetworkManager for wifi.

Can I get rid of that DHCP lookup process without losing the ability to use DHCP with plugged in to a LAN?

Old 10-08-2012, 08:38 PM   #2
Senior Member
Registered: Jul 2011
Distribution: LFS-SVN, Slackware-14.1, PCBSD-10.0
Posts: 2,401
Blog Entries: 14

Rep: Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584Reputation: 584
Have you tried NetworkManager?
Old 10-08-2012, 08:55 PM   #3
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 419

Rep: Reputation: Disabled
It seems like you're talking about rc.inet1 starting up. You can do two things:

1. Comment the rc.inet1 section in rc.M:
# Initialize the networking hardware
-if [ -x /etc/rc.d/rc.inet1 ]; then
-  . /etc/rc.d/rc.inet1

# Initialize the networking hardware
+#if [ -x /etc/rc.d/rc.inet1 ]; then
+#  . /etc/rc.d/rc.inet1
Or just make it so that rc.inet1 can't be executed:
# chmod -x /etc/rc.d/rc.inet1
1 members found this post helpful.
Old 10-09-2012, 04:38 AM   #4
Registered: Feb 2009
Distribution: Slackware, Arch
Posts: 517

Rep: Reputation: 132Reputation: 132
Edit /etc/rc.d/rc.inet1.conf and make sure you don't have any interfaces configured.

Probably somewhere you have USE_DHCP[n]="yes"

They should all look like this if you're using networkmanager:
# Config information for eth0:

Last edited by piratesmack; 10-09-2012 at 04:41 AM.
1 members found this post helpful.
Old 10-10-2012, 08:38 PM   #5
Registered: Nov 2006
Distribution: Slackware
Posts: 292

Original Poster
Rep: Reputation: 39

Sorry I missed revisiting my own thread .

Yes, I'm using NetworkManager currently. Its just that I want to cut the boot time delay caused by this DHCP thing. I'll just try disabling rc.inet1 and see if it improves and still working.

Old 10-14-2012, 08:14 AM   #6
Registered: Nov 2006
Distribution: Slackware
Posts: 292

Original Poster
Rep: Reputation: 39
I disabled /etc/rc.d/rc.inet1 and so far, it speeds boot time a bit due to few seconds saved for without looking up DHCP.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
network slows down until wifi is turned off esteeven Linux - Wireless Networking 2 10-05-2006 04:58 AM
Wifi Slows,then stops,then SOMETIMES restarts + ubuntu + dlink WDA 2320 Lagg Linux - Wireless Networking 2 09-23-2006 03:06 PM
Problem with DHCP at boot time Prassanta Suse/Novell 1 06-30-2006 03:31 PM
eth0 DHCP time out on boot AtomicAmish Fedora 9 06-19-2006 03:03 PM
dhcp slows boot javierj Linux - Newbie 3 03-02-2005 11:24 PM

All times are GMT -5. The time now is 11:04 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration