LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   DHCP slows down boot time - using wifi (http://www.linuxquestions.org/questions/slackware-14/dhcp-slows-down-boot-time-using-wifi-4175431233/)

dc_eros 10-08-2012 08:37 PM

DHCP slows down boot time - using wifi
 
I have a basic network setup which does not use a static ip address, I guess that was automatically assigning via DHCP. It slows down my boot time as it tries to detect DHCP which doesn't exists at boot time since I setup NetworkManager for wifi.

Can I get rid of that DHCP lookup process without losing the ability to use DHCP with plugged in to a LAN?

TIA

ReaperX7 10-08-2012 09:38 PM

Have you tried NetworkManager?

TommyC7 10-08-2012 09:55 PM

It seems like you're talking about rc.inet1 starting up. You can do two things:

1. Comment the rc.inet1 section in rc.M:
Code:

# Initialize the networking hardware
-if [ -x /etc/rc.d/rc.inet1 ]; then
-  . /etc/rc.d/rc.inet1
-fi

# Initialize the networking hardware
+#if [ -x /etc/rc.d/rc.inet1 ]; then
+#  . /etc/rc.d/rc.inet1
+#fi

Or just make it so that rc.inet1 can't be executed:
Code:

# chmod -x /etc/rc.d/rc.inet1

piratesmack 10-09-2012 05:38 AM

Edit /etc/rc.d/rc.inet1.conf and make sure you don't have any interfaces configured.

Probably somewhere you have USE_DHCP[n]="yes"

They should all look like this if you're using networkmanager:
Code:

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""


dc_eros 10-10-2012 09:38 PM

Hi,

Sorry I missed revisiting my own thread :D.

Yes, I'm using NetworkManager currently. Its just that I want to cut the boot time delay caused by this DHCP thing. I'll just try disabling rc.inet1 and see if it improves and still working.

Thanks

dc_eros 10-14-2012 09:14 AM

I disabled /etc/rc.d/rc.inet1 and so far, it speeds boot time a bit due to few seconds saved for without looking up DHCP.

Thanks


All times are GMT -5. The time now is 01:40 AM.