LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-25-2007, 12:50 AM   #1
brokenflea
Member
 
Registered: Nov 2003
Distribution: Slackware 11.0, FreeBSD
Posts: 284

Rep: Reputation: 30
/dev/tun not working after a kernel upgrade


Hello,

I just upgraded to kernel 2.6.15 on slackware 11.0 and now after I try running openvpn I get a:

Code:
Sat Feb 24 23:18:33 2007 Note: Cannot open TUN/TAP dev /dev/net/tun: No such device (errno=19)
Sat Feb 24 23:18:33 2007 Note: Attempting fallback to kernel 2.2 TUN/TAP interface
Sat Feb 24 23:18:33 2007 Cannot allocate TUN/TAP dev dynamically
Sat Feb 24 23:18:33 2007 Exiting
Here's my kernel config file where tunnelling is specified

Code:
CONFIG_INET_AH=y
CONFIG_INET_ESP=y
CONFIG_INET_IPCOMP=y
CONFIG_INET_TUNNEL=y
CONFIG_INET_DIAG=y
CONFIG_INET_TCP_DIAG=y
Also, I don't have a tun directory in /dev. So I created one using mkdir and then did a mknod /dev/net/tun c 10 200 ,
but that doesn't work either.

Where should I start looking next.
Any help is gladly appreciated


TIA
 
Old 02-26-2007, 12:18 AM   #2
brokenflea
Member
 
Registered: Nov 2003
Distribution: Slackware 11.0, FreeBSD
Posts: 284

Original Poster
Rep: Reputation: 30
Figured it out, I had left out CONFIG_TUN=n in my kernel config. Everything works now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/dev/lp0 gone after kernel upgrade trigggl Linux - Hardware 10 08-13-2007 01:19 PM
vnuml tun device /dev/net/tun not found. asalford Linux - Networking 1 01-30-2007 10:11 PM
need help: /dev/net/tun boxyou Linux - Networking 1 04-29-2005 02:11 AM
How do I use /dev/net/tun mike8s2 Linux - Networking 2 04-19-2005 08:01 PM
Unable to open tun device after kernel upgrade. EOHooligan Linux - Software 4 02-06-2005 09:31 AM


All times are GMT -5. The time now is 08:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration