LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 09-02-2006, 07:35 PM   #1
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 293Reputation: 293Reputation: 293
/dev/rtc + udev in current


I'm trying to get a working /dev/rtc. In my udev.rules it supposedly creates it in /dev/misc but it isn't working. In fact only agpgart and psaux are there.

# misc devices
KERNEL=="agpgart", NAME="misc/%k", SYMLINK+="%k"
KERNEL=="psaux", NAME="misc/%k", SYMLINK+="%k"
KERNEL=="rtc", NAME="misc/%k", SYMLINK+="%k", MODE="0664"
KERNEL=="uinput", NAME="misc/%k", SYMLINK+="%k"
KERNEL=="inotify", NAME="misc/%k", SYMLINK+="%k", MODE="0666"

I tried making one for dev with mknod /dev/rtc c 10 135 but that created an unreadable file.

Last edited by dive; 09-02-2006 at 07:38 PM.
 
Old 09-02-2006, 09:48 PM   #2
jimX86
Member
 
Registered: Mar 2006
Distribution: Slackware64 14.1
Posts: 233
Blog Entries: 1

Rep: Reputation: 36
It works on my machine. I'm still trying to figure out udev as I go, but here's a thought...

Do you have Enhanced Real Time Clock support built into your kernel? I'm not sure, but I don't udev will load modules for you if you have hotplug installed.
 
Old 09-02-2006, 09:50 PM   #3
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Original Poster
Rep: Reputation: 293Reputation: 293Reputation: 293
Yeah I have rtc as a built-in mod and it's a 2.6 kernel so hotplug shouldn't be running. All other devs are ok.

I will try building it as a mod and modprobing it.
 
Old 09-02-2006, 10:37 PM   #4
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Original Poster
Rep: Reputation: 293Reputation: 293Reputation: 293
Ok it seems when you select rtc as a module 2 extra options open up below - generic rtc and extended. This is not the case when having it built-in so I guess it's a bug.

Building as a mod (+ the extra 2) and modprobing works fine.

Last edited by dive; 09-02-2006 at 10:53 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slackware-current, udev 0.96, and custom udev rules not working rignes Slackware 6 08-10-2006 04:43 AM
VMWare with /dev/rtc issue megabot Linux - Software 2 01-05-2006 11:59 AM
missing /dev/rtc meres Linux - General 7 10-17-2005 02:37 PM
Not unknown problem with /dev/rtc carbono Linux - Newbie 1 10-13-2005 09:04 AM
/dev/rtc not currently available in VMWARE, Mandrake 9.2 Guitarist88 Linux - Software 1 04-11-2004 02:54 PM


All times are GMT -5. The time now is 01:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration