LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   /dev/rtc + udev in current (http://www.linuxquestions.org/questions/slackware-14/dev-rtc-udev-in-current-479859/)

dive 09-02-2006 07:35 PM

/dev/rtc + udev in current
 
I'm trying to get a working /dev/rtc. In my udev.rules it supposedly creates it in /dev/misc but it isn't working. In fact only agpgart and psaux are there.

# misc devices
KERNEL=="agpgart", NAME="misc/%k", SYMLINK+="%k"
KERNEL=="psaux", NAME="misc/%k", SYMLINK+="%k"
KERNEL=="rtc", NAME="misc/%k", SYMLINK+="%k", MODE="0664"
KERNEL=="uinput", NAME="misc/%k", SYMLINK+="%k"
KERNEL=="inotify", NAME="misc/%k", SYMLINK+="%k", MODE="0666"

I tried making one for dev with mknod /dev/rtc c 10 135 but that created an unreadable file.

jimX86 09-02-2006 09:48 PM

It works on my machine. I'm still trying to figure out udev as I go, but here's a thought...

Do you have Enhanced Real Time Clock support built into your kernel? I'm not sure, but I don't udev will load modules for you if you have hotplug installed.

dive 09-02-2006 09:50 PM

Yeah I have rtc as a built-in mod and it's a 2.6 kernel so hotplug shouldn't be running. All other devs are ok.

I will try building it as a mod and modprobing it.

dive 09-02-2006 10:37 PM

Ok it seems when you select rtc as a module 2 extra options open up below - generic rtc and extended. This is not the case when having it built-in so I guess it's a bug.

Building as a mod (+ the extra 2) and modprobing works fine.


All times are GMT -5. The time now is 01:28 PM.