LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-12-2005, 12:59 AM   #1
Lagg
Member
 
Registered: Jul 2003
Distribution: Slackware
Posts: 67

Rep: Reputation: 15
/dev/nvdia* permissions keep resetting on reboot


yes, I've checked the other permission resetting treads, and I've tried some stuff.

what i've tried

1) editing the /etc/security/console.perms
a) tried to comment anything with /dev/nvidia* out : didn't work
b) tried setting <console> 0600 <dri> 0600 root.video:didn't work
to 666 instead of the 600
b) setting console to xconsole: didn't work

2) made sure user was in VIDEO group: didn't work


now for my problem (and it's kinda interesting). Everything was fine in 10.0. I did have /dev/nvidia problems at the very very first, but adding USER to VIDEO group fixed it.

I upgrade to 10.1 and throw the newest dropline on it (although I kept the orginal 2.6.10 kernel from the EXTRA on slackware 10.0 ?problem?). I can play doom, I can play enemy territory. I can see what the GL screen saver will look like in the little preview window, but when it comes to actually using the GL screensaver...BAM!!!! ye olde "permissions are too restrictive". I can throw a chmod 666 on /dev/nvidia* and things works great but only until I restart.

Is there a solution for this or are things just and leave it be?

Thanks

Lagg.
 
Old 05-12-2005, 01:03 AM   #2
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Take a look at /etc/udev/scripts/make_extra_nodes.sh
And make sure you've these lines:
Code:
# nVidia modules don't know about udev, so a little bit more clutter is in order.
mknod -m 660 /dev/nvidiactl c 195 255
mknod -m 660 /dev/nvidia0 c 195 0
mknod -m 660 /dev/nvidia1 c 195 1
# If you have more than two of these cards, you'll have to add devices below.
#mknod -m 660 /dev/nvidia2 c 195 2
#mknod -m 660 /dev/nvidia3 c 195 3
chown root:video /dev/nvidia*
 
Old 05-12-2005, 01:08 AM   #3
kevner
LQ Newbie
 
Registered: May 2005
Location: Tuscaloosa, AL, USA
Distribution: Ubuntu 5.10
Posts: 5

Rep: Reputation: 0
I'm fairly novice when it comes to X, but you might try adding to your /etc/rc.d/rc.local file

the chmod 666 command

and then re-initialize your X server [if need be]

kill -SIGHUP X (i have no idea what the syntax is)

i dunno if that's what you're looking for, hope that helps.
 
Old 05-12-2005, 01:31 AM   #4
Lagg
Member
 
Registered: Jul 2003
Distribution: Slackware
Posts: 67

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by gbonvehi
Take a look at /etc/udev/scripts/make_extra_nodes.sh
And make sure you've these lines:
Code:
# nVidia modules don't know about udev, so a little bit more clutter is in order.
mknod -m 660 /dev/nvidiactl c 195 255
mknod -m 660 /dev/nvidia0 c 195 0
mknod -m 660 /dev/nvidia1 c 195 1
# If you have more than two of these cards, you'll have to add devices below.
#mknod -m 660 /dev/nvidia2 c 195 2
#mknod -m 660 /dev/nvidia3 c 195 3
chown root:video /dev/nvidia*

yeah I got it.
 
Old 05-12-2005, 01:41 AM   #5
Lagg
Member
 
Registered: Jul 2003
Distribution: Slackware
Posts: 67

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by kevner
I'm fairly novice when it comes to X, but you might try adding to your /etc/rc.d/rc.local file

the chmod 666 command

and then re-initialize your X server [if need be]

kill -SIGHUP X (i have no idea what the syntax is)

i dunno if that's what you're looking for, hope that helps.

hey that worked.....

but I wonder if there's another solution
 
Old 05-13-2005, 07:52 AM   #6
zborgerd
Member
 
Registered: Mar 2004
Distribution: Slackware / Dropline GNOME
Posts: 378

Rep: Reputation: 30
Hello,

The reasons that these things change are due to Slackware's UDEV permissions rules. You will need to either add yourself to the "video" group in /etc/group, or modify the nvidia and other 3d lines in /etc/udev/permissions.d/udev.permissions to 666. The first choice is the best.

The console.perms changes that you've made will not do anything yet, because the pam_console module is not applying settings on login. We're working on that for a future update. In the mean time, you need to set things as you would on a normal stock Slackware install (as noted above).
 
Old 05-13-2005, 09:32 AM   #7
mlangdn
Senior Member
 
Registered: Mar 2005
Location: Kentucky
Distribution: Slackware64-current
Posts: 1,373

Rep: Reputation: 164Reputation: 164
Quote:
Originally posted by zborgerd
Hello,

The reasons that these things change are due to Slackware's UDEV permissions rules. You will need to either add yourself to the "video" group in /etc/group, or modify the nvidia and other 3d lines in /etc/udev/permissions.d/udev.permissions to 666. The first choice is the best.

The console.perms changes that you've made will not do anything yet, because the pam_console module is not applying settings on login. We're working on that for a future update. In the mean time, you need to set things as you would on a normal stock Slackware install (as noted above).
That's because Slackware does not use Pam - probably never will.
Adding myself to video in /etc/group worked for me. Editing permissions.d did not work at all.

Be sure and put a comma in front of your user name when you add yourself to the video section of /etc/group.

Last edited by mlangdn; 05-13-2005 at 09:34 AM.
 
Old 05-13-2005, 04:04 PM   #8
Lagg
Member
 
Registered: Jul 2003
Distribution: Slackware
Posts: 67

Original Poster
Rep: Reputation: 15
Re: /dev/nvdia* permissions keep resetting on reboot

Quote:
Originally posted by Lagg
yes, I've checked the other permission resetting treads, and I've tried some stuff.

what i've tried...

2) made sure user was in VIDEO group: didn't work>

never worked.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
resetting permissions on everything? microsoft/linux Debian 7 05-31-2005 08:58 PM
Permissions resetting brinkster Mandriva 1 12-06-2004 06:54 AM
hostname resetting to localhost on unclean reboot brian_h1 Linux - Networking 0 05-11-2004 08:18 PM
samba share permissions keep resetting Red Squirrel Linux - Newbie 0 03-03-2004 08:55 PM
Permissions keep resetting for directory HiRoll3r Linux - Newbie 3 05-19-2003 11:08 AM


All times are GMT -5. The time now is 06:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration