LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   /dev/nvdia* permissions keep resetting on reboot (http://www.linuxquestions.org/questions/slackware-14/dev-nvdia%2A-permissions-keep-resetting-on-reboot-322615/)

Lagg 05-12-2005 12:59 AM

/dev/nvdia* permissions keep resetting on reboot
 
yes, I've checked the other permission resetting treads, and I've tried some stuff.

what i've tried

1) editing the /etc/security/console.perms
a) tried to comment anything with /dev/nvidia* out : didn't work
b) tried setting <console> 0600 <dri> 0600 root.video:didn't work
to 666 instead of the 600
b) setting console to xconsole: didn't work

2) made sure user was in VIDEO group: didn't work


now for my problem (and it's kinda interesting). Everything was fine in 10.0. I did have /dev/nvidia problems at the very very first, but adding USER to VIDEO group fixed it.

I upgrade to 10.1 and throw the newest dropline on it (although I kept the orginal 2.6.10 kernel from the EXTRA on slackware 10.0 ?problem?). I can play doom, I can play enemy territory. I can see what the GL screen saver will look like in the little preview window, but when it comes to actually using the GL screensaver...BAM!!!! ye olde "permissions are too restrictive". I can throw a chmod 666 on /dev/nvidia* and things works great but only until I restart.

Is there a solution for this or are things just :scratch: and leave it be?

Thanks

Lagg.

gbonvehi 05-12-2005 01:03 AM

Take a look at /etc/udev/scripts/make_extra_nodes.sh
And make sure you've these lines:
Code:

# nVidia modules don't know about udev, so a little bit more clutter is in order.
mknod -m 660 /dev/nvidiactl c 195 255
mknod -m 660 /dev/nvidia0 c 195 0
mknod -m 660 /dev/nvidia1 c 195 1
# If you have more than two of these cards, you'll have to add devices below.
#mknod -m 660 /dev/nvidia2 c 195 2
#mknod -m 660 /dev/nvidia3 c 195 3
chown root:video /dev/nvidia*


kevner 05-12-2005 01:08 AM

I'm fairly novice when it comes to X, but you might try adding to your /etc/rc.d/rc.local file

the chmod 666 command

and then re-initialize your X server [if need be]

kill -SIGHUP X (i have no idea what the syntax is)

i dunno if that's what you're looking for, hope that helps.

Lagg 05-12-2005 01:31 AM

Quote:

Originally posted by gbonvehi
Take a look at /etc/udev/scripts/make_extra_nodes.sh
And make sure you've these lines:
Code:

# nVidia modules don't know about udev, so a little bit more clutter is in order.
mknod -m 660 /dev/nvidiactl c 195 255
mknod -m 660 /dev/nvidia0 c 195 0
mknod -m 660 /dev/nvidia1 c 195 1
# If you have more than two of these cards, you'll have to add devices below.
#mknod -m 660 /dev/nvidia2 c 195 2
#mknod -m 660 /dev/nvidia3 c 195 3
chown root:video /dev/nvidia*



yeah I got it.

Lagg 05-12-2005 01:41 AM

Quote:

Originally posted by kevner
I'm fairly novice when it comes to X, but you might try adding to your /etc/rc.d/rc.local file

the chmod 666 command

and then re-initialize your X server [if need be]

kill -SIGHUP X (i have no idea what the syntax is)

i dunno if that's what you're looking for, hope that helps.


hey that worked.....

but I wonder if there's another solution

zborgerd 05-13-2005 07:52 AM

Hello,

The reasons that these things change are due to Slackware's UDEV permissions rules. You will need to either add yourself to the "video" group in /etc/group, or modify the nvidia and other 3d lines in /etc/udev/permissions.d/udev.permissions to 666. The first choice is the best.

The console.perms changes that you've made will not do anything yet, because the pam_console module is not applying settings on login. We're working on that for a future update. In the mean time, you need to set things as you would on a normal stock Slackware install (as noted above).

mlangdn 05-13-2005 09:32 AM

Quote:

Originally posted by zborgerd
Hello,

The reasons that these things change are due to Slackware's UDEV permissions rules. You will need to either add yourself to the "video" group in /etc/group, or modify the nvidia and other 3d lines in /etc/udev/permissions.d/udev.permissions to 666. The first choice is the best.

The console.perms changes that you've made will not do anything yet, because the pam_console module is not applying settings on login. We're working on that for a future update. In the mean time, you need to set things as you would on a normal stock Slackware install (as noted above).

That's because Slackware does not use Pam - probably never will.
Adding myself to video in /etc/group worked for me. Editing permissions.d did not work at all.

Be sure and put a comma in front of your user name when you add yourself to the video section of /etc/group.

Lagg 05-13-2005 04:04 PM

Re: /dev/nvdia* permissions keep resetting on reboot
 
Quote:

Originally posted by Lagg
yes, I've checked the other permission resetting treads, and I've tried some stuff.

what i've tried...

2) made sure user was in VIDEO group: didn't work>


never worked.


All times are GMT -5. The time now is 11:09 AM.