LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-23-2007, 11:53 PM   #1
Ook
Member
 
Registered: Apr 2004
Location: Hell, Arizona
Distribution: Slackware 14.1
Posts: 339

Rep: Reputation: 27
/dev/hdc no longer linked to /dev/cdrom - why?


For some reason, /dev/hdc, my cdrom/dvd player, was no longer associated with /dev/cdrom. If I try to mount /dev/cdrom, I get:

mount: /dev/cdrom is not a valid block device

I finally figured out that the cd player was being recognized as /dev/hdc, but just not /dev/cdrom. After a bit of research, I did this:

ls -l /dev/cdrom /dev/hdc

and now everything seems to be back to normal. I did recompile a new kernel, 2.6.22.5, but I've compiled several kernels before without this ever happening. Any ideas what went wrong, and did I do the correct thing to fix it?
 
Old 08-24-2007, 12:30 AM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
By default on Slackware-12.0:
Code:
anna@peter:~$ ls -lh /dev/hdc
brw-rw---- 1 root cdrom 22, 0 2007-08-22 02:27 /dev/hdc
anna@peter:~$ ls -lh /dev/cdrom
lrwxrwxrwx 1 root root 3 2007-08-22 02:27 /dev/cdrom -> hdc
When you issued:
Code:
ls -l /dev/cdrom /dev/hdc
you didn't "fix" anything. You issued the command "list -l (use a long listing format)" -- see "man ls".

What type of CD-ROM were you trying to mount? You can't mount music CDs.
 
Old 08-24-2007, 12:36 AM   #3
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Presumably the OP made a typo and meant "ln -s" .
 
Old 08-25-2007, 12:00 AM   #4
Ook
Member
 
Registered: Apr 2004
Location: Hell, Arizona
Distribution: Slackware 14.1
Posts: 339

Original Poster
Rep: Reputation: 27
My bad, it was ln -s.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount /dev/hdc /dev/cdrom doesn't work ShrikesHarvest Linux - Newbie 10 02-21-2009 07:05 AM
mount /dev/hdc /dev/cdrom doesn't work amandaortega Linux - Hardware 6 12-01-2006 04:48 AM
I cannot access EITHER CD drive! And there's no /dev/hdc or /dev/hdd or /dev/cdrom! Dmalic Linux - Hardware 13 11-18-2005 07:11 PM
/dev/cdrom constantly linked to /dev/hdd r_jensen11 Linux - Hardware 6 09-24-2004 01:51 PM
/dev/cdrom & /dev/hdc missing! Lord_Devi Slackware 4 06-25-2004 09:17 AM


All times are GMT -5. The time now is 11:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration