LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 02-09-2005, 02:42 PM   #1
KeithKessler
Member
 
Registered: Dec 2001
Location: Stow, OH
Distribution: Slackware 10
Posts: 73

Rep: Reputation: 15
/dev/hda2 not a valid block device


Hello All,

I finally got my Slack 10.1 install strightened out with one exception: I can't mount hda2. Mounting during the boot via fstab fails with: /dev/had2 is not a valid block device.

This is the output from fdisk -l

Device Boot Start End Blocks Id System
/dev/hda1 * 1 7295 58597056 83 Linux
/dev/hda2 7296 19209 95699205 83 Linux
/dev/hda3 19210 19457 1992060 82 Linux swap

You can see it's there - I formatted it as ReiserFS during the install.

When i try to mount manually with mount /dev/hda2 /mnt/backup I get the same /dev/hda2 is not a valid block device.

I even tried to format it again with mkfs -t reiserfs -f /dev/hda2 and got this:

/dev/hda2 is not a block special device
Continue (y/n):y
Guessing about desired format.. Kernel 2.4.29 is running.
reiserfs_create: can not create that small (0 blocks) filesystem

I've searched the forums and most all the postings on this subject have to do with USB or CD ROM drives.

Any ideas anyone?

Thanks,

--Keith
 
Old 02-09-2005, 02:52 PM   #2
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
As you have no data into this partition, I would try to delete it and re-create it using
cfdisk or similar tool, then re-format it
 
Old 02-09-2005, 02:59 PM   #3
KeithKessler
Member
 
Registered: Dec 2001
Location: Stow, OH
Distribution: Slackware 10
Posts: 73

Original Poster
Rep: Reputation: 15
Gave it a try.

Deleted the partition, wrote the partition table, created a new partition, wrote the partition table then attemtped mkfs -t reiserfs /dev/hda2 and got :

/dev/hda2 is not a block special device
Use -f to force over

Then tried mkfs -t reiserfs -f /dev/hda2 and got:

/dev/hda2 is not a block special device
Continue (y/n):y
Guessing about desired format.. Kernel 2.4.29 is running.
reiserfs_create: can not create that small (0 blocks) filesystem

Thanks for the suggestion though...

Any more ideas anyone??
 
Old 02-09-2005, 03:08 PM   #4
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
Could you post the output of ls -al /dev/hda2 ?
 
Old 02-09-2005, 03:13 PM   #5
KeithKessler
Member
 
Registered: Dec 2001
Location: Stow, OH
Distribution: Slackware 10
Posts: 73

Original Poster
Rep: Reputation: 15
Here you go:

total 62
drwxr-xr-x 2 root root 48 2005-02-08 07:07 ./
drwxr-xr-x 16 root root 62520 2005-02-08 22:47 ../


Thanks,
 
Old 02-09-2005, 03:54 PM   #6
DaHammer
Member
 
Registered: Oct 2003
Location: Planet Earth
Distribution: Slackware, LFS
Posts: 561

Rep: Reputation: 30
Hmm, so you have no /dev/hda2 it appears. Strange. Try creating it with mknod.
Code:
mknod /dev/hda2 b 3 2
 
Old 02-09-2005, 04:18 PM   #7
KeithKessler
Member
 
Registered: Dec 2001
Location: Stow, OH
Distribution: Slackware 10
Posts: 73

Original Poster
Rep: Reputation: 15
mknod /dev/hda2 b 3 2 yields:

mknod: `/dev/hda2': File exists

Thanks!
 
Old 02-09-2005, 06:39 PM   #8
killerbob
Member
 
Registered: Oct 2004
Location: Ottawa, ON
Distribution: Slackware
Posts: 662

Rep: Reputation: 30
Don't thank him just yet.... mknod reporting that the file already exists means that it didn't do anything.

You're using the out-of-the-box kernel? I ask, because reiser isn't compiled in by default in the kernel (at least, it isn't enabled by default in the 2.6.10 image I downloaded). It's possible, if you've downloaded a kernel from kernel.org and compiled it, you forgot to enable reiser support.

What happens if you call it with mkreiserfs instead of mkfs -t reiserfs? I know that theoretically, mkreiserfs just calls mkfs with the type set to reiser, but it might actually work. Also, what if you try a different filesystem type, such as ext3 or ext2?
 
Old 02-09-2005, 07:25 PM   #9
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
To make sure, could you post also the output with:
ls -al /dev/hda*

[edit]
forget this if you run a 2.4.* kernel (default) as I suspected a hotplug/udev failure (which
can appear with 2.6.x)

Last edited by keefaz; 02-09-2005 at 07:29 PM.
 
Old 02-09-2005, 07:48 PM   #10
mikieboy
Member
 
Registered: Apr 2004
Location: Warrington, Cheshire, UK
Distribution: Linux Mint 12 LXDE
Posts: 555

Rep: Reputation: 33
What does your /etc/fstab say for /dev/hda2 ?
 
Old 02-09-2005, 08:56 PM   #11
KeithKessler
Member
 
Registered: Dec 2001
Location: Stow, OH
Distribution: Slackware 10
Posts: 73

Original Poster
Rep: Reputation: 15
Running the bare.i 2.4.29 - what came packaged with 10.1 (will upgrade to 2.6.10 as soon as I get everything else set the way I want) Reiserfs is compiled into the kernel as hda1 is reiserfs and it mounts fine as the root (I once forgot to add reiserfs in on a custom kernel and have learned my lesson

fstab looks like:

/proc /proc proc defaults 0 0
/dev/pts /dev/pts devpts mode=0622 0 0
/dev/cdrom /mnt/cdrom auto user,noauto,exec,ro 0 0
/dev/hda1 / reiserfs defaults 1 1
/dev/hda2 /mnt/backup reiserfs defaults 0 0
/dev/hda3 swap swap defaults 0 0

One note I had to created my fstab manually (boot with knoppix and type it all out) for some reason it wasn't created by the 10.1 installer

Also the drive is brand new - ran cfdisk to set everything up then installed 10.1

--Keith

Last edited by KeithKessler; 02-09-2005 at 09:02 PM.
 
Old 02-09-2005, 10:10 PM   #12
KeithKessler
Member
 
Registered: Dec 2001
Location: Stow, OH
Distribution: Slackware 10
Posts: 73

Original Poster
Rep: Reputation: 15
Workaround

Okay, I came up with a workaround that I'm satisfied with! I deleted the partition hda2 and then created a small 500 MB partition using hda2 with the remaining free space (~95 GB) I created another partition - hda4. I formated hda4 with reiserfs and can mount it with no problems!

I'm not sure what's going on with hda2 but this will work for me!

Thanks for your help everyone!

--Keith

Last edited by KeithKessler; 02-09-2005 at 10:13 PM.
 
Old 02-10-2005, 04:39 AM   #13
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
Did you try to delete /dev/hda2 directory and do the mknod command ?
 
Old 02-10-2005, 10:10 AM   #14
KeithKessler
Member
 
Registered: Dec 2001
Location: Stow, OH
Distribution: Slackware 10
Posts: 73

Original Poster
Rep: Reputation: 15
I did not try that..

--KK
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Block device /dev/sda3 is not a valid root device.. rincewind Linux - Hardware 7 06-09-2006 05:47 AM
/dev/fd0 is not a valid block device intmail Slackware 2 07-21-2005 07:52 AM
/dev/sda1 NOT a valid block device ??? mack4evr Suse/Novell 5 10-15-2004 02:06 PM
/dev/cdrom is not a valid block device kryptotronic Debian 8 04-04-2004 06:11 PM
/dev/fd0 is not a valid block device allnight Linux - General 7 02-21-2002 09:42 PM


All times are GMT -5. The time now is 06:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration