LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-26-2005, 01:04 AM   #1
Basel
Member
 
Registered: Feb 2004
Location: United States
Distribution: Ubuntu 10.10
Posts: 319

Rep: Reputation: 30
/dev/hda under lilo.conf even thoug my HD is under /dev/hdb


Hi,

Why did Slackware added /dev/hda to the top of lilo.conf even though my HD is under /dev/hdb?
I experienced a strange behavior with Slackware 10.2 installation yesterday when I tried to install Lilo to the MBR. The installer gave and error which I do not remember at the moment. However, after I booted from the CD and viewed /etc/lilo.conf I noticed that /dev/hda was added at the top while under the Linux boot section /dev/hdb, which is the correct one in my case, was added. I had to change /dev/hda to /dev/hdb for lilo to be installed.
 
Old 10-26-2005, 06:46 PM   #2
uopjohnson
Member
 
Registered: Jun 2004
Location: San Francisco
Distribution: Slackware, Ubuntu, RHEL, OS X
Posts: 159

Rep: Reputation: 30
Did you use the automatic option when configuring lilo during installation? If I recall correctly you manually set this VAR when you select the advanced lilo option.
 
Old 10-26-2005, 10:51 PM   #3
Basel
Member
 
Registered: Feb 2004
Location: United States
Distribution: Ubuntu 10.10
Posts: 319

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by uopjohnson
Did you use the automatic option when configuring lilo during installation? If I recall correctly you manually set this VAR when you select the advanced lilo option.
Yes, I selected the automatic option when configuring lilo.
 
Old 10-26-2005, 11:03 PM   #4
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,748

Rep: Reputation: 159Reputation: 159
Re: /dev/hda under lilo.conf even thoug my HD is under /dev/hdb

Quote:
Originally posted by Basel
I had to change /dev/hda to /dev/hdb for lilo to be installed.
In an IDE system, the boot loader must be installed in the boot sector of the primary master HD.

This means that the first line of your lilo.conf file should read:
Code:
boot = /dev/hda
Then in the OS section, you should have:
Code:
image = /boot/vmlinuz
label = linux
root = /dev/hdbx
Where x= the number of the partition on hdb you want to use as Linux's root directory.
 
Old 10-26-2005, 11:25 PM   #5
Basel
Member
 
Registered: Feb 2004
Location: United States
Distribution: Ubuntu 10.10
Posts: 319

Original Poster
Rep: Reputation: 30
Re: Re: /dev/hda under lilo.conf even thoug my HD is under /dev/hdb

Quote:
Originally posted by rkelsen
In an IDE system, the boot loader must be installed in the boot sector of the primary master HD.

This means that the first line of your lilo.conf file should read:
Code:
boot = /dev/hda
Lilo refuses to be installed when the boot options is set to /dev/hda
Code:
Reading boot sector from /dev/hda
Fatal: open /dev/hda: No such device or address
 
Old 10-27-2005, 01:12 AM   #6
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,748

Rep: Reputation: 159Reputation: 159
Re: Re: Re: /dev/hda under lilo.conf even thoug my HD is under /dev/hdb

Quote:
Originally posted by Basel
Lilo refuses to be installed when the boot options is set to /dev/hda
Code:
Reading boot sector from /dev/hda
Fatal: open /dev/hda: No such device or address
Are your hard drives SATA or IDE?
 
Old 10-27-2005, 07:10 AM   #7
Basel
Member
 
Registered: Feb 2004
Location: United States
Distribution: Ubuntu 10.10
Posts: 319

Original Poster
Rep: Reputation: 30
Re: Re: Re: Re: /dev/hda under lilo.conf even thoug my HD is under /dev/hdb

Quote:
Originally posted by rkelsen
Are your hard drives SATA or IDE?
IDE. I think this problem appeared because pins 3 and 4 of the J8 jumper are jumpered. In other words, the HD is set as Slave and not as Master.
 
Old 10-27-2005, 10:24 AM   #8
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Re: Re: Re: Re: Re: /dev/hda under lilo.conf even thoug my HD is under /dev/hdb

Quote:
Originally posted by Basel
IDE. I think this problem appeared because pins 3 and 4 of the J8 jumper are jumpered. In other words, the HD is set as Slave and not as Master.
Heh, yeah, that's the root of the problem then:
hda = primary master
hdb = primary slave
hdc = secondary master
hdd = secondary slave

Probably it's assumed that at least one disk will be at primary master, you can check the setup sources to see that.

Last edited by gbonvehi; 10-27-2005 at 10:26 AM.
 
Old 10-27-2005, 06:00 PM   #9
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,748

Rep: Reputation: 159Reputation: 159
Re: Re: Re: Re: Re: /dev/hda under lilo.conf even thoug my HD is under /dev/hdb

Quote:
Originally posted by Basel
IDE. I think this problem appeared because pins 3 and 4 of the J8 jumper are jumpered. In other words, the HD is set as Slave and not as Master.
Yep. That's your problem. I find that it is best to use "Cable Select" (CS) option on all HDs. Then there is always a master and slave.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dd if=/dev/hda of=dev/hdb taking forever to complete fechin Linux - Hardware 7 06-19-2005 12:04 AM
Clone with dd if=/dev/hda of=/dev/hdb question wrc1944 Linux - Hardware 2 11-28-2004 09:10 AM
can't boot anymore /dev/hdb -> /dev/hde broxtor Linux - Hardware 4 11-13-2004 10:55 AM
How can I boot either one of my hard drives /dev/hda or /dev/hdb, I have RH9 and FC2 omogunkristi Linux - General 1 06-21-2004 05:11 AM
Lilo installation -> /dev/hda is read only ThePlague Linux - Hardware 6 06-05-2003 09:51 AM


All times are GMT -5. The time now is 09:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration