LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   /dev/hda under lilo.conf even thoug my HD is under /dev/hdb (http://www.linuxquestions.org/questions/slackware-14/dev-hda-under-lilo-conf-even-thoug-my-hd-is-under-dev-hdb-376974/)

Basel 10-26-2005 01:04 AM

/dev/hda under lilo.conf even thoug my HD is under /dev/hdb
 
Hi,

Why did Slackware added /dev/hda to the top of lilo.conf even though my HD is under /dev/hdb?
I experienced a strange behavior with Slackware 10.2 installation yesterday when I tried to install Lilo to the MBR. The installer gave and error which I do not remember at the moment. However, after I booted from the CD and viewed /etc/lilo.conf I noticed that /dev/hda was added at the top while under the Linux boot section /dev/hdb, which is the correct one in my case, was added. I had to change /dev/hda to /dev/hdb for lilo to be installed.

uopjohnson 10-26-2005 06:46 PM

Did you use the automatic option when configuring lilo during installation? If I recall correctly you manually set this VAR when you select the advanced lilo option.

Basel 10-26-2005 10:51 PM

Quote:

Originally posted by uopjohnson
Did you use the automatic option when configuring lilo during installation? If I recall correctly you manually set this VAR when you select the advanced lilo option.
Yes, I selected the automatic option when configuring lilo.

rkelsen 10-26-2005 11:03 PM

Re: /dev/hda under lilo.conf even thoug my HD is under /dev/hdb
 
Quote:

Originally posted by Basel
I had to change /dev/hda to /dev/hdb for lilo to be installed.
In an IDE system, the boot loader must be installed in the boot sector of the primary master HD.

This means that the first line of your lilo.conf file should read:
Code:

boot = /dev/hda
Then in the OS section, you should have:
Code:

image = /boot/vmlinuz
label = linux
root = /dev/hdbx

Where x= the number of the partition on hdb you want to use as Linux's root directory.

Basel 10-26-2005 11:25 PM

Re: Re: /dev/hda under lilo.conf even thoug my HD is under /dev/hdb
 
Quote:

Originally posted by rkelsen
In an IDE system, the boot loader must be installed in the boot sector of the primary master HD.

This means that the first line of your lilo.conf file should read:
Code:

boot = /dev/hda

Lilo refuses to be installed when the boot options is set to /dev/hda
Code:

Reading boot sector from /dev/hda
Fatal: open /dev/hda: No such device or address


rkelsen 10-27-2005 01:12 AM

Re: Re: Re: /dev/hda under lilo.conf even thoug my HD is under /dev/hdb
 
Quote:

Originally posted by Basel
Lilo refuses to be installed when the boot options is set to /dev/hda
Code:

Reading boot sector from /dev/hda
Fatal: open /dev/hda: No such device or address


Are your hard drives SATA or IDE?

Basel 10-27-2005 07:10 AM

Re: Re: Re: Re: /dev/hda under lilo.conf even thoug my HD is under /dev/hdb
 
Quote:

Originally posted by rkelsen
Are your hard drives SATA or IDE?
IDE. I think this problem appeared because pins 3 and 4 of the J8 jumper are jumpered. In other words, the HD is set as Slave and not as Master.

gbonvehi 10-27-2005 10:24 AM

Re: Re: Re: Re: Re: /dev/hda under lilo.conf even thoug my HD is under /dev/hdb
 
Quote:

Originally posted by Basel
IDE. I think this problem appeared because pins 3 and 4 of the J8 jumper are jumpered. In other words, the HD is set as Slave and not as Master.
Heh, yeah, that's the root of the problem then:
hda = primary master
hdb = primary slave
hdc = secondary master
hdd = secondary slave

Probably it's assumed that at least one disk will be at primary master, you can check the setup sources to see that.

rkelsen 10-27-2005 06:00 PM

Re: Re: Re: Re: Re: /dev/hda under lilo.conf even thoug my HD is under /dev/hdb
 
Quote:

Originally posted by Basel
IDE. I think this problem appeared because pins 3 and 4 of the J8 jumper are jumpered. In other words, the HD is set as Slave and not as Master.
Yep. That's your problem. I find that it is best to use "Cable Select" (CS) option on all HDs. Then there is always a master and slave.


All times are GMT -5. The time now is 03:24 AM.