LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   /dev/cdrom links to /dev/sg0 instead of /dev/sr0 -why? (http://www.linuxquestions.org/questions/slackware-14/dev-cdrom-links-to-dev-sg0-instead-of-dev-sr0-why-488434/)

Yalla-One 10-01-2006 07:27 AM

/dev/cdrom links to /dev/sg0 instead of /dev/sr0 -why?
 
For some reason, /dev/cdrom links to the character device rather than the block device, causing the "mount /dev/cdrom" to fail.

My 10-local.rules file has the following entry:
Code:

# Sony USB CD/DVD-RW
BUS=="usb", SYSFS{manufacturer}=="Sony", SYSFS{serial}=="DRX-510ULK_CED011664",
NAME="%k", GROUP="cdrom", MODE="0666", SYMLINK+="dvd cdrom"

For some reason this tags the character device sg0 rather than the block device, sr0 ...

Anyone?

-Y1

pld 10-01-2006 05:33 PM

I am having the same issues here, and was wondering if anyone knew what might be happening? (My external usb dvdrw used to work fine).

Relevant dmesg section looks like this when I plug it in:
Code:

[17201921.372000] usb 3-4.1: new high speed USB device using ehci_hcd and address 11
[17201921.496000] scsi8 : SCSI emulation for USB Mass Storage devices
[17201921.496000] usb-storage: device found at 11
[17201921.496000] usb-storage: waiting for device to settle before scanning
[17201926.528000]  Vendor: HL-DT-ST  Model: DVDRRW GSA-2166D  Rev: 1.00
[17201926.528000]  Type:  CD-ROM                            ANSI SCSI revision: 00
[17201927.056000] sr0: scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
[17201927.056000] sr 8:0:0:0: Attached scsi CD-ROM sr0
[17201927.056000] sr 8:0:0:0: Attached scsi generic sg2 type 5
[17201927.056000] usb-storage: device scan complete


ardya 10-01-2006 05:53 PM

Quote:

Originally Posted by Yalla-One
For some reason, /dev/cdrom links to the character device rather than the block device, causing the "mount /dev/cdrom" to fail.

My 10-local.rules file has the following entry:
Code:

# Sony USB CD/DVD-RW
BUS=="usb", SYSFS{manufacturer}=="Sony", SYSFS{serial}=="DRX-510ULK_CED011664",
NAME="%k", GROUP="cdrom", MODE="0666", SYMLINK+="dvd cdrom"

For some reason this tags the character device sg0 rather than the block device, sr0 ...

Anyone?

-Y1

Check udev.rules

marnold 10-01-2006 08:02 PM

A bit of a shot in the dark here, but did you try

bus=="scsi"


All times are GMT -5. The time now is 01:04 PM.