LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 02-03-2003, 09:47 PM   #1
dlandsurveys
LQ Newbie
 
Registered: Jan 2003
Location: somewhere, north america
Distribution: slackware 9.0 or 9.1 soon to be 10.0
Posts: 15

Rep: Reputation: 0
detecting a modem on Slackware 8.1


I installed Slackware 8.1 but I can't get the internet connection. I go through pppsetup but when I do ppp-go it doesn't go and just says connect script failed. I have a dial-up service with a US robotics 56k FAX INT Pnp, (which is an ISA internal faxmodem, Product ID# 00568703) on Com 2, resources say IRQ: 10; I/O 02f8h-02FFh.

US Robotics told me that I should manually set the modem to com 2 with the jumpers and set the IRQ to 3. When I did that however, windows wouldn't detect the modem. So I went back to Plug and Play and windows (98se) detected and the modem again works fine in Windows.

My kid who gave me the modem said that it worked in Mandrake and maybe I need a driver for the modem but US Robotics said that it is not supported in Linux. Does anyone know where I can get a driver for this modem off the internet? Do you think that's what I need to get a modem connection in Slackware 8.1?
 
Old 02-03-2003, 10:21 PM   #2
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
Take a look at "isapnp" support. I used to run it when I had an ISA Creative Soundblaster AWE 64 sound card. It was the only way to get Linux setup to read the setup information correctly. If you installed it on your installation, there should be some info in the /usr/doc/isapnptools-1.26 directory.

Perhaps it will help. You could also do a search here on LQ for isapnp and see what threads turn up. I would not think is very specific to just Slack.
 
Old 02-04-2003, 11:59 PM   #3
hawk4eye
Member
 
Registered: Jul 2002
Location: Lacon, IL
Distribution: Slackware
Posts: 35

Rep: Reputation: 15
You might try dmesg then scroll up <shift+PgUp> to see if the kernel has a pnp enabled and has dected the modem. You might be able to see what the hardware settings are if it does, to use in pppsetup. Or try jumpering the modem to use a chosen irq and com port. If you use the jumpers to choose the irq and com port, its not in pnp mod and windows will not detect it.
 
Old 02-05-2003, 01:58 AM   #4
Darin
Senior Member
 
Registered: Jan 2003
Location: Portland, OR USA
Distribution: Slackware, SLAX, Gentoo, RH/Fedora
Posts: 1,024

Rep: Reputation: 45
Or you could go back and jumper it again, windows won't "auto" detect it but you can run the modem scan (ctrl pnl -> modems -> add ->...heck you use slack I prolly don't have to walk you through this) and it will pick it up. Just try to use common com port settings such as COM1/ttyS0/irq4/03f8 or COM2/ttyS1/irq3/02f8.
 
Old 02-05-2003, 10:02 AM   #5
dlandsurveys
LQ Newbie
 
Registered: Jan 2003
Location: somewhere, north america
Distribution: slackware 9.0 or 9.1 soon to be 10.0
Posts: 15

Original Poster
Rep: Reputation: 0
Darin, I did run modem scan but windows wouldn't detect the modem. It would get stuck and the hourglass would freeze. The only way to get out was to shut the computer off as even control alt delete wouldn't work.

US Robotics wondered if my bios has serial settings instead of com settings but when I went through the bios I didn't notice any reference to serial port vs com port. But I did notice in the bios that I have a choice on the IRQ's between available and reserved. All my IRQ's said available. Any thoughts anyone?
 
Old 02-07-2003, 10:21 PM   #6
newpenguin
Member
 
Registered: Sep 2002
Location: lahore pakistan
Distribution: slackware,redhat, FreeBSD,openbsd
Posts: 219

Rep: Reputation: 30
normally there are 2 serial ports on your motherboard.
one uses ttyS0 and one uses ttyS1 , all you have to do is to make one serial port free and no device on it.
no just learn 1 command of how to set irq with "setserial".
and write them in your slackware's script "/etc/rc.d/rc.serial"
set your modem on the free ttyS either ttyS0 or ttyS1.and i think you can set it on any other ttyS as well like ttyS2 or ttyS3,4.
read this it will clear you
http://www.justlinux.com/nhf/Modems/...PCI_Modem.html

and ISA modems normally need no driver.
 
Old 02-07-2003, 11:01 PM   #7
Darin
Senior Member
 
Registered: Jan 2003
Location: Portland, OR USA
Distribution: Slackware, SLAX, Gentoo, RH/Fedora
Posts: 1,024

Rep: Reputation: 45
Using the modem jumpered:

To make sure there is no conflict try to find the BIOS setting for com ports and turn off the one you set your USR modem to. So if you set it to com2 then shut off the motherboard's com2. Then to prevent an IRQ conflict if that's what makes it lock up you find the IRQ's available and mark the one you use for the modem (irq3 for com2/ttyS1 or irq4 for com1/ttyS0) and set it to reserved.
 
Old 02-11-2003, 12:08 PM   #8
dlandsurveys
LQ Newbie
 
Registered: Jan 2003
Location: somewhere, north america
Distribution: slackware 9.0 or 9.1 soon to be 10.0
Posts: 15

Original Poster
Rep: Reputation: 0
Hi everybody, I found instructions on the internet (thanks to newpenguin) to configure my modem but...as you see they show where to find the appropriate init script to put this command in Redhat, Mandrake and Debian but they don't list Slackware. Where in Slackware would I find the init script? Thanks everyone for the help.



"Issue the following command as root:

setserial /dev/ttyS2 uart 16550A port 0xfcc0 irq 5

substituting the port and irq values for your own. Now let's find the appropriate init script to put this command in so that it will automatically be prepared at bootup. In Red Hat & Mandrake you should have a file called rc.local (/etc/rc.d/rc.local) where you can add this command. Make sure that the file is there, and as root type: echo setserial /dev/ttyS2 uart 16550A port 0xfcc0 irq 5 >> /etc/rc.d/rc.local (this appends the setserial entry to the end of the file). In Debian, I use /etc/init.d/bootmisc.sh. (Alternatively, you can just edit the script with your favorite editor.) Your modem should now be configured for use."
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Modem Not Detecting sagar Linux - Hardware 5 11-04-2004 09:28 AM
Not detecting modem? Ghimlok Linux - Software 1 12-01-2003 09:19 AM
Modem Not Detecting Batiu-Drami Linux - Hardware 13 06-21-2003 10:29 AM
Modem not Detecting muhammadawood Linux - Hardware 3 12-20-2002 03:27 PM
Ssue 8 not detecting my isapnp modem as a modem cmisip Linux - Hardware 6 11-10-2002 02:48 AM


All times are GMT -5. The time now is 09:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration