LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Desktop Animations in Slackware 14.0 (http://www.linuxquestions.org/questions/slackware-14/desktop-animations-in-slackware-14-0-a-4175430530/)

thirteen_engines 10-04-2012 01:11 PM

Desktop Animations in Slackware 14.0
 
As I mentioned in another thread, I've just installed Slackware 14.0 on a laptop to try it out. My first problem with virtual desktops is solved but now I have a second problem. When I try to get desktop animations going, the cube specifically, a little popup exclaims that "the following desktop effects could not be activated" one of which is the cube. I like the cube. It sometimes startles people.

The laptop was running Slackware 13.37 a couple of days ago without any problems with desktop effects but now ...

Any ideas?

escaflown 10-04-2012 01:14 PM

Do you have openGL activated?

thirteen_engines 10-04-2012 01:51 PM

No. I can select OpenGL under the Advanced tab but it doesn't want to take. If I close System Setting and open again and look at Desktop Effects under the Advanced tab it's switched back to XRender. Curious.

thirteen_engines 10-05-2012 09:46 AM

Has nobody seen this happen before? Why can I not use OpenGL instead of XRender?

escaflown 10-05-2012 10:03 AM

what graphic card do you have? If you have Nvidia or amd graphics cards, could you try to reinstall them using either the slackbuilds or the proprietary blob?

Alien Bob 10-05-2012 10:03 AM

Did you upgrade to Slackware 14.0 and are you using a proprietary driver for a Nvidia or Ati card? In that case you would have to re-install this proprietary driver too.

Eric

allend 10-05-2012 10:44 AM

Check that ~/.kde/share/kwinrc has
Code:

[Compositing]
OpenGLIsUnsafe=false


thirteen_engines 10-05-2012 11:23 AM

Thanks for the replies folks. I found where the problem lies. The xorg.conf file that was generated by xorgsetup lists several cards. The default card was using a driver called "modesetting". I switched to the card corresponding to the intel driver and I now have OpenGl and desktop animations available.

Again, my thanks for your help.


All times are GMT -5. The time now is 02:08 AM.