LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Deluge and Slackware (http://www.linuxquestions.org/questions/slackware-14/deluge-and-slackware-4175489532/)

moisespedro 12-29-2013 11:55 PM

Deluge and Slackware
 
Installed deluge and all its dependencies from sbopkg and when I try to run it I get this
Code:

Traceback (most recent call last):
  File "/usr/bin/deluge", line 9, in <module>
    load_entry_point('deluge==1.3.6', 'gui_scripts', 'deluge')()
  File "/usr/lib64/python2.7/site-packages/pkg_resources.py", line 378, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib64/python2.7/site-packages/pkg_resources.py", line 2566, in load_entry_point
    return ep.load()
  File "/usr/lib64/python2.7/site-packages/pkg_resources.py", line 2260, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/usr/lib64/python2.7/site-packages/deluge/main.py", line 49, in <module>
    import deluge.common
  File "/usr/lib64/python2.7/site-packages/deluge/common.py", line 44, in <module>
    import chardet
ImportError: No module named chardet

http://i.imgur.com/vTJwVc7.png
Any ideas?

gengisdave 12-30-2013 12:03 AM

you are missing package 'chardet' https://pypi.python.org/pypi/chardet

moisespedro 12-30-2013 01:17 AM

After installing one million missing dependencies I've got it running but then I get this message after the GUI is loaded
Code:

Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/deluge/ui/gtkui/gtkui.py", line 329, in _on_reactor_start
    client.start_classic_mode()
  File "/usr/lib64/python2.7/site-packages/deluge/ui/client.py", line 559, in start_classic_mode
    self._daemon_proxy = DaemonClassicProxy(self.__event_handlers)
  File "/usr/lib64/python2.7/site-packages/deluge/ui/client.py", line 432, in __init__
    self.__daemon = deluge.core.daemon.Daemon(classic=True)
  File "/usr/lib64/python2.7/site-packages/deluge/core/daemon.py", line 136, in __init__
    from deluge.core.core import Core
  File "/usr/lib64/python2.7/site-packages/deluge/core/core.py", line 36, in <module>
    from deluge._libtorrent import lt
  File "/usr/lib64/python2.7/site-packages/deluge/_libtorrent.py", line 59, in <module>
    import libtorrent as lt
ImportError: dynamic module does not define init function (initlibtorrent)

EDIT: And by the way, I am also having problems with file-roller and keepass. Should I make more threads or can I post on this one?

moisespedro 12-31-2013 10:37 PM

Recompiled it with all dependencies properly match and it works (damn it were a lot of dependencies)


All times are GMT -5. The time now is 01:00 AM.