-   Slackware (
-   -   Deluge and Slackware (

moisespedro 12-30-2013 12:55 AM

Deluge and Slackware
Installed deluge and all its dependencies from sbopkg and when I try to run it I get this

Traceback (most recent call last):
  File "/usr/bin/deluge", line 9, in <module>
    load_entry_point('deluge==1.3.6', 'gui_scripts', 'deluge')()
  File "/usr/lib64/python2.7/site-packages/", line 378, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib64/python2.7/site-packages/", line 2566, in load_entry_point
    return ep.load()
  File "/usr/lib64/python2.7/site-packages/", line 2260, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/usr/lib64/python2.7/site-packages/deluge/", line 49, in <module>
    import deluge.common
  File "/usr/lib64/python2.7/site-packages/deluge/", line 44, in <module>
    import chardet
ImportError: No module named chardet
Any ideas?

gengisdave 12-30-2013 01:03 AM

you are missing package 'chardet'

moisespedro 12-30-2013 02:17 AM

After installing one million missing dependencies I've got it running but then I get this message after the GUI is loaded

Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/deluge/ui/gtkui/", line 329, in _on_reactor_start
  File "/usr/lib64/python2.7/site-packages/deluge/ui/", line 559, in start_classic_mode
    self._daemon_proxy = DaemonClassicProxy(self.__event_handlers)
  File "/usr/lib64/python2.7/site-packages/deluge/ui/", line 432, in __init__
    self.__daemon = deluge.core.daemon.Daemon(classic=True)
  File "/usr/lib64/python2.7/site-packages/deluge/core/", line 136, in __init__
    from deluge.core.core import Core
  File "/usr/lib64/python2.7/site-packages/deluge/core/", line 36, in <module>
    from deluge._libtorrent import lt
  File "/usr/lib64/python2.7/site-packages/deluge/", line 59, in <module>
    import libtorrent as lt
ImportError: dynamic module does not define init function (initlibtorrent)

EDIT: And by the way, I am also having problems with file-roller and keepass. Should I make more threads or can I post on this one?

moisespedro 12-31-2013 11:37 PM

Recompiled it with all dependencies properly match and it works (damn it were a lot of dependencies)

All times are GMT -5. The time now is 09:03 AM.