LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   :( Dell Wireless 1390 WLAN Mini-Card (Broadcom Corporation BCM4311 802.11b/g WLAN) (http://www.linuxquestions.org/questions/slackware-14/dell-wireless-1390-wlan-mini-card-broadcom-corporation-bcm4311-802-11b-g-wlan-844055/)

adonisslanic 11-13-2010 10:28 AM

:( Dell Wireless 1390 WLAN Mini-Card (Broadcom Corporation BCM4311 802.11b/g WLAN)
 
I have a Dell Inspiron 1501 with a BCM4311 wireless card, and i've installed b43-fwcutter and firmware, but forget this, please guide me to the right way to install it :( Slackware 13.1 user here, in Ubuntu worked great with some restricted drivers(bcm43xx as i recall)

rfernandez 11-13-2010 12:49 PM

Once you have b43-fwcutter compiled and installed (you can check SlackBuilds.org for the SlackBuild script) and the firmaware (let's say it's the broadcom-wl-4.178.10.4.tar.bz2), these are the steps:

Code:

1) Unpack the firmware
$ tar xf broadcom-wl-4.178.10.4.tar.bz2

2) cd to the linux firmware dir
$ cd broadcom-wl-4.178.10.4/linux

3) extract the firmware to the kernel firmware directory
# b43-fwcutter -w /lib/firmware wl_apsta.o

4) load (or re-load) the b43 kernel module. In doubt, reboot
# modprobe b43
or
# modprobe -r b43 ; mobprobe b43

And you're done. These instructions are well described in the b43 - Linux Wireless site.

Hangdog42 11-13-2010 05:06 PM

Quote:

Originally Posted by adonisslanic
in Ubuntu worked great with some restricted drivers(bcm43xx as i recall)

Actually, it was probably the sta driver from Broadcom. The bcm43xx driver was the predecessor to b43 and has been deprecated for quite some time.

adonisslanic 11-14-2010 02:17 AM

I install the firmware also with the slackbuild and then I use those commands from the "code" you gave me?

adonisslanic 11-14-2010 02:28 AM

i've followed the steps... and everything seems okay, but still no wifi on O_o The led is not lighted up, and wlan0 is shown only in "iwconfig" not in "ifconfig"
Now i've managed to get it on... "ifconfig wlan0 up" :P but i think i need nm-applet now ;))
CAN'T GET A PROPER WIRELESS MANAGER :(

adonisslanic 11-14-2010 03:30 AM

ok, I have now wicd, but is giving me a very weak signal, and it doesn't refresh properly, 'cuz it can't find my wireless router :|

rfernandez 11-14-2010 10:09 AM

How far are you from the AP?


All times are GMT -5. The time now is 07:34 PM.