LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Dell Latitude D610 Kernel Upgrade Issues [Slackware 12] (http://www.linuxquestions.org/questions/slackware-14/dell-latitude-d610-kernel-upgrade-issues-%5Bslackware-12%5D-638927/)

Chryzmo 04-30-2008 12:31 PM

Dell Latitude D610 Kernel Upgrade Issues [Slackware 12]
 
Hey all,

I recently decided to try installing Slackware 12 on my Latitude D610. Prior to installing Slackware I had Ubuntu on it, which ran without issues and the hard drive was listed as /dev/sda.

Immediately after the Slackware installation, the hard drive is still /dev/sda, but if I upgrade the kernel(2.6.24.5), it reboots and tries tells me the hard drive is at /dev/hda and then panics and locks up. I know this laptop has an SATA hard drive, which is clear due to the Ubuntu and initial Slackware installations. What I don't understand is why upgrading the kernel changes what device the hard drive is listed as.

I just copied the .config file from the initial source folder into the new one and built the new kernel using that, so I have changed no options since using the initial kernel. I've also installed grub and told it root=/dev/hda1 and it boots as far as trying to mount file systems and then fsck complains that /dev/sda1 is not a valid FS(which is expected). I could just set everything up to use /dev/hda1, but I don't feel this is correct.

Does anyone have any suggestions as to what I can try so that my hard drive will be listed as /dev/sda1 with the newer kernel?

Thanks,

chryzmo

w3edr5t 04-30-2008 04:29 PM

I used to have a Dell Latitude 810, which I think has similar harddrive/optical hardware as the 610.

Have you tried to add 'hda=noprobe' as kernel argument when booting?
This worked for me several times with the 810, not sure with which kernel versions.

Regards
Terje

acummings 05-01-2008 12:06 PM

Quote:

I just copied the .config file from the initial source folder into the new one and built the new kernel using that, so I have changed no options since using the initial kernel.
2.6.21.5 -> 2.6.24.5

Are you certain that no portions of the (kernel) config had been obsoleted and new (and different) in place of the old?

IOW copying (can work) but it also may not given if too huge of changes/revisions been done to the kernel's config system.

Was it the Slack 12.0 huge kernel that did work for you?

--
Alan.

Cuetzpallin 05-01-2008 02:54 PM

I have the same problem on a Latitude D620.
I installed Slackware 12 and try to upgrade the kernel, any idea?

Franklin 05-01-2008 02:58 PM

I had the same problems with the kernels in current. One resolution is to disable ide in the kernel. See my post here:

http://www.linuxquestions.org/questi...are-12-638259/

There may be an option to pass at the lilo prompt as well, but I have not tried this. I looked in the changes & hints text which mentions passing a "no probe" option to lilo at boot, but this was with respect to dma not sata drive detection.

The "fix" in the other post will solve your problem if you are compiling a custom kernel anyway.

HTH

Just wanted to add that entering "hda=noprobe" at the lilo prompt will also allow you to boot the huge kernel without the kernel panic due to the kernel trying to boot hda instead of sda. I will assume that, as stated in the changes and hint text, passing this option during the install will also enable the install to procede without error.


All times are GMT -5. The time now is 10:56 AM.