LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-18-2008, 06:00 PM   #16
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,401
Blog Entries: 3

Rep: Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483

Hi,
Quote:
Originally Posted by rssn6 View Post
Code:
/etc/rc.d/rc.inet1 wlan0.restart
or
/etc/rc.d/rc.inet1.conf wlan0_restart
is the same thing!

because by restarting i make sure that the card is working ok
but even at boot the wifi do not go online.
You should look at the '/etc/rc.d/rc.inet1' script;

Code:
excerpt from '/etc/rc.d/rc.inet1';
############
### MAIN ###
############

case "$1" in
'start') # "start" brings up all configured interfaces:
  start
  ;;
'stop') # "stop" takes down all configured interfaces:
  stop
  ;;
'restart') # "restart" restarts the network:
  stop
  start
  ;;
*_start) # Example: "eth1_start" will start the specified interface 'eth1'
  INTERFACE=`echo $1 | /bin/cut -d '_' -f 1`
  if_up $INTERFACE
  gateway_up
  ;;
*_stop) # Example: "eth0_stop" will stop the specified interface 'eth0'
 INTERFACE=`echo $1 | /bin/cut -d '_' -f 1`
  if_down $INTERFACE
  ;;
*_restart) # Example: "wlan0_restart" will take 'wlan0' down and up again
  INTERFACE=`echo $1 | /bin/cut -d '_' -f 1`
  if_down $INTERFACE
  sleep 1
  if_up $INTERFACE
  gateway_up
  ;;
'up') # "up" does the same thing as "start"
'down') # "down" does the same thing as "stop"
  stop
  ;;
*_up) # "*_up" does the same thing as "*_start"
  INTERFACE=`echo $1 | /bin/cut -d '_' -f 1`
  if_up $INTERFACE
  gateway_up
  ;;
*_down) # "*_down" does the same thing as "*_stop"
  INTERFACE=`echo $1 | /bin/cut -d '_' -f 1`
  if_down $INTERFACE
  ;;
Bruce's statements are correct;

Quote:
excerpt from 'SlackwareNetworkSubSection' of Alien_Bob's Wiki;

User induced
You as the user can decide to stop, start or restart any network interface by directly running one of the commands

/etc/rc.d/rc.inet1 INTERFACE_stop
/etc/rc.d/rc.inet1 INTERFACE_start
/etc/rc.d/rc.inet1 INTERFACE_restart

That last command will mostly be used after changing one or more of the interface's configuration parameters like for instance the IP address, or the wireless encryption key.
 
Old 10-18-2008, 06:13 PM   #17
rssn6
Member
 
Registered: Jun 2008
Location: Canada
Distribution: Slackware,Ubuntu, m0n0wall,Freenas
Posts: 66

Original Poster
Rep: Reputation: 16
I added an applet for wireless that came with kde and it shows me that the connection is ok but

at start of my laptop there a check up and then the led of my wifi goes up then it goes down!!

when i got to use the command
Code:
/etc/rc.d/rc.inet1 wlan0_restart
it just dies and the message is
Code:
Error for wireless request "Set Nickname" (8B1C) :
    SET failed on device wlan0 ; Operation not supported.
Polling for DHCP server on interface wlan0:
No carrier detected on wlan0.  Reducing DHCP timeout to 10 seconds.
dhcpcd: MAC address = 00:16:cf:8c:9f:27
it can't get an ip i think.

I hope it will helps
 
Old 10-18-2008, 06:44 PM   #18
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 649

Rep: Reputation: 92
Hi Rssn6,

I can hear your frustration! I went through a similar experience with a BCM4312 and Slackware 12.1. IMHO the Broadcom chip can be a bit of a pain :-).

If you leaf through that thread you can see the various attempts I made to kick-start the chip. My final, successful, strategy was:
  1. Load the firmware provided by LinuxWireless, there is a nice script for this on slackbuilds.org
  2. Remove all changes made to Slackware networking scripts
  3. Installed wicd with slackbuilds.org script

It was a bit of a cop-out on my part but it now works flawlessly. Hopefully it will for you too?

Andrew
 
Old 10-18-2008, 11:45 PM   #19
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,401
Blog Entries: 3

Rep: Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483Reputation: 1483
Hi,

You should comment out your '#DHCP_HOSTNAME[1]="" ' instead of a null in the '/etc/rc.d/rc.inet1.conf'.

You could try too use a static IP an see if that is possible. Disable the encryption for now. Once you confirm the static IP works then work from there.
 
Old 10-19-2008, 07:33 PM   #20
rssn6
Member
 
Registered: Jun 2008
Location: Canada
Distribution: Slackware,Ubuntu, m0n0wall,Freenas
Posts: 66

Original Poster
Rep: Reputation: 16
Thank you to everybody for replying!!!!

I did what andrew.46 told me to but not all the steps I just installed wicd and everything is working (I hope...).

Quote:
Originally Posted by andrew.46 View Post
Hi Rssn6,

I can hear your frustration! I went through a similar experience with a BCM4312 and Slackware 12.1. IMHO the Broadcom chip can be a bit of a pain :-).

If you leaf through that thread you can see the various attempts I made to kick-start the chip. My final, successful, strategy was:
  1. Load the firmware provided by LinuxWireless, there is a nice script for this on slackbuilds.org
  2. Remove all changes made to Slackware networking scripts
  3. Installed wicd with slackbuilds.org script

It was a bit of a cop-out on my part but it now works flawlessly. Hopefully it will for you too?

Andrew

Quote:
I also add a some lines to rc.wicd to start auto
You will need to start the wicd service at boot by adding the following
to your /etc/rc.d/rc.local:
if [ -x /etc/rc.d/rc.wicd ]; then
/etc/rc.d/rc.wicd start
fi
http://slackbuilds.org/repository/12.1/network/wicd/

and another thing does anybody knows how to make the buttons in front of the laptop work and
make the laptop standby I use
Code:
echo -n mem > /sys/power/state
but I would like to run it when my lid close

thank you again for everything!!! people!!!!!
 
  


Reply

Tags
config, dell, mini, slackware12, wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless connection dosn't work on dell inspirion 6400 after installing opensuse 10.3 doronkimchi Linux - Laptop and Netbook 2 05-03-2008 04:51 AM
Dell 6400/E1505 wireless not work on FedoraCore8 x86_64 lengogiang Linux - Wireless Networking 1 03-02-2008 07:44 PM
dell inspiron 6400 wireless card problem (intel pro wlan 3945 internal) windycity_linux Linux - Laptop and Netbook 1 03-02-2007 05:55 AM
dell e1505/6400 wireless issues bofallon68 Linux - Laptop and Netbook 4 06-20-2006 10:24 AM
FC5 on a Dell Inspiron 6400 - wireless help shanec Fedora 2 05-18-2006 02:39 PM


All times are GMT -5. The time now is 05:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration