LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-01-2011, 09:54 PM   #1
CTM
Member
 
Registered: Apr 2004
Distribution: Slackware64 14.0 / 14.1
Posts: 131

Rep: Reputation: 50
Delayed screen refresh (Intel GM45, 2.6.39, Xorg 1.9.5, xf86-video-intel 2.15.0)


I'm experiencing an odd and extremely annoying screen refresh bug on my laptop. It only seems to happen (or, at least, severely enough to be noticeable) in terminal windows: if I leave irssi open in Xfce Terminal with no other activity on-screen, the clock on the status bar (which displays the current time as a hh:mm:ss timestamp) will only update itself every 2 seconds. If there is any activity anywhere else on-screen, e.g. by moving the mouse, an animated GIF displayed in Firefox or even just the flashing caret in the text box I'm using to write this message, the irssi clock updates itself at the correct speed. The problem isn't unique to irssi either; I've encountered the same delay while tab-completing file names from the shell and waiting for the status line in nano to be updated. Sometimes the delay is significantly longer than 2 seconds - I think the longest I've waited for a tab-completion to be displayed in the shell is about 5 seconds.

I'm not sure what information is necessary to debug this because I have absolutely no idea where to start, so here's everything relevant I can think of: I'm running Slackware64 13.37 with Robby's Xfce 4.8 packages, kernel 2.6.39 (I can post my .config if required), Xorg 1.9.5 with the xf86-video-intel 2.15.0 driver, and mesa 7.9.2. The chipset is a Mobile Intel GM45 Express. This problem is making my laptop almost unusable, so any help whatsoever would be appreciated!

Last edited by CTM; 06-01-2011 at 09:56 PM.
 
Old 06-02-2011, 02:46 AM   #2
Martinus2u
Member
 
Registered: Apr 2010
Distribution: Slackware
Posts: 345

Rep: Reputation: 56
hi, just a quick comment since i cannot re-create the problem: it sounds more like an issue related to the scheduler than the video subsystem. play with the scheduler settings -- tickless, pre-emption model, type of scheduler (CFS/BFS), scheduling priorities. Does it happen with other applications?
 
Old 06-02-2011, 02:58 PM   #3
CTM
Member
 
Registered: Apr 2004
Distribution: Slackware64 14.0 / 14.1
Posts: 131

Original Poster
Rep: Reputation: 50
Quote:
Originally Posted by Martinus2u View Post
hi, just a quick comment since i cannot re-create the problem: it sounds more like an issue related to the scheduler than the video subsystem. play with the scheduler settings -- tickless, pre-emption model, type of scheduler (CFS/BFS), scheduling priorities. Does it happen with other applications?
Good idea - I just tested this with 13.37's default (huge) 2.6.37.6 kernel, but I get the same problem. Is it still likely to be the kernel? I thought the Slackware default .config was designed to be pretty safe. I didn't have this problem when I used 13.1 with GSB 2.32 (when upgrading to 13.37 I decided to format and install from scratch to eliminate some cruft). I don't notice the problem with any other applications, but I guess that doesn't mean it's not happening - but it's definitely most noticeable with Xfce Terminal.

edit: after some further testing, I've found that the problem never happens on the console, further strengthening my belief that this is X's or the graphics driver's fault...

Last edited by CTM; 06-02-2011 at 03:12 PM.
 
Old 06-03-2011, 03:25 PM   #4
CTM
Member
 
Registered: Apr 2004
Distribution: Slackware64 14.0 / 14.1
Posts: 131

Original Poster
Rep: Reputation: 50
Confirming that the problem in fact appears to lie with Xfce Terminal - other terminal emulators (sakura, gnome-terminal) don't display this behaviour. I tried changing all available settings but nothing seemed to have an effect. Shame too, because Xfce Terminal is a nice lightweight alternative to gnome-terminal with almost the same feature set. I'll report it to the developers and hope it gets fixed in time for 4.10.
 
Old 06-03-2011, 06:45 PM   #5
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,263

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
I remember this from 13.0/13.1's CHANGES_AND_HINTS.TXT:
Code:
If you notice Xfce's Terminal and perhaps some other applications being drawn
  very slowly in X, then you should try explicitly disabling the Composite
  extension in /etc/X11/xorg.conf, or set XLIB_SKIP_ARGB_VISUALS=1 in your
  environment prior to starting X.  For more information on this, see:
    http://bugzilla.xfce.org/show_bug.cgi?id=2792
  We've also gotten a report of some other things (such as VirtualBox) that
  might benefit from this.
Though I'm not sure how relevant it is in 13.37 or in Xfce 4.8 (as opposed to 4.6). If it is no longer relevant and I just wasted your time, I apologize; I haven't used Xfce in 13.37 and I don't use Robby's upgraded Xfce packages.
 
Old 06-04-2011, 06:00 AM   #6
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 647

Rep: Reputation: 91
As T3slider has suggested a similar problem on my system solved with the following in /etc/X11/xorg.conf:

Code:
Section "Extensions"
Option "Composite" "Disable"
EndSection
This is with xfce 4.6.2, I had hoped this would not be necessary in newer versions .
 
Old 06-04-2011, 12:02 PM   #7
CTM
Member
 
Registered: Apr 2004
Distribution: Slackware64 14.0 / 14.1
Posts: 131

Original Poster
Rep: Reputation: 50
Confirming that both T3slider's and andrew.46's suggestions work - sadly, yes, it appears to be necessary in Xfce 4.8 too. The original Bugzilla report about this, linked in CHANGES_AND_HINTS.TXT, has been marked closed/invalid so I guess it'll continue to be necessary in future versions of Xfce.

Last edited by CTM; 06-04-2011 at 12:04 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Best xorg/mesa/drm/xf86-video-intel for Intel 82845G/GL gnashley Slackware 9 03-04-2011 03:20 AM
compiling xf86-video-intel and xorg-macros 1.1.3 centguy Linux - Software 7 03-19-2010 01:34 AM
[SOLVED] xf86-video-intel-2.9.0-i486-1.tgz how to identify to xorg.conf to make sure it runs matters Slackware 37 02-07-2010 12:55 PM
Intel GM45 + linux play back HD video ,thx hkcyber Linux - Hardware 0 02-17-2009 12:54 AM
Intel graphic driver(xf86-video-intel) won't work me_and_linux Linux - Laptop and Netbook 1 10-06-2008 11:26 AM


All times are GMT -5. The time now is 11:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration