LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Delay after running "startx" and problems with udev and rtl8192se in Slack14-x64 (http://www.linuxquestions.org/questions/slackware-14/delay-after-running-startx-and-problems-with-udev-and-rtl8192se-in-slack14-x64-4175431196/)

gmjs 10-08-2012 02:56 PM

Delay after running "startx" and problems with udev and rtl8192se in Slack14-x64
 
Hello,

After a clean, full, install of Slackware 14 x64 on a laptop, I had a problem at bootup caused by udev and the wireless card. Most posts suggest disabling the offending module. This resolves the delay but I would like to use the wireless card! Is creating an initrd with that module the way to achieve this (I'm running without separate initrd at the moment).

Also I have a strange problem when running "startx". There's a delay of 15-20 seconds before it starts (all DEs and WMs). Can anyone help me work out what is causing this delay?

Many thanks.


Att. Xorg.log.0

Code:

[  578.589]
X.Org X Server 1.12.3
Release Date: 2012-07-09
[  578.594] X Protocol Version 11, Revision 0
[  578.595] Build Operating System: Slackware 14.0 Slackware Linux Project
[  578.596] Current Operating System: Linux onyx 3.2.29 #2 SMP Mon Sep 17 14:19:22 CDT 2012 x86_64
[  578.596] Kernel command line: root=/dev/sda10 ro
[  578.598] Build Date: 23 August 2012  02:03:27PM
[  578.599] 
[  578.600] Current version of pixman: 0.26.2
[  578.601]        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[  578.601] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  578.605] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Oct  8 20:34:20 2012
[  578.606] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  578.606] (==) No Layout section.  Using the first Screen section.
[  578.606] (==) No screen section available. Using defaults.
[  578.606] (**) |-->Screen "Default Screen Section" (0)
[  578.606] (**) |  |-->Monitor "<default monitor>"
[  578.607] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[  578.607] (==) Automatically adding devices
[  578.607] (==) Automatically enabling devices
[  578.607] (WW) The directory "/usr/share/fonts/local" does not exist.
[  578.607]        Entry deleted from font path.
[  578.607] (WW) The directory "/usr/share/fonts/CID" does not exist.
[  578.607]        Entry deleted from font path.
[  578.607] (==) FontPath set to:
        /usr/share/fonts/TTF,
        /usr/share/fonts/OTF,
        /usr/share/fonts/Type1,
        /usr/share/fonts/misc,
        /usr/share/fonts/75dpi/:unscaled,
        /usr/share/fonts/100dpi/:unscaled,
        /usr/share/fonts/75dpi,
        /usr/share/fonts/100dpi,
        /usr/share/fonts/cyrillic
[  578.607] (==) ModulePath set to "/usr/lib64/xorg/modules"
[  578.607] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[  578.607] (II) Loader magic: 0x7c48e0
[  578.607] (II) Module ABI versions:
[  578.607]        X.Org ANSI C Emulation: 0.4
[  578.607]        X.Org Video Driver: 12.0
[  578.607]        X.Org XInput driver : 16.0
[  578.607]        X.Org Server Extension : 6.0
[  578.609] (--) PCI:*(0:0:2:0) 8086:0106:1558:4140 rev 9, Mem @ 0xf7800000/4194304, 0xe0000000/268435456, I/O @ 0x0000f000/64
[  578.609] (II) Open ACPI successful (/var/run/acpid.socket)
[  578.609] (II) LoadModule: "extmod"
[  578.609] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
[  578.609] (II) Module extmod: vendor="X.Org Foundation"
[  578.609]        compiled for 1.12.3, module version = 1.0.0
[  578.609]        Module class: X.Org Server Extension
[  578.609]        ABI class: X.Org Server Extension, version 6.0
[  578.609] (II) Loading extension MIT-SCREEN-SAVER
[  578.609] (II) Loading extension XFree86-VidModeExtension
[  578.609] (II) Loading extension XFree86-DGA
[  578.609] (II) Loading extension DPMS
[  578.609] (II) Loading extension XVideo
[  578.609] (II) Loading extension XVideo-MotionCompensation
[  578.609] (II) Loading extension X-Resource
[  578.609] (II) LoadModule: "dbe"
[  578.610] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
[  578.610] (II) Module dbe: vendor="X.Org Foundation"
[  578.610]        compiled for 1.12.3, module version = 1.0.0
[  578.610]        Module class: X.Org Server Extension
[  578.610]        ABI class: X.Org Server Extension, version 6.0
[  578.610] (II) Loading extension DOUBLE-BUFFER
[  578.610] (II) LoadModule: "glx"
[  578.610] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[  578.610] (II) Module glx: vendor="X.Org Foundation"
[  578.610]        compiled for 1.12.3, module version = 1.0.0
[  578.610]        ABI class: X.Org Server Extension, version 6.0
[  578.610] (==) AIGLX enabled
[  578.610] (II) Loading extension GLX
[  578.610] (II) LoadModule: "record"
[  578.611] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
[  578.611] (II) Module record: vendor="X.Org Foundation"
[  578.611]        compiled for 1.12.3, module version = 1.13.0
[  578.611]        Module class: X.Org Server Extension
[  578.611]        ABI class: X.Org Server Extension, version 6.0
[  578.611] (II) Loading extension RECORD
[  578.611] (II) LoadModule: "dri"
[  578.611] (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
[  578.611] (II) Module dri: vendor="X.Org Foundation"
[  578.611]        compiled for 1.12.3, module version = 1.0.0
[  578.611]        ABI class: X.Org Server Extension, version 6.0
[  578.611] (II) Loading extension XFree86-DRI
[  578.611] (II) LoadModule: "dri2"
[  578.612] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
[  578.612] (II) Module dri2: vendor="X.Org Foundation"
[  578.612]        compiled for 1.12.3, module version = 1.2.0
[  578.612]        ABI class: X.Org Server Extension, version 6.0
[  578.612] (II) Loading extension DRI2
[  578.612] (==) Matched intel as autoconfigured driver 0
[  578.612] (==) Matched vesa as autoconfigured driver 1
[  578.612] (==) Matched fbdev as autoconfigured driver 2
[  578.612] (==) Assigned the driver to the xf86ConfigLayout
[  578.612] (II) LoadModule: "intel"
[  578.612] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[  578.612] (II) Module intel: vendor="X.Org Foundation"
[  578.612]        compiled for 1.12.1, module version = 2.19.0
[  578.612]        Module class: X.Org Video Driver
[  578.612]        ABI class: X.Org Video Driver, version 12.0
[  578.612] (II) LoadModule: "vesa"
[  578.612] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[  578.612] (II) Module vesa: vendor="X.Org Foundation"
[  578.612]        compiled for 1.12.1, module version = 2.3.1
[  578.612]        Module class: X.Org Video Driver
[  578.612]        ABI class: X.Org Video Driver, version 12.0
[  578.612] (II) LoadModule: "fbdev"
[  578.613] (WW) Warning, couldn't open module fbdev
[  578.613] (II) UnloadModule: "fbdev"
[  578.613] (II) Unloading fbdev
[  578.613] (EE) Failed to load module "fbdev" (module does not exist, 0)
[  578.613] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
        i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
        E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
        965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
        4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
        Sandybridge Desktop (GT1), Sandybridge Desktop (GT2),
        Sandybridge Desktop (GT2+), Sandybridge Mobile (GT1),
        Sandybridge Mobile (GT2), Sandybridge Mobile (GT2+),
        Sandybridge Server, Ivybridge Mobile (GT1), Ivybridge Mobile (GT2),
        Ivybridge Desktop (GT1), Ivybridge Desktop (GT2), Ivybridge Server,
        Ivybridge Server (GT2)
[  578.613] (II) VESA: driver for VESA chipsets: vesa
[  578.613] (--) using VT number 7

[  578.619] (WW) Falling back to old probe method for vesa
[  578.619] drmOpenDevice: node name is /dev/dri/card0
[  578.619] drmOpenDevice: open result is 11, (OK)
[  578.619] drmOpenByBusid: Searching for BusID pci:0000:00:02.0
[  578.619] drmOpenDevice: node name is /dev/dri/card0
[  578.619] drmOpenDevice: open result is 11, (OK)
[  578.619] drmOpenByBusid: drmOpenMinor returns 11
[  578.619] drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
[  578.619] (II) intel(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
[  578.619] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[  578.619] (==) intel(0): RGB weight 888
[  578.619] (==) intel(0): Default visual is TrueColor
[  578.619] (II) intel(0): Integrated Graphics Chipset: Intel(R) Sandybridge Mobile (GT1)
[  578.619] (--) intel(0): Chipset: "Sandybridge Mobile (GT1)"
[  578.619] (**) intel(0): Relaxed fencing enabled
[  578.619] (**) intel(0): Wait on SwapBuffers? enabled
[  578.619] (**) intel(0): Triple buffering? enabled
[  578.619] (**) intel(0): Framebuffer tiled
[  578.619] (**) intel(0): Pixmaps tiled
[  578.619] (**) intel(0): 3D buffers tiled
[  578.619] (**) intel(0): SwapBuffers wait enabled
[  578.619] (==) intel(0): video overlay key set to 0x101fe
[  578.619] (II) intel(0): Output LVDS1 has no monitor section
[  578.621] (II) intel(0): found backlight control interface /sys/class/backlight/acpi_video0
[  578.621] (II) intel(0): Output VGA1 has no monitor section
[  578.643] (II) intel(0): Output HDMI1 has no monitor section
[  578.656] (II) intel(0): Output DP1 has no monitor section
[  578.656] (II) intel(0): EDID for output LVDS1
[  578.656] (II) intel(0): Manufacturer: LGD  Model: 2dc  Serial#: 0
[  578.656] (II) intel(0): Year: 2010  Week: 0
[  578.656] (II) intel(0): EDID Version: 1.4
[  578.656] (II) intel(0): Digital Display Input
[  578.656] (II) intel(0): 6 bits per channel
[  578.656] (II) intel(0): Digital interface is undefined
[  578.656] (II) intel(0): Max Image Size [cm]: horiz.: 34  vert.: 19
[  578.656] (II) intel(0): Gamma: 2.20
[  578.656] (II) intel(0): No DPMS capabilities specified
[  578.656] (II) intel(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4
[  578.656] (II) intel(0): First detailed timing is preferred mode
[  578.656] (II) intel(0): Preferred mode is native pixel format and refresh rate
[  578.656] (II) intel(0): redX: 0.613 redY: 0.371  greenX: 0.350 greenY: 0.606
[  578.656] (II) intel(0): blueX: 0.152 blueY: 0.099  whiteX: 0.313 whiteY: 0.329
[  578.656] (II) intel(0): Manufacturer's mask: 0
[  578.656] (II) intel(0): Supported detailed timing:
[  578.656] (II) intel(0): clock: 76.0 MHz  Image Size:  344 x 194 mm
[  578.656] (II) intel(0): h_active: 1366  h_sync: 1402  h_sync_end 1450 h_blank_end 1564 h_border: 0
[  578.656] (II) intel(0): v_active: 768  v_sync: 771  v_sync_end 776 v_blanking: 810 v_border: 0
[  578.656] (II) intel(0): Supported detailed timing:
[  578.656] (II) intel(0): clock: 51.0 MHz  Image Size:  344 x 194 mm
[  578.656] (II) intel(0): h_active: 1366  h_sync: 1402  h_sync_end 1450 h_blank_end 1564 h_border: 0
[  578.656] (II) intel(0): v_active: 768  v_sync: 771  v_sync_end 776 v_blanking: 814 v_border: 0
[  578.656] (II) intel(0):  9HXXJ156WH4
[  578.656] (II) intel(0): Unknown vendor-specific block 0
[  578.656] (II) intel(0): EDID (in hex):
[  578.656] (II) intel(0):        00ffffffffffff0030e4dc0200000000
[  578.656] (II) intel(0):        00140104902213780a09159d5f599b27
[  578.656] (II) intel(0):        19505400000001010101010101010101
[  578.656] (II) intel(0):        010101010101b01d56c650002a302430
[  578.656] (II) intel(0):        350058c210000019ec1356c650002e30
[  578.656] (II) intel(0):        2430350058c210000019000000fe0039
[  578.656] (II) intel(0):        4858584a803135365748340a00000000
[  578.657] (II) intel(0):        00004131960100000001010a202000f7
[  578.657] (II) intel(0): EDID vendor "LGD", prod id 732
[  578.657] (II) intel(0): Printing DDC gathered Modelines:
[  578.657] (II) intel(0): Modeline "1366x768"x0.0  76.00  1366 1402 1450 1564  768 771 776 810 -hsync -vsync (48.6 kHz eP)
[  578.657] (II) intel(0): Modeline "1366x768"x0.0  51.00  1366 1402 1450 1564  768 771 776 814 -hsync -vsync (32.6 kHz e)
[  578.657] (II) intel(0): Not using default mode "320x240" (doublescan mode not supported)
[  578.657] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[  578.657] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[  578.657] (II) intel(0): Not using default mode "512x384" (doublescan mode not supported)
[  578.657] (II) intel(0): Not using default mode "640x480" (doublescan mode not supported)
[  578.657] (II) intel(0): Not using default mode "640x512" (doublescan mode not supported)
[  578.657] (II) intel(0): Not using default mode "800x600" (doublescan mode not supported)
[  578.657] (II) intel(0): Not using default mode "896x672" (doublescan mode not supported)
[  578.657] (II) intel(0): Not using default mode "928x696" (doublescan mode not supported)
[  578.657] (II) intel(0): Not using default mode "960x720" (doublescan mode not supported)
[  578.657] (II) intel(0): Not using default mode "700x525" (doublescan mode not supported)
[  578.657] (II) intel(0): Not using default mode "1024x768" (doublescan mode not supported)
[  578.657] (II) intel(0): Printing probed modes for output LVDS1
[  578.657] (II) intel(0): Modeline "1366x768"x60.0  76.00  1366 1402 1450 1564  768 771 776 810 -hsync -vsync (48.6 kHz eP)
[  578.657] (II) intel(0): Modeline "1366x768"x40.1  51.00  1366 1402 1450 1564  768 771 776 814 -hsync -vsync (32.6 kHz e)
[  578.657] (II) intel(0): Modeline "1024x768"x60.0  65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz d)
[  578.657] (II) intel(0): Modeline "800x600"x60.3  40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz d)
[  578.657] (II) intel(0): Modeline "800x600"x56.2  36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz d)
[  578.657] (II) intel(0): Modeline "640x480"x59.9  25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz d)
[  578.657] (II) intel(0): EDID for output VGA1
[  578.680] (II) intel(0): EDID for output HDMI1
[  578.692] (II) intel(0): EDID for output DP1
[  578.692] (II) intel(0): Output LVDS1 connected
[  578.692] (II) intel(0): Output VGA1 disconnected
[  578.692] (II) intel(0): Output HDMI1 disconnected
[  578.692] (II) intel(0): Output DP1 disconnected
[  578.692] (II) intel(0): Using exact sizes for initial modes
[  578.692] (II) intel(0): Output LVDS1 using initial mode 1366x768
[  578.692] (II) intel(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[  578.692] (II) intel(0): Kernel page flipping support detected, enabling
[  578.692] (**) intel(0): Display dimensions: (340, 190) mm
[  578.692] (**) intel(0): DPI set to (102, 102)
[  578.692] (II) Loading sub module "fb"
[  578.692] (II) LoadModule: "fb"
[  578.692] (II) Loading /usr/lib64/xorg/modules/libfb.so
[  578.692] (II) Module fb: vendor="X.Org Foundation"
[  578.692]        compiled for 1.12.3, module version = 1.0.0
[  578.692]        ABI class: X.Org ANSI C Emulation, version 0.4
[  578.692] (II) Loading sub module "dri2"
[  578.692] (II) LoadModule: "dri2"
[  578.693] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
[  578.693] (II) Module dri2: vendor="X.Org Foundation"
[  578.693]        compiled for 1.12.3, module version = 1.2.0
[  578.693]        ABI class: X.Org Server Extension, version 6.0
[  578.693] (II) UnloadModule: "vesa"
[  578.693] (II) Unloading vesa
[  578.693] (==) Depth 24 pixmap format is 32 bpp
[  578.693] (II) intel(0): [DRI2] Setup complete
[  578.693] (II) intel(0): [DRI2]  DRI driver: i965
[  578.693] (II) intel(0): Allocated new frame buffer 1408x768 stride 5632, tiled
[  578.696] (II) UXA(0): Driver registered support for the following operations:
[  578.696] (II)        solid
[  578.696] (II)        copy
[  578.696] (II)        composite (RENDER acceleration)
[  578.696] (II)        put_image
[  578.696] (II)        get_image
[  578.696] (==) intel(0): Backing store disabled
[  578.696] (==) intel(0): Silken mouse enabled
[  578.696] (II) intel(0): Initializing HW Cursor
[  578.696] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[  578.702] (==) intel(0): DPMS enabled
[  578.702] (==) intel(0): Intel XvMC decoder enabled
[  578.702] (II) intel(0): Set up textured video
[  578.702] (II) intel(0): [XvMC] xvmc_vld driver initialized.
[  578.702] (II) intel(0): direct rendering: DRI2 Enabled
[  578.702] (==) intel(0): hotplug detection: "enabled"
[  578.764] (--) RandR disabled
[  578.764] (II) Initializing built-in extension Generic Event Extension
[  578.764] (II) Initializing built-in extension SHAPE
[  578.764] (II) Initializing built-in extension MIT-SHM
[  578.764] (II) Initializing built-in extension XInputExtension
[  578.764] (II) Initializing built-in extension XTEST
[  578.764] (II) Initializing built-in extension BIG-REQUESTS
[  578.764] (II) Initializing built-in extension SYNC
[  578.764] (II) Initializing built-in extension XKEYBOARD
[  578.764] (II) Initializing built-in extension XC-MISC
[  578.764] (II) Initializing built-in extension XINERAMA
[  578.764] (II) Initializing built-in extension XFIXES
[  578.764] (II) Initializing built-in extension RENDER
[  578.764] (II) Initializing built-in extension RANDR
[  578.764] (II) Initializing built-in extension COMPOSITE
[  578.764] (II) Initializing built-in extension DAMAGE
[  578.778] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[  578.778] (II) AIGLX: enabled GLX_INTEL_swap_event
[  578.778] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[  578.778] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[  578.779] (II) AIGLX: Loaded and initialized i965
[  578.779] (II) GLX: Initialized DRI2 GL provider for screen 0
[  578.779] (II) intel(0): Setting screen physical size to 361 x 203
[  578.871] (II) config/udev: Adding input device Power Button (/dev/input/event5)
[  578.871] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  578.871] (**) Power Button: Applying InputClass "keyboard-all"
[  578.871] (II) LoadModule: "evdev"
[  578.872] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[  578.872] (II) Module evdev: vendor="X.Org Foundation"
[  578.872]        compiled for 1.12.1, module version = 2.7.0
[  578.872]        Module class: X.Org XInput Driver
[  578.872]        ABI class: X.Org XInput driver, version 16.0
[  578.872] (II) Using input driver 'evdev' for 'Power Button'
[  578.872] (**) Power Button: always reports core events
[  578.872] (**) evdev: Power Button: Device: "/dev/input/event5"
[  578.873] (--) evdev: Power Button: Vendor 0 Product 0x1
[  578.873] (--) evdev: Power Button: Found keys
[  578.873] (II) evdev: Power Button: Configuring as keyboard
[  578.873] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input5/event5"
[  578.873] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[  578.873] (**) Option "xkb_rules" "evdev"
[  578.873] (**) Option "xkb_model" "evdev"
[  578.873] (**) Option "xkb_layout" "us"
[  578.873] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[  578.897] (EE) Error loading keymap /tmp/server-0.xkm
[  578.897] (EE) XKB: Failed to load keymap. Loading default keymap instead.
[  578.932] (II) config/udev: Adding input device Video Bus (/dev/input/event10)
[  578.932] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[  578.932] (**) Video Bus: Applying InputClass "keyboard-all"
[  578.932] (II) Using input driver 'evdev' for 'Video Bus'
[  578.932] (**) Video Bus: always reports core events
[  578.932] (**) evdev: Video Bus: Device: "/dev/input/event10"
[  578.933] (--) evdev: Video Bus: Vendor 0 Product 0x6
[  578.933] (--) evdev: Video Bus: Found keys
[  578.933] (II) evdev: Video Bus: Configuring as keyboard
[  578.933] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:00/input/input10/event10"
[  578.933] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[  578.933] (**) Option "xkb_rules" "evdev"
[  578.933] (**) Option "xkb_model" "evdev"
[  578.933] (**) Option "xkb_layout" "us"
[  578.933] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[  578.934] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[  578.934] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  578.934] (**) Power Button: Applying InputClass "keyboard-all"
[  578.934] (II) Using input driver 'evdev' for 'Power Button'
[  578.934] (**) Power Button: always reports core events
[  578.934] (**) evdev: Power Button: Device: "/dev/input/event2"
[  578.934] (--) evdev: Power Button: Vendor 0 Product 0x1
[  578.934] (--) evdev: Power Button: Found keys
[  578.934] (II) evdev: Power Button: Configuring as keyboard
[  578.934] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input2/event2"
[  578.934] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 8)
[  578.934] (**) Option "xkb_rules" "evdev"
[  578.934] (**) Option "xkb_model" "evdev"
[  578.934] (**) Option "xkb_layout" "us"
[  578.934] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[  578.934] (II) config/udev: Adding input device Lid Switch (/dev/input/event4)
[  578.934] (II) No input driver specified, ignoring this device.
[  578.934] (II) This device may have been added with another device file.
[  578.934] (II) config/udev: Adding input device Sleep Button (/dev/input/event3)
[  578.934] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[  578.934] (**) Sleep Button: Applying InputClass "keyboard-all"
[  578.934] (II) Using input driver 'evdev' for 'Sleep Button'
[  578.934] (**) Sleep Button: always reports core events
[  578.934] (**) evdev: Sleep Button: Device: "/dev/input/event3"
[  578.935] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[  578.935] (--) evdev: Sleep Button: Found keys
[  578.935] (II) evdev: Sleep Button: Configuring as keyboard
[  578.935] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0E:00/input/input3/event3"
[  578.935] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 9)
[  578.935] (**) Option "xkb_rules" "evdev"
[  578.935] (**) Option "xkb_model" "evdev"
[  578.935] (**) Option "xkb_layout" "us"
[  578.935] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[  578.935] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=3 (/dev/input/event6)
[  578.935] (II) No input driver specified, ignoring this device.
[  578.935] (II) This device may have been added with another device file.
[  578.935] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event7)
[  578.935] (II) No input driver specified, ignoring this device.
[  578.935] (II) This device may have been added with another device file.
[  578.935] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event8)
[  578.935] (II) No input driver specified, ignoring this device.
[  578.935] (II) This device may have been added with another device file.
[  578.935] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event1)
[  578.935] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[  578.936] (**) AT Translated Set 2 keyboard: Applying InputClass "keyboard-all"
[  578.936] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[  578.936] (**) AT Translated Set 2 keyboard: always reports core events
[  578.936] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event1"
[  578.936] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[  578.936] (--) evdev: AT Translated Set 2 keyboard: Found keys
[  578.936] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[  578.936] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input1/event1"
[  578.936] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 10)
[  578.936] (**) Option "xkb_rules" "evdev"
[  578.936] (**) Option "xkb_model" "evdev"
[  578.936] (**) Option "xkb_layout" "us"
[  578.936] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[  578.936] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event9)
[  578.936] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[  578.936] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad"
[  578.936] (II) LoadModule: "synaptics"
[  578.936] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[  578.936] (II) Module synaptics: vendor="X.Org Foundation"
[  578.936]        compiled for 1.12.2, module version = 1.6.2
[  578.936]        Module class: X.Org XInput Driver
[  578.936]        ABI class: X.Org XInput driver, version 16.0
[  578.936] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[  578.936] (**) SynPS/2 Synaptics TouchPad: always reports core events
[  578.936] (**) Option "Device" "/dev/input/event9"
[  578.972] (--) synaptics: SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5692
[  578.972] (--) synaptics: SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4680
[  578.972] (--) synaptics: SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[  578.972] (--) synaptics: SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[  578.972] (--) synaptics: SynPS/2 Synaptics TouchPad: buttons: left right double triple
[  578.972] (--) synaptics: SynPS/2 Synaptics TouchPad: Vendor 0x2 Product 0x7
[  578.972] (**) Option "TapButton1" "1"
[  578.972] (**) Option "TapButton2" "2"
[  578.972] (**) Option "TapButton3" "3"
[  578.972] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[  578.972] (**) SynPS/2 Synaptics TouchPad: always reports core events
[  579.004] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio2/input/input9/event9"
[  579.004] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 11)
[  579.004] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
[  579.004] (**) synaptics: SynPS/2 Synaptics TouchPad: MaxSpeed is now 1.75
[  579.004] (**) synaptics: SynPS/2 Synaptics TouchPad: AccelFactor is now 0.037
[  579.004] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[  579.004] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[  579.004] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[  579.004] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[  579.004] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[  579.005] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[  579.005] (II) No input driver specified, ignoring this device.
[  579.005] (II) This device may have been added with another device file.
[  579.006] (II) config/udev: Adding input device Speakup (/dev/input/event0)
[  579.006] (**) Speakup: Applying InputClass "evdev keyboard catchall"
[  579.006] (**) Speakup: Applying InputClass "keyboard-all"
[  579.006] (II) Using input driver 'evdev' for 'Speakup'
[  579.006] (**) Speakup: always reports core events
[  579.006] (**) evdev: Speakup: Device: "/dev/input/event0"
[  579.006] (--) evdev: Speakup: Vendor 0 Product 0
[  579.006] (--) evdev: Speakup: Found keys
[  579.006] (II) evdev: Speakup: Configuring as keyboard
[  579.006] (**) Option "config_info" "udev:/sys/devices/virtual/input/input0/event0"
[  579.006] (II) XINPUT: Adding extended input device "Speakup" (type: KEYBOARD, id 12)
[  579.006] (**) Option "xkb_rules" "evdev"
[  579.006] (**) Option "xkb_model" "evdev"
[  579.006] (**) Option "xkb_layout" "us"
[  579.006] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[  599.570] (II) evdev: Power Button: Close
[  599.570] (II) UnloadModule: "evdev"
[  599.580] (II) evdev: Video Bus: Close
[  599.580] (II) UnloadModule: "evdev"
[  599.589] (II) evdev: Power Button: Close
[  599.589] (II) UnloadModule: "evdev"
[  599.613] (II) evdev: Sleep Button: Close
[  599.613] (II) UnloadModule: "evdev"
[  599.645] (II) evdev: AT Translated Set 2 keyboard: Close
[  599.645] (II) UnloadModule: "evdev"
[  599.709] (II) UnloadModule: "synaptics"
[  599.741] (II) evdev: Speakup: Close
[  599.741] (II) UnloadModule: "evdev"
[  599.820] Server terminated successfully (0). Closing log file.


ReaperX7 10-08-2012 03:14 PM

Normally there's nothing that can usually be done about this.

I would ask but software what are you using to manage your network?

T3slider 10-08-2012 03:33 PM

You should place an appropriate modprobe line in /etc/rc.d/rc.netdevice (or maybe /etc/rc.d/rc.local if that doesn't work) to load the module. The blacklist will prevent it from being loaded by udev before the firmware is available (thus preventing the timeout), but you will have to load it manually later. Loading it in rc.netdevice should load it when the firmware is available and before the network systems initialize, so it would be the best place to put it. rc.local is run last, so if you have to put it there (ie. if it doesn't work in rc.netdevice) then you will probably have to rerun the network configuration scripts as well.

I don't know what to say about your other issue (the startx delay).

Haythem 10-08-2012 03:42 PM

Quote:

Originally Posted by gmjs (Post 4800598)
Hello,

Also I have a strange problem when running "startx". There's a delay of 15-20 seconds before it starts (all DEs and WMs). Can anyone help me work out what is causing this delay?

i also have this issue in slackware x86.

gsl 10-08-2012 04:18 PM

Quote:

Originally Posted by gmjs (Post 4800598)
Hello,
Also I have a strange problem when running "startx". There's a delay of 15-20 seconds before it starts (all DEs and WMs). Can anyone help me work out what is causing this delay?

Were you disconnected from the network at the time? I encountered this last night in my just-upgraded 14.0 installation when I forgot to turn my network switch on. X started normally once I was connected to the network. I also need to find a solution for this issue.

Geoff.

gsl 10-10-2012 05:06 AM

The startx delay seems to be caused by 'hostname -f' taking a long time to complete when there is no network connection. I use a static IP address and made-up hostname.domainname (for a home network) which is in my /etc/hosts file and in /etc/HOSTNAME. The /etc/host.conf has 'order hosts, bind'.

Still, 'hostname -f' takes 10+ seconds to complete when there is no network connection, and when it does complete, it returns the contents of /etc/HOSTNAME anyway.

Geoff.

sairum 10-10-2012 12:32 PM

Hi

One thing is for sure: you are not alone! I'm also trying to figure out the root of this problem. I must say that this is the *first* time a Slackware version did not end up fully functional after a clean install and some mandatory tweaks (kernel recompilation, net configuration, etc.)

I also think that the problem resides in “hostname” (more precisely in “hostname -f”). First I discovered that hostname is included in two different packages, although sources are apparently similar.

#grep hostname /var/adm/packages/*
/var/adm/packages/net-tools-1.60.20120726git-x86_64-1:bin/hostname
/var/adm/packages/util-linux-2.21.2-x86_64-5:bin/hostname

Also, net-tools is included in util-linux! But this is on purpose...

Anyway, I untarred the net-tools-1.60.20120726git.tar.xz package from slack source of util-linux and used the companion net-tools.config.h.gz (which has config.h gzipped).

In config.h, I disabled AFINET6

#define HAVE_AFINET6 0

because I suspected the “hostname -f” problem might be related to IPV6, which I usually remove from my kernels. The result? The new hostname is behaving "normally" (“hostname -f”) and I can now startx even when the network is down. I’m not fully convinced by this hack, and I will continue to search in order to understand it correctly. One thing I’ve noticed was that if I disabled the lan with

#/etc/rc.d/rc.inet1 stop

then the stock “hostname” would behave “normally” returning the fqdn quickly...

Antonio

gsl 10-10-2012 03:57 PM

Thanks for confirming the problem exists on a clean install of 14.0 as well. I thought it might be due to some misconfiguration following an upgrade from 13.37.

As a work-around, I have simply edited /usr/bin/startx so that it always uses 'hostname' instead of 'hostname -f'.

Geoff.

gmjs 10-12-2012 02:25 PM

Hi everyone.

Many thanks Geoff and Antonio--that's the startx delay gone. I remember that not having a network cable connected stopped a lot of things working in a timely fashion in another distro that I used a while ago. I perhaps should have been able to work this one out myself--sorry!

Thanks T3slider--I'm still having problems getting the wireless device working, but the module is being loaded and there's no delay at bootup now, so I just need to look at its configuration more now.

@ReaperX7--I haven't really configured networking yet, other than configuring the wired network info during setup, so I'm not really "using" anything yet. I posted before I understood exactly what was causing the issues I was having, so I'll be looking at the wireless config next.

Thanks to everyone in this thread for taking the time to reply.

v2george 10-14-2012 01:50 AM

Machines having network configured, but no /etc/resolv.conf nameserver entries didn't had the delay in startx.
Each nameserver entry seems to have a delay of 20 seconds for me, when network connection is physically removed. "hostname -f" delayed startx script by 40 seconds when there were two nameserver entries in resolv.conf.
Looks like the delay is timeout contacting the nameserver. Try commenting out the nameserver entries to check this.

the3dfxdude 10-14-2012 11:36 AM

Guys,

I noticed an issue myself last night with startx taking a while. The problem is I have a static IP and DNS server connected by LAN. Not only that, I have a local DNS caching server on my LAN. I think that this is not a network connection issue, and comment #10 might indicate a symptom to the behavior. I will test this out some more.


All times are GMT -5. The time now is 09:03 AM.