LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 08-12-2010, 08:13 AM   #1
njb
Member
 
Registered: Apr 2010
Location: Behind the Gateway
Distribution: Slackware 13.1
Posts: 167
Blog Entries: 4

Rep: Reputation: 16
Wink default start to linux


Hello,

When I installed the slackware 13.1 iso dvd to my pc, I specified a partition of 10 GB with w95 fat format, and the rest for swap and the home system.
Now at each boot, the widow stops 2 min in the windows partition by default.

I want to change this to Linux, but I don't remember the file that needs to be configured.

;-) NjB
 
Old 08-12-2010, 09:23 AM   #2
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
To change your boot default selection change/add a line for "default=" in /etc/lilo.conf. Run "man lilo.conf" for further information.

Note you'll have to rerun lilo as root to make the changes work.
 
Old 08-12-2010, 09:13 PM   #3
dc_eros
Member
 
Registered: Nov 2006
Distribution: Slackware
Posts: 292

Rep: Reputation: 39
As a newbie, what I did was edit /etc/lilo.conf and changed the countdown timer (I forgot the name) to 100 (10 seconds). To make Slackware as the first selected on the menu, I simply swapped the order or Slackware entry and my windows XP entry making Linux as the first entry on the menu. (Since by default, windows installation is listed first).
 
1 members found this post helpful.
Old 08-13-2010, 08:15 PM   #4
markomarko
Member
 
Registered: Nov 2006
Location: Belgrade, Serbia
Distribution: Slackware
Posts: 67

Rep: Reputation: 19
Quote:
Originally Posted by dc_eros View Post
As a newbie, what I did was edit /etc/lilo.conf and changed the countdown timer (I forgot the name) to 100 (10 seconds). To make Slackware as the first selected on the menu, I simply swapped the order or Slackware entry and my windows XP entry making Linux as the first entry on the menu. (Since by default, windows installation is listed first).
make sure that you don't forget to run command 'lilo' as root after editing lilo.conf...
 
1 members found this post helpful.
Old 08-14-2010, 09:01 AM   #5
njb
Member
 
Registered: Apr 2010
Location: Behind the Gateway
Distribution: Slackware 13.1
Posts: 167
Blog Entries: 4

Original Poster
Rep: Reputation: 16
Wink lilo.conf

Thank for the path
/etc/lilo.conf
I could then change the order of boot to linux first.

:-/ NjB /
 
Old 08-15-2010, 10:38 PM   #6
dc_eros
Member
 
Registered: Nov 2006
Distribution: Slackware
Posts: 292

Rep: Reputation: 39
Quote:
Originally Posted by markomarko View Post
make sure that you don't forget to run command 'lilo' as root after editing lilo.conf...
Yes, I forget sometimes but it is easy to retry
 
Old 08-16-2010, 10:02 AM   #7
slappyCruzer
LQ Newbie
 
Registered: Apr 2010
Posts: 7

Rep: Reputation: 1
Smile

as this thread is solved. but would like to make a point here..


change the /etc/lilo.conf file
move your desired entry orders ( at the bottom of file ) ( move linux first if you want this to be booted by default
change the default= value

once you save /etc/lilo.conf file

run below commands:

# liloconfig
choose -> expert
choose -> recycle existing lilo.conf ( dont remember exact string )

and you are done...
 
Old 08-16-2010, 12:42 PM   #8
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
I appreciate this is a solved thread as slappyCruzer says but, (no offence meant), he is making more work of this than is necessary. There is no point changing any stanza order in lilo.conf and adding a default= setting - just do one or the other. The stanza appearance order is only honoured if no default setting exists. Personally I feel the easy fix is, as I originally posted, just add the default= statement to /etc/lilo.conf - then run lilo as root - job done. There is no point running the liloconfig script either - this is just a helper script to help initially setup a lilo.conf brought over from the install and overkill in this case - even when just choosing expert and recycle. I'm posting this for any future thread readers as there's no point taking more steps than are necessary to do this simple fix.
 
  


Reply

Tags
start, timeout


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Default OS at Start Up.... abenavar Linux - Newbie 3 04-02-2007 06:41 PM
I want KDE to start by default. marsguy Suse/Novell 7 10-17-2005 05:21 PM
change default os to start Ammad Solaris / OpenSolaris 1 12-31-2004 01:39 PM
how to start kde as default pkuer Linux - Software 4 07-24-2004 10:29 PM
Start x server by default juby *BSD 6 08-11-2003 02:41 PM


All times are GMT -5. The time now is 10:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration