LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-04-2003, 10:42 AM   #1
kiley_rodgers
Member
 
Registered: May 2003
Location: Chicago
Distribution: Slackware 9
Posts: 34

Rep: Reputation: 15
default home directory


OK, I have searched high and low for this and could not find anything addressing it, so I come to you guys for help. I do not know how I managed to do it, but everything was working fine with my Slack 9 system. Then recently, some of the defaul behavior started to change on my logon. For example 'ls' did not produce the nice 'ls --color' display. I found that I did not have a $HOME/.bashrc file. I have since then set this up and and populated it with I need. I still have one annoying problem. When I open a new xterm window or 'su <username>' it does not go directly to my home directly. Instead it goes to '/etc/X11/xinit' (for all accounts). Perhaps I deleted something from the xinitrc file???? Just another note... ALL accounts on the system have this behavior now, so it must be a common file..


Thanks for the help in advance
 
Old 08-04-2003, 10:51 AM   #2
Noryungi
Member
 
Registered: Jul 2003
Location: --> X <-- You are here.
Distribution: Slackware
Posts: 262

Rep: Reputation: 30
Are you starting X11 as "root"?
Do you have a file named ".xinitrc" in your "/home"?

Something smells very fishy in your problem... Are you connected to the Internet by a high-speed link?
 
Old 08-04-2003, 10:59 AM   #3
kiley_rodgers
Member
 
Registered: May 2003
Location: Chicago
Distribution: Slackware 9
Posts: 34

Original Poster
Rep: Reputation: 15
I do not auto start X (through the inittab). I simply log into the character cell environment as myself (normal user) and then 'startx'. I do not have an .xinitrc file in my home dir. Hope I did not mislead you, I simply added the xinitrc tidbit in since that is the dir evreything is defaulting to and I seem to remember futzing around with it early.


I am connect on a LAN @ work.

BTW, I just installed and am using xfce4, perhaps that may had done something?


-kiley

Last edited by kiley_rodgers; 08-04-2003 at 11:01 AM.
 
Old 08-04-2003, 11:10 AM   #4
Noryungi
Member
 
Registered: Jul 2003
Location: --> X <-- You are here.
Distribution: Slackware
Posts: 262

Rep: Reputation: 30
First of all, you probably need an .xinitrc in your home directory.

Second, XFCE4 is not (yet) part of the standard Slackware 9.0 installation... where, and how, did you install XFCE from?
 
Old 08-04-2003, 11:16 AM   #5
kiley_rodgers
Member
 
Registered: May 2003
Location: Chicago
Distribution: Slackware 9
Posts: 34

Original Poster
Rep: Reputation: 15
I will try the .xinitrc fic. Can I use the one from 'etc/X11/xinit' for now (for testing). I got xfce4 from sourceforge and manually installed it. I have to tell you, it is really awesome if you like a simple and fast X environment. Kinda of a pain to install though. I tried and auto script to install that I found on the web, but it never did work, so I did it manually. Just have to follow the steps on the 'Documents Page' of xfce.org for the specifics.
 
Old 08-04-2003, 11:28 AM   #6
Noryungi
Member
 
Registered: Jul 2003
Location: --> X <-- You are here.
Distribution: Slackware
Posts: 262

Rep: Reputation: 30
I use XFCE 3 everyday...

I'll wait for XFCE 4 to get out of beta [I like stability, that's why I use Slackware!] before compiling/installing it on my machine...
 
Old 08-04-2003, 12:11 PM   #7
linuxJaver
Member
 
Registered: Jul 2003
Location: Jakartax, ID
Distribution: slack9.1+,9.1,rh9
Posts: 203

Rep: Reputation: 30
I also got some strange problem with the xterm in xfce (original version come with slack 9). First I tried to put a line in ~/.xinitrc in order to automatically start xterm after xfce is started, It didn't started xterm, later I put such shortcut in Desktop/../autostart, it startet xterm but I got some strange characters at beginning of each line. I though hat modified something in the .xfce directory ..

But I have no lust to bring it back, bcoz I was a little bit thought xfce could be faster through its simplycity, but it also inserted kde/gnome menus with it indirectly (become too thick n slow). I better run kde/gnome if I want kde/gnome menus stuff within xfce ..

Last edited by linuxJaver; 08-04-2003 at 07:06 PM.
 
Old 08-04-2003, 01:29 PM   #8
kiley_rodgers
Member
 
Registered: May 2003
Location: Chicago
Distribution: Slackware 9
Posts: 34

Original Poster
Rep: Reputation: 15
I do not necssarily think this is an xterm problem, but rather an environment issue. Even if I download a file using netscape, it defaults to '/etc/X11/xinitrc' dir when the save as dialog comes up. Any other suggestions?
 
Old 08-04-2003, 07:17 PM   #9
linuxJaver
Member
 
Registered: Jul 2003
Location: Jakartax, ID
Distribution: slack9.1+,9.1,rh9
Posts: 203

Rep: Reputation: 30
It is surely not problem of xterm, konsole worked normally, konsole is actualy a marked up xterm. Surely it is due to the modification of the files in .xfce, that make strange behaviour of xfce, but am too silly to costomize it further.

The action of put the xterm shortcut (copied from kde) into the folder ~/Desktop/../autostart is actually come from kde, as I couldn't costomize ~/.xinitrc to start some extra X-application (xterms) automatically .., but as said it behave unnormal ..

I think xfce is quite ok, Am just too silly to costomize xfce further ..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache Root/Home Directory and setting up FTP for home directories? Mankind75 Linux - Newbie 6 07-23-2006 02:37 PM
Home Directory Default Rights Cottsay Linux - General 2 08-29-2005 01:44 PM
xterm default home directory Fritz_Monroe Linux - Newbie 2 08-05-2005 01:33 PM
Default home directory permission kumarsundaram Linux - Security 14 06-30-2005 07:33 PM
Default home directory permission in SUSE 9.1 soldonz Linux - Security 1 05-26-2005 05:41 AM


All times are GMT -5. The time now is 10:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration