LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-13-2004, 12:12 PM   #1
tw001_tw
Member
 
Registered: Mar 2003
Location: St. Louis, MO
Distribution: kubuntu-current
Posts: 551
Blog Entries: 4

Rep: Reputation: 31
default alsa device?


I guess thats how you would phrase my question.

I recently switched soundcards and now my mixer won't work. It defaults
back to my bt878 card. In the console, when I type:
Code:
alsamixer
It comes up to the mixer settings for the bt878 card.
When I type:
Code:
alsamixer -c1  (i think its '-c' - i'm at work now)
Then the mixer comes up for my soundblaster card.

My question is - how can I convince alsa that my soundblaster card is
device 1 and the bt878 card is device 2?

I guess I could remove both cards, remove alsa, install alsa, put in the
soundblaster, set that up, then install the bt878 - but anyone could
do it that way!
- actually I am taking this opportunity as a learning experience.


I have 1 other question about a different topic, but I'm gonna save
that till after this is resolved.

Thanks in advance - tw
 
Old 10-14-2004, 01:12 AM   #2
jag
Member
 
Registered: Jun 2001
Location: Philippines
Distribution: Slackware
Posts: 34

Rep: Reputation: 15
try running alsaconf. it will let you choose which card you want to be the default.
 
Old 10-21-2004, 08:09 AM   #3
bubbacola367
LQ Newbie
 
Registered: Oct 2004
Posts: 8

Rep: Reputation: 0
Same problem I have - alsaconf however does not show the Tv-Card, but does show up in the mixer as Device 0. If I disable PCI-slots in the BIOS then the MOBO soundcard card is Device 0 and sound works perfectly. I noticed in the /etc/modules.conf that alsa shows prefered device to be the Intel MOBO soundcard, but lists it as device 0, when the mixer shows it to be device 1. What language do I use to change the soundcard info in modules.etc so I can point to device 1. Read you could change the first 0 to 1, but the device will still be device 0. Driving me craz!! Incidentally Knoppix handles it correctly, but does not use Alsa. If I could just have info on how to set up OSS that would also be a great help.
 
Old 10-21-2004, 12:20 PM   #4
bubbacola367
LQ Newbie
 
Registered: Oct 2004
Posts: 8

Rep: Reputation: 0
Came up with a workable solution for the Tv-Card problem that Alsa exhibits - remove Alsa! Specifically: remove Alsa-Utils/Alsa-Driver/Alsa-Lib/Alsa-OSS and modprobe your card (in my instance an Intel 845G which uses the i810_audio). This brings you down to OSS and I am more than pleased. Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
setting the alsa default device Byenary Linux - Newbie 3 06-12-2005 01:52 PM
Getting error: "ALSA device "default" is already in use by another program." brynjarh Debian 7 02-04-2005 12:45 PM
ALSA error: ALSA device "default" is already in use by another program. darkleaf Linux - Software 2 07-20-2004 05:34 PM
Set default ALSA device redneon Linux - Software 2 06-01-2004 10:02 AM
ALSA: Setting default device, MDK10-C. nATEmATE Linux - Software 0 05-07-2004 06:54 PM


All times are GMT -5. The time now is 12:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration