LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-22-2006, 02:03 PM   #1
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 741

Rep: Reputation: 64
Debug info by inet1 during boot


I get the following lines during boot:
Code:
Info, MAC address = xx:xx:xx:xx:xx:xx
Debug, broadcasting DHCP_DISCOVER
Debug, broadcastAddr option is missing in DHCP server response.
Assuming x.x.x.x
Debug, dhcpIPaddrLeaseTime=604800 in DHCP server response.
Debug, DHCP_OFFER received from  (x.x.x.x)
Debug, broadcasting DHCP_REQUEST for x.x.x.x
Debug, dhcpIPaddrLeaseTime=604800 in DHCP server response.
Debug, DHCP_ACK received from  (x.x.x.x)
Debug, broadcasting ARPOP_REQUEST for xxx.xxx.x.xxx
Info, verified x.x.x.x address is not in use
Info, your IP address = x.x.x.x
Debug, orig hostname = xxxxx
Isn't that a bit too much? I mean, just the "Info" messages would suffice. The rest could go in a log. I checked /etc/rc.d/rc.inet1, and I guess these are the responsible lines:
Code:
###########
# LOGGING #
###########

# If possible, log events in /var/log/messages:
if [ -f /var/run/syslogd.pid -a -x /usr/bin/logger ]; then
  LOGGER=/usr/bin/logger
else # output to stdout/stderr:
  LOGGER=/bin/cat
fi
Both /var/run/syslogd.pid and /usr/bin/logger are present, so wouldn't that mean that the messages should go to /var/log/messages instead of on the screen during boot? Or am I missing something?

Cheers, Leon.
 
Old 09-23-2006, 02:09 PM   #2
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,472

Rep: Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523
Quote:
The rest could go in a log.
They are in the logs. Check /var/log/messages or /var/log/syslog. I have my /etc/syslog.conf configured to send all dchcpc output to its own log (see the man page) and all the messages you posted are in that log. The DEBUG feature is for immediate feedback on screen.

Quote:
Or am I missing something?
If you do not need to debug your rc.inet scripts, then disable the debug function (DEBUG_ETH_UP="no") in rc.inet1.conf.
 
Old 09-24-2006, 02:18 AM   #3
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 741

Original Poster
Rep: Reputation: 64
Quote:
Originally Posted by Woodsman
If you do not need to debug your rc.inet scripts, then disable the debug function (DEBUG_ETH_UP="no") in rc.inet1.conf.
I have that set to "no" already.

I had a look at /etc/syslog.conf. How can I modify it so that the rc.inet debug info does not appear on the screen but only in /var/log/messages and/or /var/log/syslog?

Cheers, Leon.
 
Old 09-24-2006, 06:44 AM   #4
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,184

Rep: Reputation: Disabled
You can't, because rc.inet1 will be run several times by UDEV or hotplug before the syslog daemon has even been started. In that case, message will be spilled out onto the screen.

Eric
 
Old 09-24-2006, 10:59 AM   #5
BroX
Member
 
Registered: Oct 2003
Location: Sweden
Distribution: Slackware64-current
Posts: 741

Original Poster
Rep: Reputation: 64
Quote:
Originally Posted by Alien Bob
You can't, because rc.inet1 will be run several times by UDEV or hotplug before the syslog daemon has even been started. In that case, message will be spilled out onto the screen.

Eric
Thanks. Ok, then I'll rest my case and live with those boot messages ;-)

Cheers, Leon.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rc.inet1 isn't running at boot oxleyk Slackware 26 08-04-2005 02:23 PM
Redirecting debug info to another file subu_s Programming 1 12-07-2004 01:15 PM
rpmbuild without stripping debug info gdaly77 Linux - Software 0 05-27-2004 02:43 PM
slackware not running rc.inet1 at boot? razormonkey Linux - Networking 2 10-06-2003 05:05 AM
redirect debug info raven Linux - General 1 11-20-2002 08:16 AM


All times are GMT -5. The time now is 10:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration