LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 01-04-2010, 02:54 PM   #1
gtludwig
Member
 
Registered: Oct 2005
Location: Brazil
Distribution: Slackware64-current
Posts: 221

Rep: Reputation: 16
dbus problem slackware64-current


hey all,

my issue started with a problem running dolphin, then I found out I have a dbus problem.

when I try running dolphin from console I get the following message:
Code:
gtl@cpc-5564:~$dolphin
<unknown program name>(3846)/: Communication problem with  "dolphin" , it probably crashed.
Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." "

gtl@cpc-5564:~$ "/usr/bin/dolphin(3847)" Error in thread 140415397828448 : "org.freedesktop.DBus.Error.NoReply - Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."
I'm running stock Slackware64-current. Please advise!

Thanks in advance!

gtludwig

Last edited by gtludwig; 01-05-2010 at 11:33 AM. Reason: solved!
 
Old 01-04-2010, 03:41 PM   #2
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Linux Mint 17.1
Posts: 1,424

Rep: Reputation: 137Reputation: 137
I am running Slackware64-current (multi-lib) and do not see any errors when starting dolphin from the command line, though I do get an error on exit
Quote:
kDebugStream called after destruction (from void KDirWatchPrivate::removeEntry(KDirWatch*, KDirWatchPrivate::Entry*, KDirWatchPrivate::Entry*) file /tmp/kdelibs-4.3.4/kio/kio/kdirwatch.cpp line 901)
Cancelled INotify (fd 11, 1) for "/home/samac/.local/share"
seems fairly insignificant though. I am not running nepomuk or strigi I don't know if that would make a difference.

samac
 
Old 01-04-2010, 04:03 PM   #3
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,393

Rep: Reputation: Disabled
Exact same behaviour here on slackware64-current starting dolphin in a console as samac describes.

Do you have dbus running?

Eric
 
Old 01-04-2010, 08:56 PM   #4
gtludwig
Member
 
Registered: Oct 2005
Location: Brazil
Distribution: Slackware64-current
Posts: 221

Original Poster
Rep: Reputation: 16
dbus is running.

Code:
gtl@cpc-5564:~$ ps ax | grep dbus-daemon
 1664 pts/1    S+     0:00 grep dbus-daemon
 3052 ?        Ss     0:01 /usr/bin/dbus-daemon --system
 3622 ?        Ss     0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session

Last edited by gtludwig; 01-04-2010 at 09:02 PM.
 
Old 01-05-2010, 02:12 AM   #5
ppr:kut
Slackware Contributor
 
Registered: Aug 2006
Location: Netherlands
Distribution: Slackware
Posts: 370

Rep: Reputation: 98
interesting. I get the same error for skrooge on 13.0. dolphin works fine though.
 
Old 01-05-2010, 11:32 AM   #6
gtludwig
Member
 
Registered: Oct 2005
Location: Brazil
Distribution: Slackware64-current
Posts: 221

Original Poster
Rep: Reputation: 16
according to this post the solution is to remove

/home/[username]/.kde/share/config/dolphinrc

and log KDE back up.

I did a little more, I removed the whole /home/[username]/.kde/ directory and restarted KDE.

It's working now! =)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Updating from Slackware64-current to Slackware64 13. glore2002 Slackware 4 08-28-2009 07:50 PM
Slackware64-current on a second HD. glore2002 Slackware 7 08-23-2009 12:38 PM
Slackware64-current KDE4 Soundserver problem (esd / eSound) Jack128 Slackware 6 08-04-2009 03:17 AM
[SOLVED] Problem with kqemu in slackware64-current since 2.6.29.5 kernel niels.horn Slackware 3 06-20-2009 05:27 PM
DBUS Problem at -Current willysr Slackware 6 03-26-2007 11:01 PM


All times are GMT -5. The time now is 12:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration