LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-13-2006, 03:59 PM   #1
epoo
Member
 
Registered: Aug 2003
Distribution: slackware 11, ubuntu 7.04
Posts: 165

Rep: Reputation: 30
dbus-glib-1 version error when installing xfce4.4


i'm trying to install xfce4.4, and it gets almost all the way through and ends up giving me an error:

checking for dbus-glib-1 >= 0.34... found, but 0.23.4
*** The required package dbus-glib-1 was found on your system,
*** but the installed version (0.23.4) is too old.
*** Please upgrade dbus-glib-1 to atleast version 0.34, or adjust
*** the PKG_CONFIG_PATH environment variable if you installed
*** the new version of the package in a nonstandard prefix so
*** pkg-config is able to find it.
!! Failed to configure xfdesktop, see the errors above
!! for details on the problem.

i'm not sure where to start. i tried doing a search for package dbus-glib-1 both on my pc and google but found nothing. from another thread i did:
pkg-config glib-2.0 --modversion and it returned 2.6.5.

any help please ?
 
Old 10-14-2006, 10:32 AM   #2
Cpoc
Member
 
Registered: Sep 2005
Distribution: Switched to Debian Lenny
Posts: 69

Rep: Reputation: 15
You can get Xfce RC1 and dbus already compiled for Slackware 11 from Rob's site. http://slackpacks.rlworkman.net/

That's what I used and it works perfectly. I'm using Xfce RC1 just had to install dbus and dbus lib from his site.
 
Old 01-28-2008, 01:03 AM   #3
Micky_123
LQ Newbie
 
Registered: Dec 2007
Posts: 17

Rep: Reputation: 0
I am trying to get dbus with glib bindings library. In the above link, its not there.can you please point some other link where I can get it...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dbus-glib-1 -- where to get it from? byte weaver Linux - General 3 02-09-2008 11:16 AM
Xfce4.4RC1 fails to build missing dbus ? exvor Linux - Software 2 10-02-2006 04:34 PM
How to change system default dbus to version 0.23??? okeyla Linux - Newbie 0 10-27-2005 02:31 AM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 06:07 PM
XMMS glib-config error (old conflicting version maybe?) Balkman Linux - Software 0 02-06-2004 04:28 PM


All times are GMT -5. The time now is 11:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration