LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-10-2012, 09:34 PM   #16
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,557
Blog Entries: 28

Rep: Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178

Does "I am not set up as hardware clock is set to UTC" in the OP mean that your hardware/BIOS/real time clock is set to UTC?
Quote:
Originally Posted by fatalerror0x00 View Post
But i don't have to right time...? I'm still always off an hour or more on any clock I chose.
Have you tried using a UTC RTC and a UTC timezone? That would be the simplest of settings, perhaps useful for testing.
 
Old 11-11-2012, 03:12 AM   #17
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
Quote:
Originally Posted by fatalerror0x00 View Post
...
So if i set my time zone to US/Eastern my computer now thinks it's 10:12:17 in the morning -.- I am not finding a timezone man page -.- anyone care to specify a manpage for what he was refering too so i may look at it
When you execute the command
Code:
man timezone
in a terminal, you should see the manpage for timezone. If this is not the case, maybe you're system is messed up.

Markus
 
Old 11-11-2012, 03:30 AM   #18
fatalerror0x00
Member
 
Registered: Oct 2012
Location: Holden, ME, USA
Distribution: SlackWare64 14.00
Posts: 185

Original Poster
Rep: Reputation: 0
Well for now i guess non of this matters or well maybe you can tell me what to do now. I am reinstalling slackware64 14 to undo some stuff I've done and just to start fresh. I need to know though how can I set my clock up properly you think between ntp (if needed) and choosing yes instead of no when it comes to the hardware clock where I don't think I'm gonna use windows I have a spare PC so I can try and better fix this issue. Thanks everyone
 
Old 11-11-2012, 03:38 AM   #19
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,557
Blog Entries: 28

Rep: Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178
Alternatively man -k timezone to get a list of related man pages instead of just the timezone function man page.
 
Old 11-11-2012, 03:38 AM   #20
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
There's also the timeconfig command, execute it as root, it provides the same settings as the installer.

Markus
 
Old 11-11-2012, 03:43 AM   #21
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,557
Blog Entries: 28

Rep: Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178
The only thing I do after a standard installation as you describe is to edit /etc/ntp.conf. Here's my netbook's as an example (I don't have security concerns).
Code:
# Configuration file for ntpd.

# Time sources
# ~~~~~~~~~~~~
# Using pool method from /usr/share/doc/ntp-4.2.6p1/html/manyopt.html#pool
# also at http://www.eecis.udel.edu/~mills/ntp/html/manyopt.html#pool

# For India
# (Asia also required because India is inadequate)
pool in.pool.ntp.org
pool asia.pool.ntp.org

# For UK
#pool uk.pool.ntp.org

# Local, for use when not connected to the Internet
server 127.127.1.0
fudge 127.127.1.0 stratum 10

# Drift file
# ~~~~~~~~~~
driftfile /etc/ntp/drift
 
Old 11-11-2012, 03:45 AM   #22
fatalerror0x00
Member
 
Registered: Oct 2012
Location: Holden, ME, USA
Distribution: SlackWare64 14.00
Posts: 185

Original Poster
Rep: Reputation: 0
I know that markush and thats wheat I been running to change my timezone this whole time :P Hasn't done me anygood but lets take a break from this issue I'm having some performance issues ever since I switched to multilib this afternoon that I'm not happy about and so now I need to reverse this issue -.- gonna just clear the entire system reinstall the system and do all but one thing right this time (we hope all but that one thing right ) we see if setting up the system to look at my RTC will help anything
 
Old 11-11-2012, 03:53 AM   #23
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
When

1. Your hardwarclock in the BIOS is set to localtime (the correct time at your home) and
2. You've chosen the correct timezone US/Eastern and
3. you've selected (in timeconfig) "hardwareclock is set to localtime"

Then it should actually work for you.

You can also use the ntpdate command (when the above settings are all correct)
Code:
ntpdate ntp.colby.edu
as root. Afterwards the system should have the correct time.

Markus
 
Old 11-11-2012, 01:34 PM   #24
fatalerror0x00
Member
 
Registered: Oct 2012
Location: Holden, ME, USA
Distribution: SlackWare64 14.00
Posts: 185

Original Poster
Rep: Reputation: 0
Well I shall try that since that should be the way I'm gonna setup my machine. I gotta redo my machine as something is wrong since I i become multilib
 
Old 11-11-2012, 01:54 PM   #25
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,974

Rep: Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849Reputation: 849
You seem to have many problems with Slackware, maybe you try it a bit more simple and install Slackware 32bit, then you don't need multilib and can make some experience with Linux and Slackware before doing more advanced things.

Markus
 
Old 11-11-2012, 03:40 PM   #26
fatalerror0x00
Member
 
Registered: Oct 2012
Location: Holden, ME, USA
Distribution: SlackWare64 14.00
Posts: 185

Original Poster
Rep: Reputation: 0
I've used slackware 32bit for years I'm just I been taking some chances and exploring but I have considered it but I really need the advantage of my cpu at 64bit because of lot of my applications take advantage of 64bit. I just still getting used to the fact that no one really considers linux in the windows environment and I use both and it's hard to not use a linux version of some my apps but i have decided that some alternatives are really working out for me and that I think i know what I need to do now. Like i said this time around I'm gonna do things differently
 
Old 11-11-2012, 05:18 PM   #27
fatalerror0x00
Member
 
Registered: Oct 2012
Location: Holden, ME, USA
Distribution: SlackWare64 14.00
Posts: 185

Original Poster
Rep: Reputation: 0
So I can't get ntpdate to work it always tells me socket is in use exiting it and it looks like everytime i enter the command a number next to ntpdate gets larger by 1 everytime. Any ideas I can't get any timeservers setup with this thing for some reason? gonna try adding it to the file directly thought but i doubt that will change anything.
 
Old 11-11-2012, 09:16 PM   #28
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,557
Blog Entries: 28

Rep: Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178
Quote:
Originally Posted by fatalerror0x00 View Post
So I can't get ntpdate to work it always tells me socket is in use
That's probably because the NTP daemon, ntpd, is running. If you want to run ntpdate then stop the daemon. AFAIK there's no point because Slackware starts ntpd with the -g option. From the ntpd man page:
Code:
       -g, --panicgate
              Allow  the  first  adjustment to be Big.
Here's an illustrative command shell session
Code:
root@CW9:~# ntpdate asia.pool.ntp.org
12 Nov 07:38:59 ntpdate[3048]: the NTP socket is in use, exiting
root@CW9:~# /etc/rc.d/rc.ntpd stop
Stopping NTP daemon...
root@CW9:~# ntpdate asia.pool.ntp.org
12 Nov 07:39:20 ntpdate[3060]: step time server 103.12.12.126 offset -0.567154 sec
root@CW9:~# /etc/rc.d/rc.ntpd start
Starting NTP daemon:  /usr/sbin/ntpd -g
 
Old 11-12-2012, 10:20 AM   #29
interndan
Member
 
Registered: Aug 2004
Location: near Marion, Ill
Distribution: Slackware 13.37
Posts: 238

Rep: Reputation: 17
I have used this method since about Slack 9 and now with Slack 14 64 bit. I always set hardware clock to local time.

1. Open a terminal and become root

2. Issue the command
Code:
touch /etc/cron.daily/settime
3. Open the file with (I use pico)
Code:
pico /etc/cron.daily/settime
4. Paste the copy and paste this in the editor.
Code:
/usr/sbin/ntpdate north-america.pool.ntp.org && /sbin/hwclock -w
(You will have to use another time server in this is not appropriate for your locale.)
then save the file. In pico control x.

5. make the file executable.
Code:
chmod +x /etc/cron.daily/settime
6. Issue (still as root)
Code:
/etc/cron.daily/settime
This has always kept my clock accurate.

Dan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Daylight Savings time depdiver Linux - General 4 03-13-2006 02:30 PM
Daylight savings time depdiver Red Hat 2 02-21-2006 11:00 AM
Daylight savings time Jeebizz Slackware 13 11-21-2005 09:08 PM
NTP and Daylight Savings Time jrdioko Linux - Software 8 11-01-2005 10:25 AM


All times are GMT -5. The time now is 11:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration