LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Daylight Savings Time (http://www.linuxquestions.org/questions/slackware-14/daylight-savings-time-4175436374/)

fatalerror0x00 11-09-2012 04:01 AM

Daylight Savings Time
 
So Daylight savings time I believe it is ended a couple days ago. My clock is still 1 hour ahead on my linux machine. I am not set up as hardware clock is set to UTC (like to refrain from it too if possible) and my timezone is currently set to ETC/GMT -5

I live in Maine so I'm assuming that is the correct time zone there are several others I've seen used for our timezone before like America/New York US/Eastern are 2 other common ones but those make my clock 3 hours ahead which is worse. I've done some reading on this and I'M REALLY CONFUSED. Any help here would be appreciated thank you! :)

mudangel 11-09-2012 08:33 AM

You could do something like
Code:

ntpdate <IP of local time server>
hwclock --systohc --utc

.

tronayne 11-09-2012 09:10 AM

Are you by any chance dual booting Windows?

If so, get into Windows and get into Control Panel, Date and Time, Time Zone and un-check Automatically adjust clock for daylight savings. That way, Linux will do the saylight changes and you won't have Windows adding an hour.

If you're going to be using MySQL and PHP, you do want to select a specific place-name from the list presented when you run timeconfig; If you're in the eastern time zone, selecting New York is just fine; do that before you do what @mudangel recommends and you ought to be good to go.

Hope this helps some.

bassplayer69 11-09-2012 09:25 AM

See http://www.linuxquestions.org/questi...me-4175435762/

sse007 11-09-2012 09:34 AM

any of those tz is fine, just enable your ntp daemon /etc/rc.d/rc.ntpd and setup your ntp.conf and your time will sync up with the time source when you are online, i don't have to adjust anything when time changed over the weekend

Quote:

Originally Posted by mudangel (Post 4825745)
You could do something like
Code:

ntpdate <IP of local time server>
hwclock --systohc --utc

.


tronayne 11-09-2012 12:02 PM

Note that you only need to do
Code:

ntpdate <IP of local time server>
hwclock --systohc --utc

once (to get the software clock and the hardware clock set to the correct time). After that, get NTPD running and it will keep your clocks accurate whenever you've got a network connection.

A workable configuration for NTPD (in /etc/ntp.conf) might be
Code:

server        127.127.1.0        # local clock
fudge        127.127.1.0 stratum 10       
#server  pool.ntp.org
server  0.us.pool.ntp.org
server  1.us.pool.ntp.org
server  2.us.pool.ntp.org

(in the server section near the top of the file); you don't really need to set anything else in a stock Slackware /etc/ntp.conf.

BTW, you can use
Code:

ntpdate pool.ntp.org
hwclock --systohc --utc

for the initial setting.

Hope this helps some.

fatalerror0x00 11-10-2012 05:12 PM

Not dual booting with windows not yet I plan to later but stilll iffy if I want to deal with some of the issues that can arise from that. and if you give me a moment I will go through this a little more and see what I can get to work for me if not I guess I'll deal with this issue I could adjust but between clocks in my life being different then the computer it's gonna be tough. Thanks guys lets see what we can accomplish here

So whenever I do ntpdate serveraddress then it tells some time and date ntpdate[2857]: the NTP socket is in use, exiting

markush 11-10-2012 05:38 PM

The timezone distinguishes between normal time and daylight saving time (ok, that was clear), when you execute the date command, you should see if the clock is set to normal or daylight-saving. For example here in Germany we have CET (central European time) but during daylightsavin-time it's shown as CEST (central European summertime).

What does the date command show on your computer?

Markus

fatalerror0x00 11-10-2012 06:42 PM

mine when I type in date to the terminal outputs

Sat Nov 10 19:42:33 GMT-5 2012

but the actual time right should be:

Sat Nov 10 18:42:33 GMT-5 2012 or whatever the time zone should say but on every other operatin system I feel like GMT-5 doesn't handle DST but any other time zone I choose screws up my time and makes it like 6 hours more then it should be right now. :( do I maybe need to do a restart after changing time zones for it to take effect properly?

markush 11-10-2012 06:48 PM

I'm not sure, but couldn't you select one of the timezones from /usr/share/zoneinfo/US/ ?

possibly these handle daylight-saving. I'm using /usr/share/zoneinfo/Europe/Berlin

Markus

fatalerror0x00 11-10-2012 06:51 PM

Thats what I'm talking about if i use timeconfig i would select from US and my time zone to select would be Eastern but some reason when I change to Eastern if I remember properly it is like 6 hours more then it is

I will try this again though in a few minutes maybe it's just me -.- I was extremely tired that night and maybe i was doing my math all wrong but i swear I double checked and triple checked :P

markush 11-10-2012 06:54 PM

The manpage for timezone seems to be very helpful in order to explore this subject in more depth.

Well, I'm going to sleep now, it's one o'clock in the morning...

Markus

fatalerror0x00 11-10-2012 07:06 PM

haha alright i keep forgetting they have man pages for like everything I keep thinking man pages are very limited -.- should have looked there first out of anything

alright dude

So if i set my time zone to US/Eastern my computer now thinks it's 10:12:17 in the morning -.- I am not finding a timezone man page -.- anyone care to specify a manpage for what he was refering too so i may look at it :)

catkin 11-10-2012 08:33 PM

Now you have the right time zone set you could shutdown, power up, enter the BIOS setup screens and set the real time clock (RTC) to GMT. That should work until you install Windows.

fatalerror0x00 11-10-2012 08:35 PM

But i don't have to right time...? I'm still always off an hour or more on any clock I chose.


All times are GMT -5. The time now is 03:00 PM.