LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-14-2004, 10:03 PM   #1
rgiggs
Member
 
Registered: Apr 2004
Location: berkeley, ca
Distribution: slk10, winxp
Posts: 313

Rep: Reputation: 30
dark color in some (gtk?) applications.


hi,

http://www.geocities.com/eplmanutd

the first picture at the site above is a snapshot from eclipse for gtk. the mouse is hovering over the menu item help->welcome. as you can see, it's almost impossible to read the text under the dark blue color.

the second one is from the gimp that comes default with slackware 10. the mouse is hovering over the checkbox. again, can't tell whether the box is checked or not until the mouse moves away.

anjuta (a C/C++ IDE for gtk/gnome (but also works in kde)) also has that problem.

anyone knows what's going on and how i can fix this?

thanks.

ps: i think the problem only happens when i use kde. i try to use those applications in gnome and the problem doesn't happen.

Last edited by rgiggs; 07-14-2004 at 10:10 PM.
 
Old 07-15-2004, 12:49 PM   #2
rgiggs
Member
 
Registered: Apr 2004
Location: berkeley, ca
Distribution: slk10, winxp
Posts: 313

Original Poster
Rep: Reputation: 30
bump
 
Old 07-15-2004, 12:58 PM   #3
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,282

Rep: Reputation: 66
try go to /etc/gtk and choose a good gtkrc then copy it to your ~/.gtkrc
 
Old 07-15-2004, 01:30 PM   #4
rgiggs
Member
 
Registered: Apr 2004
Location: berkeley, ca
Distribution: slk10, winxp
Posts: 313

Original Poster
Rep: Reputation: 30
i tried doing that with a couple of different files from /etc/gtk/ (for example, i did cp /etc/gtk/gtkrc.az ~/.gtkrc), but it didn't seem to change anything. i also logged out and rebooted, but still no change. did i do that right, or other ideas?
 
Old 07-15-2004, 01:40 PM   #5
tubatodd
Member
 
Registered: Jun 2003
Location: Birmingham, Alabama (USA)
Distribution: Slackware
Posts: 351

Rep: Reputation: 30
When I used to create GTK themes I had that same problem. Little-by-little I learned how to do things and I learned how to fix nagging things like that. In any event, depending on the theme this may or may not be a simple fix. What it looks like you need to changed is the fg[PRELIGHT] color the the theme's "gtkrc" file. The bg[PRELIGHT] is what give the blue highlight to that menu and the fg[PRELIGHT] does the text. Make sure the fg[PRELIGHT] is "#ffffff" and NOT "#000000" White text will show up much better. If you wish to use a different color, fire up your favorite color chooser (I stumbled across one of GTK a while ago) and mix your color. Then copy the hex info to the fg[PRELIGHT] selection.

These instructions will work simpler themes like Cleanice or Thinice. More complex engines/themes like Smooth, will require that you find the appropriate section in the code that is responsible for the text of that kind of menu. Then you can change THAT fg[PRELIGHT]

As for the check box...similar rules apply.

I hope this helps!!

If you are interested seeing some of my GTK creations, visit....

www.geocities.com/tubatodd/

***EDIT***

I just realized that this was only a KDE problem. Perhaps this will still help to correct the issue.
 
Old 07-15-2004, 01:56 PM   #6
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,282

Rep: Reputation: 66
Nice site Todd, and Elements by Kelly looks very nice...

rgiggs> have you tried to change theme in gnome and then switch to kde to see if it takes effect ?
 
Old 07-15-2004, 02:04 PM   #7
tubatodd
Member
 
Registered: Jun 2003
Location: Birmingham, Alabama (USA)
Distribution: Slackware
Posts: 351

Rep: Reputation: 30
Quote:
Originally posted by keefaz
Nice site Todd, and Elements by Kelly looks very nice...

rgiggs> have you tried to change theme in gnome and then switch to kde to see if it takes effect ?
If you'd like a full-size (1024x768) version of "Elements" I can email it to you.
 
Old 07-15-2004, 02:06 PM   #8
rgiggs
Member
 
Registered: Apr 2004
Location: berkeley, ca
Distribution: slk10, winxp
Posts: 313

Original Poster
Rep: Reputation: 30
it's strange! this is my current ~/.gtkrc:

style "gtk-default-az" {
fontset = "-*-helvetica-medium-r-normal--12-*-*-*-*-*-iso8859-1,\
-*-arial-medium-r-normal--12-*-*-*-*-*-iso8859-1,\
-*-helvetica-medium-r-normal--12-*-*-*-*-*-iso8859-9e,\
-*-arial-medium-r-normal--12-*-*-*-*-*-iso8859-9e,*-r-*"
-*-helvetica-medium-r-normal--12-*-*-*-*-*-iso10646-1,\
-*-arial-medium-r-normal--12-*-*-*-*-*-iso10646-1,*-r-*"
}
class "GtkWidget" style "gtk-default-az"

it seems it only sets the font. so i added fg[prelight] and fg[PRELIGHT] both inside and outside the curly braces ({ }) but still it didn't change anything. then i read that it could be using ~/.gtkrc-2.0, so i tried to edit that and this is what the text of file:

# -- THEME AUTO-WRITTEN DO NOT EDIT
include "/usr/share/themes/Galaxy/gtk-2.0/gtkrc"

# -- THEME AUTO-WRITTEN DO NOT EDIT

any thoughts?
 
Old 07-15-2004, 02:14 PM   #9
rgiggs
Member
 
Registered: Apr 2004
Location: berkeley, ca
Distribution: slk10, winxp
Posts: 313

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by keefaz
rgiggs> have you tried to change theme in gnome and then switch to kde to see if it takes effect ?
i'll try that and see what happens.

Quote:
Originally posted by tubatodd
If you'd like a full-size (1024x768) version of "Elements" I can email it to you.
i am not sure what you meant by "Elements," but if it's something you think can solve my problem (or can teach me how to solve it), then you can post it here or send it to eplmanutd@yahoo.com.

thanks.
 
Old 07-15-2004, 02:16 PM   #10
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,282

Rep: Reputation: 66
Quote:
If you'd like a full-size (1024x768) version of "Elements" I can email it to you.
Sure email me with the button, I will reply with a complete adress.
 
Old 07-15-2004, 02:23 PM   #11
tubatodd
Member
 
Registered: Jun 2003
Location: Birmingham, Alabama (USA)
Distribution: Slackware
Posts: 351

Rep: Reputation: 30
Quote:
Originally posted by rgiggs
it's strange! this is my current ~/.gtkrc:

style "gtk-default-az" {
fontset = "-*-helvetica-medium-r-normal--12-*-*-*-*-*-iso8859-1,\
-*-arial-medium-r-normal--12-*-*-*-*-*-iso8859-1,\
-*-helvetica-medium-r-normal--12-*-*-*-*-*-iso8859-9e,\
-*-arial-medium-r-normal--12-*-*-*-*-*-iso8859-9e,*-r-*"
-*-helvetica-medium-r-normal--12-*-*-*-*-*-iso10646-1,\
-*-arial-medium-r-normal--12-*-*-*-*-*-iso10646-1,*-r-*"
}
class "GtkWidget" style "gtk-default-az"

it seems it only sets the font. so i added fg[prelight] and fg[PRELIGHT] both inside and outside the curly braces ({ }) but still it didn't change anything. then i read that it could be using ~/.gtkrc-2.0, so i tried to edit that and this is what the text of file:

# -- THEME AUTO-WRITTEN DO NOT EDIT
include "/usr/share/themes/Galaxy/gtk-2.0/gtkrc"

# -- THEME AUTO-WRITTEN DO NOT EDIT

any thoughts?
The PRELIGHT stuff was only to suggested in regard to modifying a specific theme. For example, if you are running Gnome and installed my "iFog-XP" theme in your /home/user/.themes/ folder, you could modify the /home/user/.themes/iFog-ZP/gtk-2.0/gtkrc file and change colors and other attributes. What it sounds like to me is, KDE is using its color scheme when running and Gnome is using its color scheme when it is running. So when you run a GTK/Gnome app in KDE, KDE will impose its color scheme so that everything looks the same. In the color scheme section of the KDE control center you can uncheck the option for KDE to use its color scheme with NON-KDE/QT apps. So, your GTK apps would simply use the info written right in the gtkrc file itself. This might correct the problem.

Quote:
i am not sure what you meant by "Elements," but if it's something you think can solve my problem (or can teach me how to solve it), then you can post it here or send it to eplmanutd@yahoo.com.

thanks.
I was replying to keefaz about his post regarding my wife's artwork on my website.
 
Old 07-15-2004, 02:33 PM   #12
rgiggs
Member
 
Registered: Apr 2004
Location: berkeley, ca
Distribution: slk10, winxp
Posts: 313

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by tubatodd
In the color scheme section of the KDE control center you can uncheck the option for KDE to use its color scheme with NON-KDE/QT apps. So, your GTK apps would simply use the info written right in the gtkrc file itself. This might correct the problem.
yay! that worked. i am using win 2000 color scheme, which colors hovered menu items dark blue and the item text white. anyway, thanks.

ps: wanna stop itching? install slackware on your desktop , though i will keep windows around.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dark color schemes-white text doesnt show up in firefox, etc aw76 Linux - General 5 12-01-2005 10:16 AM
Gtk Apps Color in KDE hydorn Linux - Software 1 09-13-2004 11:58 AM
Dark Color Scheme in Mdk10.0? akihandyman Mandriva 0 07-16-2004 05:21 PM
get-background-color in GTK+-2.0 fromzj Programming 0 04-04-2004 03:46 AM
ls --color=yes -> colors too dark clockworks Linux - General 2 01-26-2004 12:31 PM


All times are GMT -5. The time now is 11:22 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration