LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 09-17-2005, 08:21 AM   #1
jiawj
Member
 
Registered: Jul 2004
Location: Beijing, China
Distribution: Slackware,Redhat
Posts: 121

Rep: Reputation: 15
Unhappy cyrus-sasl & openldap issue


I wanna cyrus-sasl support ldap authentication mechanisms, so , I installed openldap( 2.2.26 ) first: ( I have installed BerkeleyDB )
Quote:
./configure --prefix=/usr/local/openldap && make depend && make && make test && make install
and this step successed.

then, I configure cyrus-sasl (2.1.20) src-pkg with following parameters:

Quote:
env - CPPFLAGS="-I/usr/local/openldap/include" LDFLAGS="-L/usr/local/openldap/lib" \
./configure --prefix=/usr/local/sasl2 \
--disable-checkapop \
--disable-cram \
--disable-digest \
--disable-otp \
--disable-srp \
--disable-srp-setpass \
--disable-krb4 \
--disable-gssapi \
--disable-gss_mutexes \
--disable-plain \
--disable-anon \
--disable-login \
--disable-ntlm \
--disable-passdss \
--disable-sql \
--enable-ldapdb \
--with-bdb-libdir=/usr/local/bdb/lib \
--with-bdb-incdir=/usr/local/bdb/include \
--with-gdbm=/usr/local/gdbm \
--with-saslauthd=/var/run \
--with-openssl=/usr/local/openssl \
--with-ldap=/usr/local/openldap \
--with-plugindir=/usr/lib/sasl2 \
--with-authdaemond=/tmp \
--with-dblib=berkeley \
&& make && make install
and it seems successed, at least no error message prompted.
but ......
I tested the saslauthed, It tell me that:

Quote:
#./saslauthd -v
saslauthd 2.1.20
authentication mechanisms: getpwent rimap shadow
can't find ldap support at here,


can anyone help me, thanks very much.

Last edited by jiawj; 09-17-2005 at 08:24 AM.
 
Old 09-17-2005, 05:47 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,395

Rep: Reputation: Disabled
You started saslauthd with
Code:
saslauthd -a ldap
?
The rc.saslauthd file of Slackware 10.2 starts "saslauthd -a shadow" and therefore will not support ldap unless you add "-a ldap".

And you put the your ldap server's configuration parameters into
Code:
/etc/saslauthd.conf
?

Eric
 
Old 09-18-2005, 01:53 AM   #3
jiawj
Member
 
Registered: Jul 2004
Location: Beijing, China
Distribution: Slackware,Redhat
Posts: 121

Original Poster
Rep: Reputation: 15
thx for your reply, I got it.

Quote:
# ./saslauthd -v
saslauthd 2.1.20
authentication mechanisms: getpwent rimap shadow ldap
if saslauthd authentication mechanisms did not include ldap , you can't invoke saslauthd with -a ldap.

I configured cyrus-sasl with:

Quote:
env - CPPFLAGS="-I/usr/local/openldap/include" LDFLAGS="-L/usr/local/openldap/lib" \
./configure --prefix=/usr/local/sasl2 \
--disable-checkapop \
--disable-cram \
--disable-digest \
--disable-otp \
--disable-srp \
--disable-srp-setpass \
--disable-krb4 \
--disable-gssapi \
--disable-gss_mutexes \
--disable-plain \
--disable-anon \
--disable-login \
--disable-ntlm \
--disable-passdss \
--disable-sql \
--enable-ldapdb \
--with-bdb-libdir=/usr/local/bdb/lib \
--with-bdb-incdir=/usr/local/bdb/include \
--with-gdbm=/usr/local/gdbm \
--with-saslauthd=/var/run \
--with-openssl=/usr/local/openssl \
--with-ldap=/usr/local/openldap \
--with-dblib=none
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cyrus-sasl authentication problem nobu Red Hat 1 11-01-2005 07:54 PM
Problem with openLDAP and SASL triley Linux - Software 0 07-14-2005 04:43 PM
Cyrus SASL & Postfix RPM Build ghight Suse/Novell 0 06-03-2005 10:46 AM
Cyrus SASL help littlebill Red Hat 0 10-02-2004 09:43 PM
Cyrus SASL compile error Manuel-H Linux - General 2 05-10-2003 10:12 AM


All times are GMT -5. The time now is 04:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration