LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Current versions of policykit/consolekit vs Gnome Slackbuild Projects pk/ck? (http://www.linuxquestions.org/questions/slackware-14/current-versions-of-policykit-consolekit-vs-gnome-slackbuild-projects-pk-ck-806557/)

damgar 05-07-2010 04:33 PM

Current versions of policykit/consolekit vs Gnome Slackbuild Projects pk/ck?
 
I have a box that I'm running the gnome slackbuild project's 2.28 which has it's own versions of policykit and consolekit. The 13.1 beta/current now include policykit and consolekit as well. I would like to upgrade to the new 13.1 beta .... inlcuding kde 4.4.3, but I'm not sure how to handle these two packages. Does anyone know if these two packages will be specific to a kde or gnome environment or if they are interchangeable?

damgar 05-07-2010 07:53 PM

I bit the bullet and just did the upgrade. So far things seem to be working fine with GSB 2.28 and 13.1b. I'll leave the thread open in case anything untowards comes about. :)

Ivshti 05-08-2010 04:03 PM

Yes, they are both for kde and gnome. If you want to use polkit instead of policykit, you must recompile GNOME. I suggest you compile the svn branch of gsb (see the website for details).

damgar 05-08-2010 06:48 PM

Everything so far is working perfectly by first upgrading GSB to 2.28 with a local mirror and upgradepkg and then using slackpkg to upgrade to 13.1 after blacklisting the GSB replacement packages.

The only hang up that I have found was that after the upgrade to current/13.1 I could no longer change any of the backgrounds or themes in gnome until I created a symlink to a library that got upgraded:
Code:

dtest@dtest:~$ ls -alt /usr/lib/libltdl.so.3
lrwxrwxrwx 1 root root 19 2010-05-07 21:27 /usr/lib/libltdl.so.3 -> /usr/lib/libltdl.so*

Since that I have yet to find anything that doesnt work.


All times are GMT -5. The time now is 09:44 AM.