LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-06-2010, 11:26 AM   #1
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-14.1 on a Lenovo T61 6457-4XG
Posts: 4,021

Rep: Reputation: 966Reputation: 966Reputation: 966Reputation: 966Reputation: 966Reputation: 966Reputation: 966Reputation: 966
-current users with 2.6.33+ and nVidia GPU : nomodeset can avoid you a blank screen


Let's suppose you updated -current >= March 1 2010 and have a nVidia GPU

Question: the screen goes blank during startup what can I do ?
Answer: reboot typing nomodeset at the Lilo prompt, like this:
Code:
Linux nomodeset
Explanation: for nVidia users and kernel 2.6.33 or newer, a nouveau driver is automatically loaded during the startup sequence. But if you chose a VESA resolution at boot like most people do (and is chosen by default if you don't edit lilo.conf before running lilo), the nouveau framebuffer doesn't work for now with some GPUs including mine, and vesa framebuffer is no more in use=> no display at all on the console.

But if you use the nomodeset kernel parameter, nouveaufb is not used so you keep vesafb and all goes well.

Once you are given access to you system again, better either blacklist nouveau or edit lilo.conf to choose one of the "VGA=normal", "VGA=ext" or "VGA=ask" option in your lilo.conf. This way you won't encounter this problem any more.

Last edited by Didier Spaier; 04-07-2010 at 08:25 AM. Reason: Minor fix
 
Old 04-07-2010, 08:04 AM   #2
HerbertJ
LQ Newbie
 
Registered: Oct 2008
Posts: 26

Rep: Reputation: 16
Wow, thanks
I can't test it since I already fixed the problem, but I'm sure someone else out there will get the problem someday.
 
Old 04-08-2010, 02:07 PM   #3
igadoter
Member
 
Registered: Sep 2006
Location: wroclaw, poland
Distribution: slack 12.2, debian-Trinity , openbsd
Posts: 729

Rep: Reputation: 56
nouveau blacklisted

Hi,

I had similar problem. I resolved it blacklisted the noveau
driver.

However when I loggedout from KDE the computer freezed.

Any suggestions what's wrong?

I'm using nvidia fx5500 card.

Greetings
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Fedora 12 with nVidia - Blank screen Lord Mortus Linux - Newbie 17 02-13-2010 08:39 PM
nVidia driver : blank screen oonoon Ubuntu 7 12-20-2009 11:47 PM
yet again need help,screen goes blank in tv out nvidia zeltak Linux - Software 1 02-13-2006 08:58 AM
screen goes blank after nvidia upgrade bitterjack Linux - Newbie 5 09-24-2003 07:41 AM
nvidia driver problem with X - blank screen hollywoodb Linux - Hardware 12 09-03-2003 12:35 AM


All times are GMT -5. The time now is 02:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration