LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-12-2013, 06:19 AM   #1
burdi01
Member
 
Registered: Dec 2010
Location: The Netherlands
Distribution: Slackware, Xubuntu, PartedMagic
Posts: 69

Rep: Reputation: 7
Current: kernel 3.11 with radeon 5700 causes 30 second hiccup at boot/kms


Slackware current, kernel 3.11 with Radeon HD 5700 Series: 30 seconds hiccup at boot/kms.
As per dmesg the firmware "radeon/JUNIPER_smc.bin" is missing.
Upgrading kernel-firmware from 20130705git to 20130912git (created by running source/a/kernel-firmware/kernel-firmware.SlackBuild) resolved the problem.

Last edited by burdi01; 09-12-2013 at 06:27 AM.
 
Old 09-12-2013, 07:02 AM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,407
Blog Entries: 2

Rep: Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994
Just to clarify, the *_smc.bin firmware parts are those that are needed for the DPM function (Dynamic Power Management) of ATI/AMD videocards. That functionality was introduced with the 3.11 kernel, but is not enabled by default. If you want to use it, despite that that feature is called experimental (it works fine on my machines), you have to add the kernel option radeon.dpm=1 to your bootloader configuration.
 
Old 09-12-2013, 11:37 AM   #3
burdi01
Member
 
Registered: Dec 2010
Location: The Netherlands
Distribution: Slackware, Xubuntu, PartedMagic
Posts: 69

Original Poster
Rep: Reputation: 7
For as far as I am aware I did nothing "special" for this kernel:
Code:
root@riposo:~/works# grep -i radeon /boot/config-3.11.0-burdi64 
CONFIG_DRM_RADEON=m
# CONFIG_DRM_RADEON_UMS is not set
CONFIG_FB_RADEON=m
CONFIG_FB_RADEON_I2C=y
CONFIG_FB_RADEON_BACKLIGHT=y
# CONFIG_FB_RADEON_DEBUG is not set
root@riposo:~/works# grep -i dpm /boot/config-3.11.0-burdi64 
root@riposo:~/works#
And I certainly do not have a "radeon.dpm=" kernel boot parameter.
So it looks like DPM is now enabled by default.

Last edited by burdi01; 09-12-2013 at 11:47 AM.
 
Old 09-12-2013, 12:47 PM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,407
Blog Entries: 2

Rep: Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994Reputation: 3994
Nope, it has to be enabled explicitly, otherwise it will fall back to the old manual power management (which should cause your videocard to always run in high power mode).
If
Code:
cat /sys/class/drm/card0/device/power_method
does not show dpm as result you are not using DPM.
 
Old 09-12-2013, 04:59 PM   #5
burdi01
Member
 
Registered: Dec 2010
Location: The Netherlands
Distribution: Slackware, Xubuntu, PartedMagic
Posts: 69

Original Poster
Rep: Reputation: 7
When I boot as always (so no radeon.dpm=1) I get:
Code:
root@riposo:~/works# cat /sys/class/drm/card0/device/power_method
profile
root@riposo:~/works# cat /sys/class/drm/card0/device/power_profile
default
root@riposo:~/works#
When I boot with radeon.dpm=1 I get:
Code:
root@riposo:~/works# cat /sys/class/drm/card0/device/power_method
dpm
root@riposo:~/works# cat /sys/class/drm/card0/device/power_profile
default
root@riposo:~/works#
So my assumption that with kernel 3.11 DPM is on by default was wrong.

I tested kernel 3.11 (again) with and without the radeon.dpm=1 kernel boot parameter: in both cases the radeon/JUNIPER_smc.bin firmware was searched for.

Last edited by burdi01; 09-12-2013 at 05:03 PM.
 
Old 09-14-2013, 04:23 AM   #6
burdi01
Member
 
Registered: Dec 2010
Location: The Netherlands
Distribution: Slackware, Xubuntu, PartedMagic
Posts: 69

Original Poster
Rep: Reputation: 7
The Fri Sep 13 20:00:48 UTC 2013 changes update kernel-firmware to 20130912git, making this thread moot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Kernel-3.11-rc7 kms init causes system hang during boot with cape verde gpu. Only me? Holering Linux - Kernel 5 09-18-2013 09:41 AM
Slackware64-current in VirtualBox: if EFI always KMS, else no KMS. Why? Didier Spaier Slackware 6 07-04-2013 02:21 PM
[SOLVED] ati radeon hd6970 catalyst 12.4 blank screen at boot slackware current 3.2.13 kernel matters Slackware 8 06-14-2012 03:10 AM
Radeon kms works! dolphin77 Slackware 147 01-05-2012 05:32 AM
KMS with radeon gives garbled screen with x onlyolli Linux - Software 0 06-29-2009 04:14 PM


All times are GMT -5. The time now is 09:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration