LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Current: kernel 3.11 with radeon 5700 causes 30 second hiccup at boot/kms (http://www.linuxquestions.org/questions/slackware-14/current-kernel-3-11-with-radeon-5700-causes-30-second-hiccup-at-boot-kms-4175476850/)

burdi01 09-12-2013 06:19 AM

Current: kernel 3.11 with radeon 5700 causes 30 second hiccup at boot/kms
 
Slackware current, kernel 3.11 with Radeon HD 5700 Series: 30 seconds hiccup at boot/kms.
As per dmesg the firmware "radeon/JUNIPER_smc.bin" is missing.
Upgrading kernel-firmware from 20130705git to 20130912git (created by running source/a/kernel-firmware/kernel-firmware.SlackBuild) resolved the problem.
:D

TobiSGD 09-12-2013 07:02 AM

Just to clarify, the *_smc.bin firmware parts are those that are needed for the DPM function (Dynamic Power Management) of ATI/AMD videocards. That functionality was introduced with the 3.11 kernel, but is not enabled by default. If you want to use it, despite that that feature is called experimental (it works fine on my machines), you have to add the kernel option radeon.dpm=1 to your bootloader configuration.

burdi01 09-12-2013 11:37 AM

For as far as I am aware I did nothing "special" for this kernel:
Code:

root@riposo:~/works# grep -i radeon /boot/config-3.11.0-burdi64
CONFIG_DRM_RADEON=m
# CONFIG_DRM_RADEON_UMS is not set
CONFIG_FB_RADEON=m
CONFIG_FB_RADEON_I2C=y
CONFIG_FB_RADEON_BACKLIGHT=y
# CONFIG_FB_RADEON_DEBUG is not set
root@riposo:~/works# grep -i dpm /boot/config-3.11.0-burdi64
root@riposo:~/works#

And I certainly do not have a "radeon.dpm=" kernel boot parameter.
So it looks like DPM is now enabled by default.
:D

TobiSGD 09-12-2013 12:47 PM

Nope, it has to be enabled explicitly, otherwise it will fall back to the old manual power management (which should cause your videocard to always run in high power mode).
If
Code:

cat /sys/class/drm/card0/device/power_method
does not show dpm as result you are not using DPM.

burdi01 09-12-2013 04:59 PM

When I boot as always (so no radeon.dpm=1) I get:
Code:

root@riposo:~/works# cat /sys/class/drm/card0/device/power_method
profile
root@riposo:~/works# cat /sys/class/drm/card0/device/power_profile
default
root@riposo:~/works#

When I boot with radeon.dpm=1 I get:
Code:

root@riposo:~/works# cat /sys/class/drm/card0/device/power_method
dpm
root@riposo:~/works# cat /sys/class/drm/card0/device/power_profile
default
root@riposo:~/works#

So my assumption that with kernel 3.11 DPM is on by default was wrong. :redface:

I tested kernel 3.11 (again) with and without the radeon.dpm=1 kernel boot parameter: in both cases the radeon/JUNIPER_smc.bin firmware was searched for.
:D

burdi01 09-14-2013 04:23 AM

The Fri Sep 13 20:00:48 UTC 2013 changes update kernel-firmware to 20130912git, making this thread moot.
:D


All times are GMT -5. The time now is 09:21 AM.