LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-20-2011, 02:03 AM   #1
aocab
Member
 
Registered: Nov 2009
Location: Heart of Texas
Distribution: Slackware-current
Posts: 138

Rep: Reputation: 30
current+KDE 4.7.4 attempting to install kernel 3.1.5


Apologies in advance for a long post...I wanted to make sure I covered everything I did up to this point.

Running slackware current w/Alien Bob's KDE 4.7.4 packages. Attempting to install Kernel 3.1.5 but not having much luck.

It appears to not even boot far enough to get any messages in the log files or in the bootlogd /var/log/boot file.

The steps I took using Alien Bob's "Building a Linux Kernel from source" as a reference:
Code:
echo $DISPLAY
su -
xauth merge ~alpha/.Xauthority
export DISPLAY=:0

cd /usr/src

wget http://www.kernel.org/pub/linux/kernel/v3.0/linux-3.1.5.tar.xz
wget http://www.kernel.org/pub/linux/kernel/v3.0/linux-3.1.5.tar.sign
Code:
unxz  linux-3.1.5.tar.xz 
 
gpg --keyserver wwwkeys.pgp.net --recv-keys 0x6092693E

gpg --verify linux-3.1.5.tar.sign linux-3.1.5.tar       

tar -xf linux-3.1.5.tar

rm linux
ln -s linux-3.1.5 linux

zcat /proc/config.gz > /usr/src/linux/.config
Code:
cd /usr/src/linux
make oldconfig
(pressed ENTER for the default answers to all the new options)
Code:
make bzImage modules

make modules_install

cp arch/x86/boot/bzImage /boot/vmlinuz-cabgeneric-smp-3.1.5-smp
cp System.map /boot/System.map-cabgeneric-smp-3.1.5-smp
cp .config /boot/config-cabgeneric-smp-3.1.5-smp
cp -a /etc/rc.d/rc.modules-2.6.38.7-smp /etc/rc.d/rc.modules-3.1.5-smp
Added the following to lilo.conf.
Code:
# Linux bootable partition config begins
image = /boot/vmlinuz-cabgeneric-smp-3.1.5-smp
  initrd = /boot/initrd-3.1.5-smp.gz
  root = /dev/sda2
  label = 3.1.5Linux
  read-only
# Linux bootable partition config ends
Code:
mkinitrd -c -k 3.1.5-smp -f ext3 -r /dev/sda2 -m usb-storage:pcmcia_core:pcmcia:mmc_core:ssb:modprobe:ehci-hcd:mbcache:jbd:ext3 -u -o /boot/initrd-3.1.5-smp.gz
Ran lilo.

Rebooted to test the new kernel and the loading process just stopped.

Had to force a reboot and try again but the loading process stopped again but at a different place.

The last line it would stop at was one of the following (paraphrasing):
Quote:
smbus...right before the first drm message...
hub 3-0:1.0 4 ports detected...shortly after OHCI Host Controller...
8139too...Realtek...eth0...RTL 8139...
shpchp...Standard Hot Plug PCI Controller...
parport0...pc style @ 0x378...
Where it stopped loading was not consistent.

If I try loading the new kernel with:
Code:
init=/bin/bash
I get as far as the bash prompt...just not sure where to go from there.

On one occasion it appeared as if it was going to completely boot up. Right after the screen text changes when kms kicks in the screen cleared and I was left with a blinking cursor in the upper left corner.

On another occasion right after kms kicks in it stopped with the last line being (paraphrasing):
Quote:
drm...registered panic notifier
Anyway...Does anyone have any ideas/pointers? Did I miss something obvious?

Thanks in advance for any information.

Cheers & Thanks

System:
Quote:
eMachines w3503 Desktop
Intel Celeron D 356
Ati Radeon Xpress 200
1 GB Memory

Last edited by aocab; 12-20-2011 at 09:31 PM.
 
Old 12-20-2011, 10:35 PM   #2
R3V0LV3R
Member
 
Registered: Nov 2011
Posts: 78

Rep: Reputation: 11
I don't have a solution (sorry), but I recently tried upgrading the kernel to 3.1.5 and was able to log into X, but once I got there the mouse & keyboard didn't work.

So I just wiped it all out, started from scratch, switched to current, and left the kernel as is. Unless your hardware isn't supported, there's no real advantage to upgrading the kernel for the hell of it. I just did it for a learning experience.


All I learned in this case was that it's not worth the trouble unless I need to fix a security hole or address some unsupported hardware.
 
Old 12-21-2011, 02:21 AM   #3
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,564
Blog Entries: 3

Rep: Reputation: 218Reputation: 218Reputation: 218
I hope this helps
seems the 3.1.5 has had some changes please take time and read this
http://www.x.org/wiki/radeonBuildHowTo it start with how to prep your kernel config ok. i wish you luck
 
Old 12-21-2011, 12:18 PM   #4
aocab
Member
 
Registered: Nov 2009
Location: Heart of Texas
Distribution: Slackware-current
Posts: 138

Original Poster
Rep: Reputation: 30
@R3V0LV3R
Quote:
I just did it for a learning experience.
And
Quote:
for the hell of it
because current has been too quiet.

@Drakeo
Thanks, I am familiar with that page.
I used the information found there to get KMS working with the radeon driver when I had
Slackware 13.1 installed because my monitor would lose signal right when KMS kicked in.

I had to:
Add nomodeset to the lilo append line.
Blacklist drm and radeon (blacklisting radeon alone did not work for me).
Load the drivers with KMS enabled right before starting X.

I did not have to do any of this with Slackware 13.37.

Now with Slackware current I still have a problem on occasion when booting:
Once in a while the bootup process stops right when KMS should kick in.

And I also see error messages on occasion in the log files:
Quote:
*ERROR* failed to reserve new rbo buffer before flip
Either way, I will try building the drivers from git as mentioned on that page if I can figure it out.

Again, Thanks.
 
Old 12-21-2011, 03:54 PM   #5
aocab
Member
 
Registered: Nov 2009
Location: Heart of Texas
Distribution: Slackware-current
Posts: 138

Original Poster
Rep: Reputation: 30
I am posting now from Slackware current with kernel 3.1.5 using KDE 4.7.4.
So what exactly is the problem, I am not quite sure.

The machine would stop loading at a point where it looked like it
was wanting to load a printer driver (I have no printer attached)
so I disabled the printer port in the bios.

That got me a little further.

I tried a live Gparted cd w/kernel 3.1.5 and I could not get it to
load with any of the options even failsafe.

Failsafe would give me an error about OHCI bios handoff failed.
Researching this led me to disable the usb options in the bios
(so I have no access to my mouse at this moment).

I also had to add acpi=off to the lilo command line.

And I'm in. Now if I can just figure out what is wrong.

Anyone have any ideas on where to go from here?

Thanks in advance...
(am going back to kernel 2.6.38.7 so I can use my mouse...
as working on a computer these days without a mouse is not very easy.)

Cheers

Last edited by aocab; 12-21-2011 at 04:00 PM.
 
Old 12-21-2011, 07:25 PM   #6
R3V0LV3R
Member
 
Registered: Nov 2011
Posts: 78

Rep: Reputation: 11
You're way more determined than me. It's funny because I was in the exact same situation a few days ago. Tried to go to the most up-to-date kernel simply because I had nothing else to do at the moment (sad isn't it?) and wanted to go to current so I could upgrade KDE.

After the kernel FAIL, I just reinstalled 13.37 and upgraded to current through slackpkg. I just decided the kernel wasn't worth risking yet another reinstall and 25 additional slack builds. Everything works swimmingly now.


P.S. - Where in the heart of Texas are you? Corpus Christi native here.

Last edited by R3V0LV3R; 12-21-2011 at 07:27 PM.
 
Old 12-22-2011, 12:29 AM   #7
aocab
Member
 
Registered: Nov 2009
Location: Heart of Texas
Distribution: Slackware-current
Posts: 138

Original Poster
Rep: Reputation: 30
@R3V0LV3R
Determined? No. Just a stubborn San Antonio native here.
Corpus Christi? I have fond memories of CC. Went to CCSU (early 90's).

@ANYONE
Additional information in case anyone can shed some light on the situation:

Slackware current - KDE 4.7.4 - Kernel 3.1.5

Disabled in BIOS: serial port, parallel port, and USB.

screenshot:
http://imageshack.us/photo/my-images...apshot001.jpg/

dmesg:
http://pastebin.com/4UDM341f

bootlogd:
http://pastebin.com/n194x7Te

lspci
http://pastebin.com/TmEywfJQ

Cheers
 
Old 12-28-2011, 11:51 AM   #8
aocab
Member
 
Registered: Nov 2009
Location: Heart of Texas
Distribution: Slackware-current
Posts: 138

Original Poster
Rep: Reputation: 30
To summarize:
When using any of the following options I can get all the way into the system.
Code:
acpi=off
cpuidle.off=1
idle=poll
idle=mwait
idle=halt
Thoughts?

Notes on things I have tried:
From: https://wiki.ubuntu.com/DebuggingACPI
Quote:
Trouble Booting

For detailed instructions regarding how to modify boot parameters see DebuggingKernelBoot.

Try booting with the "acpi=off" kernel parameter
This will disable ACPI support.
If the error is the same with ACPI enabled and disabled, this may not be an ACPI issue.
If "acpi=off" allows the system to boot, try to isolate the ACPI issue with the following boot parameters

Try booting with "acpi=ht"
This disables all of ACPI except just enough to enable Hyper Threading.
If acpi=off works and acpi=ht fails, then the issue is in the ACPI table
parsing code itself, or perhaps the SMP code.

Try booting with "pci=noacpi"
This disables ACPI for IRQ routing and PCI scanning.

Try booting with "acpi=noirq"
This disables ACPI for IRQ routing.

Try booting with "pnpacpi=off"
This disables the ACPI component of the Linux Plug and Play code.

Try booting with "noapic"
Disables the IO-APIC for IRQ routing or PCI scanning.

Try booting with "nolapic"
Disables the local APIC
I tried all the options and only "acpi=off" works to get me into the system.
The system would just stop loading with all the other options.
It stops before any message is logged and I am not seeing any errors
(just the standard lines that get output as something is loaded).

Tried
Code:
debug initcall_debug
And the system would stop at (paraphrasing):
Quote:
...calling...acpi_processor_init...
...acpi...acpiidle registerred with cpuidle...
Did a google search and came up with this thread:
https://bugzilla.redhat.com/show_bug.cgi?id=155794
The thread is old but it gave me some ideas on things to check.

Disabling CPU frequency:
Quote:
to disable cpufreq w/o re-building the kernel using CONFIG_CPU_FREQ=n,
just move the modules and reboot.

# mv /lib/modules/`uname -r`/kernel/drivers/cpufreq /tmp
# reboot

and to restore:
# mv /tmp/cpufreq /lib/modules/`uname -r`/kernel/drivers
# reboot
I tried this and still could not get all the way into the system.

Try:
Code:
idle=poll
I tired this option and it works.

Quote:
However, "idle=poll" is the biggest clue so far. It suggests
the problem is in the ACPI or CPU_IDLE C-state code.

Please try booting with "processor.max_cstate=1"
If that works, try booting with "processor.max_cstate=2"
If that works, try booting with "processor.max_cstate=3"
I cannot get into the system with any of these options.
Quote:
Also, if you can test with Linux 2.6.27 or later,
please try "idle=halt" and then "idle=nomwait"
"idle=nomwait" does not work for me.
"idle=poll", "idle=mwait", and "idle=halt" work.

Try turning cpuidle off:
Code:
cpuidle.off=1
Quote:
cpuidle.off=1...
useful for disabling cpuidle to fall back
to architecture-default idle loop
Turning off cpuidle also works.

Quote:
I'm surprised that "processor.max_cstate=1" was ineffective
in making the issue go away when "idle=poll" worked...
CONFIG_ACPI_PROCESSOR=y on this kernel?
Mine shows...
Code:
cat /boot/config | grep CONFIG_ACPI_PROCESSOR
CONFIG_ACPI_PROCESSOR=m
CONFIG_ACPI_PROCESSOR_AGGREGATOR=m
http://www.mjmwired.net/kernel/Docum...parameters.txt
Quote:
idle= [X86]
940 Format: idle=poll, idle=mwait, idle=halt, idle=nomwait
941 Poll forces a polling idle loop that can slightly
942 improve the performance of waking up a idle CPU, but
943 will use a lot of power and make the system run hot.
944 Not recommended.
945 idle=mwait: On systems which support MONITOR/MWAIT but
946 the kernel chose to not use it because it doesn't save
947 as much power as a normal idle loop, use the
948 MONITOR/MWAIT idle loop anyways. Performance should be
949 the same as idle=poll.
950 idle=halt: Halt is forced to be used for CPU idle.
951 In such case C2/C3 won't be used again.
952 idle=nomwait: Disable mwait for CPU C-states
953
Again, anyone have any thoughts on this?
Thanks in advance...
Cheers
 
Old 01-26-2012, 05:16 PM   #9
aocab
Member
 
Registered: Nov 2009
Location: Heart of Texas
Distribution: Slackware-current
Posts: 138

Original Poster
Rep: Reputation: 30
I never could figure out how to get the system to boot up far enough to a point where something would get logged without using any of the options mentioned.

This page leads me to believe that my cpu supports c-state modes C0, C1, and C2.
From: http://www.cpu-world.com/CPUs/Celero...552356%29.html
Quote:
Low power features
AutoHALT state
Stop Grant state
This page leads me to believe that my cpu does not support any c-state modes.
From: http://ark.intel.com/products/27131/...533-MHz-FSB%29
Quote:
Idle States No
The problem happens with all the 3+ kernels I've tried (3.1.5, 3.1.6 and 3.2.1) and with a couple of live cds using a 3+ kernel.

As a work around I've added idle=halt to the cmdline since the intel website indicates that my cpu does not support idle states.

System: emachines w3503
Kernel: 3.2.1
DE: KDE 4.8.0
WM: Compiz

http://imageshack.us/photo/my-images...0snapshot.jpg/

http://imageshack.us/photo/my-images...0snapshot.jpg/

Cheers
 
Old 02-02-2012, 05:16 PM   #10
aocab
Member
 
Registered: Nov 2009
Location: Heart of Texas
Distribution: Slackware-current
Posts: 138

Original Poster
Rep: Reputation: 30
Just wanted to add that I installed the latest updates to current
and the problem still occurs with all the available (3.2.2) kernels
(generic, generic-smp, huge, and huge-smp).

None of them will boot up far enough to get anything helpful in the logs.
And there are no obvious errors echoed to the screen.
They all boot fine if I add the cmdline option "idle=halt".

So if anyone has any helpful tips on how to isolate the problem...
please let me know.

Thanks in advance.
Cheers

I am running:
Slackware current (up to date) with Alien Bob's KDE 4.8.0.
I could not find a way to update the title of this thread.

Last edited by aocab; 02-02-2012 at 05:38 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can I install GNOME over my current KDE? ColtraneFan89 Linux - Newbie 5 09-03-2010 11:03 PM
fatal error attempting to install /var/log/mount/slackware/a/kernel-modules-smp-2.6.2 v@ny@ Slackware - Installation 10 05-19-2010 01:40 AM
Install kernel headers (current kernel only) squashed Fedora 2 02-24-2010 10:08 AM
kernel:mtrr error when attempting to login via KDE Swart Linux - General 2 06-02-2007 10:42 AM
Upgrading Kernel from fresh install of 9.1 to Current sganarelle Slackware 10 05-17-2004 10:52 PM


All times are GMT -5. The time now is 10:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration