LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 04-13-2008, 01:06 PM   #1
-{Jester}-
Member
 
Registered: Apr 2008
Location: The Internet
Distribution: Slackware
Posts: 49

Rep: Reputation: 15
Curious Boot Quirk


I am running Slackware 12.0 with the huge.smp kernal booting with the noapic parameter.

The specs on my computer can be found here.

When I start up my Computer, the Lilo menu pops up just fine. I select the Linux option and the screen turns black. If I just let the computer sit there, the screen will stay black and nothing will happen. However, there is a power button on the front of my laptop. If you press it once it puts the computer into sleep mode. If you hold it down it turns the computer off. If I press it once while the screen is black, the boot will start and everything goes smoothly. I guess I do not understand why pressing this button causes the boot to continue as normal. Pressing any other key does not do anything.

I appreciate your time and your thoughts in tracking down the cause of this strange issue :-).
 
Old 04-13-2008, 04:24 PM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,469
Blog Entries: 4

Rep: Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525
Hi,

You could try the 'hugesmp.s acpi=off noapic' to see if that will work for the laptop.

BTW, Welcome to LQ.
 
Old 04-13-2008, 04:33 PM   #3
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,298

Rep: Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722
A black screen sounds like it could be a framebuffer issue (not sure why it would be resolved by pressing the power button, but pressing it may reset the display or something allowing you to see it boot...). Of course, this is assuming that the computer is actually booting in the first place and you just can't see it. If this is the case you should edit /etc/lilo.conf, comment out any vga=### lines and uncomment vga = normal, which should work for any display. You must run `/sbin/lilo` as root before rebooting to write to the MBR or wherever else you wrote lilo's bootloader to. If this ISN'T the case and it actually isn't booting, there may be a module loaded that is causing trouble. In this case you should think about switching to the generic-smp kernel (you should probably do this anyway -- Pat discourages the use of the huge kernels for daily use), which may or may not clear up the issue.

It is possible that something else involving motherboard-specific issues is going on (ie if the above solutions do not work), and for this you'd have to wait for someone else to reply (they may recommend adding another boot option or something like that).

Good luck.

[edit]I should try refreshing the page before I reply. It looks like onebuck already suggested another boot option.[/edit]

Last edited by T3slider; 04-13-2008 at 04:34 PM.
 
Old 04-13-2008, 05:09 PM   #4
-{Jester}-
Member
 
Registered: Apr 2008
Location: The Internet
Distribution: Slackware
Posts: 49

Original Poster
Rep: Reputation: 15
I added the extra boot parameter apci=off and also uncommented vga = normal and this seems to fix the issue. I am thinking it was the vga = normal part that fixed it. Unfourtunetly now my bootup is hanging and never gets to completion. Could apci=off have caused this? The step before it hangs reads:

Code:
Triggering udev events: /sbin/udevtrigger --retry-failed
It's good that vga=normal works, but is there a way to make the boot up use the nVidia driver that I have installed? Also, any suggestions about how to fix the boot up would be appreciated.


One additional problem I discovered is that I get the same black screen when I attempt to logout of my fluxbox session, although that may be fixed now too. I cannot tell though because the boot hangs :-(.

I am going to try to use my Slackware install CD to make a rescue USB stick and see what I can do with that.

Last edited by -{Jester}-; 04-13-2008 at 05:14 PM.
 
Old 04-13-2008, 05:22 PM   #5
digger95
Member
 
Registered: Oct 2007
Location: Indiana, PA
Distribution: Slackware 14
Posts: 330

Rep: Reputation: 45
I'm relatively new so take anything I say with a grain of salt. LoL. However I too had problems logging out of an X session. The screen would just go blank and hang there. Nothing. Turned out to be a xorg issue and running xorgsetup corrected it.
 
Old 04-13-2008, 05:42 PM   #6
-{Jester}-
Member
 
Registered: Apr 2008
Location: The Internet
Distribution: Slackware
Posts: 49

Original Poster
Rep: Reputation: 15
Well the USB key idea failed, but I did manage to mount my harddrive with the install CD and I have edited the lilo configuation file back to what it was (to see if that fixes the problem). The only issue is that I cannot find where the lilo command is on my hard drive. I know I need to execute it to save the .conf file, but so far, no luck.
 
Old 04-13-2008, 05:52 PM   #7
digger95
Member
 
Registered: Oct 2007
Location: Indiana, PA
Distribution: Slackware 14
Posts: 330

Rep: Reputation: 45
/sbin/lilo
 
Old 04-13-2008, 06:08 PM   #8
-{Jester}-
Member
 
Registered: Apr 2008
Location: The Internet
Distribution: Slackware
Posts: 49

Original Poster
Rep: Reputation: 15
Thanks guys for the tips, it's fixed! It was the acpi=off that caused the problem.

I have a / (sda3), /boot (sda1), and /swap (sda2) on my HD. So I did:

Code:
~ # mkdir /mnt/hd ; mkdir /mnt/boot
~ # mount /dev/sda1 /mnt/boot
~ # mount /dev/sda3 /mnt/hd
~ # /mnt/hd/sbin/lilo -C /mnt/hd/etc/lilo.conf -m /mnt/boot/System.map
That issue is taken care of :-).

I attempted to run xorgsetup again as root to see if it would fix the log off problem, but it is still there. Could it be a similar issue like the startup black screen?

Last edited by -{Jester}-; 04-13-2008 at 06:09 PM.
 
Old 04-13-2008, 06:22 PM   #9
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 293Reputation: 293Reputation: 293
Hmmm I have suffered from long delay at

Code:
Triggering udev events: /sbin/udevtrigger --retry-failed
For ages on my desktop. I've never used acpi=off though. Will have to experiment with acpi to see if it's a problem.
 
Old 04-13-2008, 06:32 PM   #10
-{Jester}-
Member
 
Registered: Apr 2008
Location: The Internet
Distribution: Slackware
Posts: 49

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by dive View Post
Hmmm I have suffered from long delay at

Code:
Triggering udev events: /sbin/udevtrigger --retry-failed
For ages on my desktop. I've never used acpi=off though. Will have to experiment with acpi to see if it's a problem.
I was looking back on my old lilo.conf file (I don't overwrite when I make changes, I just make new copies :-p). I was thinking that perhaps it could have been a syntax error that causes the hang up. Specifically, the key line:

Code:
append="apci=off noapic"
I know for sure that my boot up hangs if I do not have noapic. So perhaps this is just the wrong way to pass through two boot parameters. I checked lilo.conf(5), but the part about append was not helpful.
 
Old 04-13-2008, 07:33 PM   #11
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 293Reputation: 293Reputation: 293
Quote:
Originally Posted by -{Jester}- View Post
append="apci=off noapic"
That is the correct way to do it. Didn't work with my problem though.
 
Old 04-13-2008, 10:40 PM   #12
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,298

Rep: Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722
-{Jester}-, what drivers are you using for your nVidia card? The best drivers available are the proprietary ones from nVidia. You *can* use the open-source drivers, but you should expect problems and no 3D acceleration. If you are already using the nVidia drivers, what version are you using? If you did install the nVidia drivers, did you let the installer compile the module itself or did you let if fetch a module from the internet (it's best to let it compile it)? What kernel are you using? (Hopefully an smp kernel, and even more hopefully the generic-smp kernel, or one you compiled yourself.) What model is your video card?

I'm using the latest proprietary nVidia drivers (NVIDIA-Linux-x86-169.12-pkg1.run) with no problems (I have experienced the black screen after exiting X or switching from an X display to a VT, but only when using compiz, which I no longer use. I have since updated the nVidia drivers and I'm not sure whether the latest version is still affected).
 
Old 04-13-2008, 11:04 PM   #13
-{Jester}-
Member
 
Registered: Apr 2008
Location: The Internet
Distribution: Slackware
Posts: 49

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by T3slider View Post
-{Jester}-, what drivers are you using for your nVidia card? The best drivers available are the proprietary ones from nVidia. You *can* use the open-source drivers, but you should expect problems and no 3D acceleration. If you are already using the nVidia drivers, what version are you using? If you did install the nVidia drivers, did you let the installer compile the module itself or did you let if fetch a module from the internet (it's best to let it compile it)? What kernel are you using? (Hopefully an smp kernel, and even more hopefully the generic-smp kernel, or one you compiled yourself.) What model is your video card?

I'm using the latest proprietary nVidia drivers (NVIDIA-Linux-x86-169.12-pkg1.run) with no problems (I have experienced the black screen after exiting X or switching from an X display to a VT, but only when using compiz, which I no longer use. I have since updated the nVidia drivers and I'm not sure whether the latest version is still affected).
nVidia Driver: http://www.nvidia.com/object/linux_d...32_169.12.html

I simply ran the script that came with the download in order to install the driver. It gave me the correct resolution (1280x800).

Kernel: 2.6.21.5-smp

It was the default one that was recommended during install: hugesmp.s.

Graphics Card: VGA compatible controller: nVidia Corporation C51 [Geforce 6150 Go] (rev a2)

I noticed something else as well. When I wake up my computer after the display has been put to sleep, the graphics are wavy and burly and I have to restart.
 
Old 04-14-2008, 06:48 PM   #14
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,298

Rep: Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722
...does Pat write the CHANGES_AND_HINTS.TXT file for himself?
Quote:
Originally Posted by Pat, our Slackware God
It is recommended that you use one of the generic kernels (either the plain
kernel-generic or kernel-generic-smp) for daily use. For most systems,
you should use the generic SMP kernel if it will run, even if your system
is not SMP-capable. Some newer hardware needs the local APIC enabled in
the SMP kernel, and theoretically there should not be a performance penalty
with using the SMP-capable kernel on a uniprocessor machine, as the SMP
kernel tests for this and makes necessary adjustments. Furthermore, the
kernel sources shipped with Slackware 12.0 are configured for SMP usage,
so you won't have to modify those to build external out-of-tree modules
(such as NVidia or ATI proprietary drivers) if you use the SMP kernel.
Quote:
Originally Posted by Pat -- the leader is good, the leader is great
As stated earlier, it is recommended that you use one of the generic kernels
rather than the huge kernels; the huge kernel is primarily intended as
an "installer" and "emergency" kernel in case you forget to make an initrd.
It is *possible* (DEFINITELY not 100%) that a kernel module is loaded that shouldn't be, and is interfering with the nVidia module. You should really move to the generic-smp kernel. However, since the module compiled successfully, this is unlikely. You should post your /etc/X11/xorg.conf file and your /etc/lilo.conf file (does the problem still occur with the vga = normal option?). Beyond that, it's hard to troubleshoot. The only thing I can think of right now, other than the huge-smp scapegoat, is an incorrectly configured X (hence the request to post your xorg.conf). But others are much more intelligent than I, and may have better advice.
 
Old 04-14-2008, 07:48 PM   #15
digger95
Member
 
Registered: Oct 2007
Location: Indiana, PA
Distribution: Slackware 14
Posts: 330

Rep: Reputation: 45
Just to backup what T3slider said, you should really think about switching to one of the generic kernels. I had nothing but problems with the huge kernel. Also, 2.6.21.5 had a lot of acpi problems on my hardware. I've since upgraded to 2.6.24.4-generic kernel and it's been nothing but smooth sailing. Everything 'just works'. Your mileage may vary of course.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Partition Quirk htnakirs Linux - Newbie 2 04-24-2008 07:15 AM
Quirk with Kmail floydking General 0 11-04-2005 06:09 PM
iptable quirk? Jukas Linux - Networking 4 09-24-2005 06:18 PM
Bash quirk? AMMullan Programming 4 02-06-2004 09:16 PM
PCI quirk Tenchi147 Slackware 0 06-04-2003 09:56 PM


All times are GMT -5. The time now is 11:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration