LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-03-2007, 12:43 AM   #1
sysman
LQ Newbie
 
Registered: Dec 2005
Posts: 11

Rep: Reputation: 0
CUPS: remote admin


Hi,

I have installed Slack 12 & have CUPS running, but want to administer remotely via the gui. (the server is not running xwindows).
The server is, say, 192.168.0.20 & my main box is 192.168.1.240.

I tried playing around with cupsd.conf & changing Listen & Allow From directives, but that didn't help.

Anyone got any ideas?

Thanks
 
Old 10-03-2007, 08:08 AM   #2
ramram29
Member
 
Registered: Jul 2003
Location: Miami, Florida, USA
Distribution: Debian
Posts: 848
Blog Entries: 1

Rep: Reputation: 47
Open http://192.168.0.20:631
 
Old 10-04-2007, 12:58 PM   #3
sysman
LQ Newbie
 
Registered: Dec 2005
Posts: 11

Original Poster
Rep: Reputation: 0
Ofcourse I tried that. Page wouldn't load. Apache is up & running ok.
 
Old 10-04-2007, 01:21 PM   #4
MQMan
Member
 
Registered: Jan 2004
Location: Los Angeles
Distribution: Slack64 13.37
Posts: 535

Rep: Reputation: 36
The target machine is on a different subnet. Can you ping 192.168.0.20 from 192.168.1.240.

Cheers.
 
Old 10-04-2007, 02:29 PM   #5
TSquaredF
Member
 
Registered: Dec 2005
Location: "The South Coast of Texas"
Distribution: Slackware64-current
Posts: 490
Blog Entries: 1

Rep: Reputation: 55
Try this link. I know, it's Debian, but all you need to do is modify the cups restart commands & it works fine. The only thing it doesn't do is allow remote access to the admin pages, however, if you apply the instructions for the "Restrict access to configuration files..." section to the "Restrict access to the admin pages..." section, you can get to the admin pages remotely.
Regards,
Bill
 
Old 10-04-2007, 05:53 PM   #6
XGizzmo
Member
 
Registered: Mar 2007
Distribution: Slackware
Posts: 264

Rep: Reputation: 68
Just so you understand apache has nothing to do with the cups web interface. As pointed out it looks like you are using 2 different subnets. also remote access to the cups admin page and server for that matter is disabled by default to all but localhost.

Quote:
Originally Posted by /etc/cups/cupsd.conf
# Restrict access to the server...
<Location />
Order allow,deny
Allow localhost
</Location>

# Restrict access to the admin pages...
<Location /admin>
Encryption Required
Order allow,deny
Allow localhost
</Location>

# Restrict access to configuration files...
<Location /admin/conf>
AuthType Basic
Require user @SYSTEM
Order allow,deny
Allow localhost
</Location>

Last edited by XGizzmo; 10-04-2007 at 05:55 PM.
 
Old 10-05-2007, 12:36 AM   #7
sysman
LQ Newbie
 
Registered: Dec 2005
Posts: 11

Original Poster
Rep: Reputation: 0
First, thanks for the replies.

1) I am using subnet mask of 255.255.248.0, which should (and does) allow for ips in the range 192.168.0.0-7.254

2) I can ping the server. I mentioned apache primarily to indicate that the server is live, working & can be accessed from the network (eg from 192.168.1.240)

3) I tried the page abour Debian which is basically the same as what XGizzmo posted & it didnt help - still getting "problem loading page"

4) the following is the complete cups.conf file

# troubleshooting...
LogLevel info

# Administrator user group...
SystemGroup sys root

# Only listen for connections from the local machine.
Listen localhost:631
Listen 192.168.1.240:631
Listen /var/run/cups/cups.sock

# Show shared printers on the local network.
Browsing On
BrowseOrder allow,deny
BrowseAllow @LOCAL

# Default authentication type, when authentication is required...
DefaultAuthType Basic
DefaultEncryption IfRequested

# Restrict access to the server...
<Location />
Order allow,deny
Allow localhost
Allow 192.168.0.0/21
</Location>

# Restrict access to the admin pages...
<Location /admin>
Encryption Required
Order allow,deny
Allow localhost
Allow 192.168.0.0/21
</Location>

# Restrict access to configuration files...
<Location /admin/conf>
AuthType Basic
Require user @SYSTEM
Order allow,deny
Allow localhost
Allow 192.168.0.0/21
</Location>

# Set the default printer/job policies...
<Policy default>
# Job-related operations must be done by the owner or an adminstrator...
<Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set$
Require user @OWNER @SYSTEM
Order deny,allow
</Limit>

# All administration operations require an adminstrator to authenticate...
<Limit Pause-Printer Resume-Printer Set-Printer-Attributes Enable-Printer Dis$
AuthType Basic
Require user @SYSTEM
Order deny,allow
</Limit>

# Only the owner or an administrator can cancel or authenticate a job...
<Limit Cancel-Job CUPS-Authenticate-Job>
Require user @OWNER @SYSTEM
Order deny,allow
</Limit>

<Limit All>
Order deny,allow
</Limit>
</Policy>

#
# End of "$Id: cupsd.conf.in 5454 2006-04-23 21:46:38Z mike $".
#
cupsd is running (ps -ax | grep cupsd)
5) Are there special users/groups that must be defined???

Thanks a lot

sysman
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Admin cups Jeebizz Slackware 2 08-11-2007 02:03 PM
remote cups printing to a smb/cups print server? justanothergeek Linux - Networking 2 09-15-2004 08:31 AM
CUPS admin tool hangs coshx Linux - Software 0 09-11-2004 02:38 AM
cups admin legin Debian 2 05-29-2004 08:52 AM
CUPS - cannot access admin page Vincent_Vega Linux - Software 0 03-18-2004 01:20 AM


All times are GMT -5. The time now is 07:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration