LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-24-2009, 06:19 AM   #1
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 11, Sabayon 3.1
Posts: 1,464

Rep: Reputation: 46
CUPS - print pages in reverse order


Hi,

I can't get cups to print pages on my printer in reverse order (i.e the right order for documents).

I see that there is an option to the lp command along the lines of lp -o outputorder=reverse ,but I cannot see a way to make this work in graphical interface.

If there is a file I have to edit which one is it?


Also what happened to the nice KDE printer management front end. Now I have to use cups at:
http://localhost:631/

In kde 3.5.x I could manage printers from a KDE app. If there is one now I haven't found it.

Any help appreciated.

Tom
 
Old 11-24-2009, 06:39 AM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,378

Rep: Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824
From http://www.linuxfoundation.org/colla...verse_order.3F
Quote:
How do I print pages always in reverse order?

In the PPD: *DefaultOutputOrder: "reverse"
So, find the .ppd for you printer in /usr/share/cups/model and add or edit '*DefaultOutputOrder: "reverse"'

Last edited by allend; 11-24-2009 at 06:40 AM.
 
Old 11-24-2009, 06:48 AM   #3
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 11, Sabayon 3.1
Posts: 1,464

Original Poster
Rep: Reputation: 46
Quote:
Originally Posted by allend View Post
From http://www.linuxfoundation.org/colla...verse_order.3F


So, find the .ppd for you printer in /usr/share/cups/model and add or edit '*DefaultOutputOrder: "reverse"'
There isn't a ppd file for my printer. just some standard ones (none of the dates of any of the files is recent anyway).

It seems a bit odd that this has never been a problem before but now it doesn't work.
 
Old 11-24-2009, 07:02 AM   #4
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,378

Rep: Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824
Do you have a ppd in /etc/cups/ppd? This is the location for installed printers.
 
Old 11-24-2009, 08:00 AM   #5
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 11, Sabayon 3.1
Posts: 1,464

Original Poster
Rep: Reputation: 46
Hi,

yes, I went there thanks. but adding the line

*DefaultOutputOrder: "reverse"


doesn't change anything. I have tried removing the " from reverse. I have restarted cups too.



Tom
 
Old 11-24-2009, 08:02 AM   #6
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 11, Sabayon 3.1
Posts: 1,464

Original Poster
Rep: Reputation: 46
Supplementary information:

This did work fine in slackware 12.2 (I didn't have to select print in reverse order).

The printer is a sharpe ar-336 copier (uses the sharpe ar161 "driver").
 
Old 11-24-2009, 09:01 AM   #7
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,378

Rep: Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824
This is an excerpt from the .ppd for my printer that does output as you desire.
Quote:
*%==== Basic Device Capabilities =============
*LanguageLevel: "3"
*ColorDevice: True
*DefaultColorSpace: RGB
*FileSystem: False
*Throughput: "12"
*LandscapeOrientation: Plus90
*VariablePaperSize: False
*TTRasterizer: Type42
*FreeVM: "1700000"

*DefaultOutputOrder: Reverse
Did you restart cups after making your edits?
 
Old 11-24-2009, 10:25 AM   #8
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 11, Sabayon 3.1
Posts: 1,464

Original Poster
Rep: Reputation: 46
Yeah, I have restarted CUPS post edit. Still no joy.
 
Old 11-25-2009, 07:56 AM   #9
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,378

Rep: Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824
Looking at the 'stp-sharp-ar-161.5.2.ppd.gz' in /usr/share/cups/model/gutenprint/5.2/ as well as your location, I am wondering whether you should prefix the line with en_GB. i.e.
Quote:
*en_GB.DefaultOutputOrder: Reverse
 
Old 11-26-2009, 08:09 AM   #10
satinet
Senior Member
 
Registered: Feb 2004
Location: England
Distribution: Slackware 11, Sabayon 3.1
Posts: 1,464

Original Poster
Rep: Reputation: 46
unfortunately that doesn't work either.

It is a bit strange as it always worked fine on earlier versions of Slackware and on Ubuntu.
 
Old 02-15-2010, 01:38 PM   #11
ceros
Member
 
Registered: Oct 2005
Distribution: Kubuntu Edgy
Posts: 98

Rep: Reputation: 15
A better way would be to add this option for the specific printer(s) in printers.conf that need reverse printing.

Check http://www.cups.org/documentation.ph...nf.html#Option

So you would add the line "Option outputorder reverse" somewhere for your printer in printers.conf.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Can I set the cups output order to always print in reverse order Thane Ubuntu 2 12-06-2009 06:57 AM
Setting CUPS to print the first page last (reverse) DanielCox Linux - Hardware 1 02-04-2007 05:46 PM
CUPS trunicating print jobs to 2 pages tisource Linux - Software 1 02-01-2006 11:28 AM
CUPS-Don't know how do print in reverse order. SonicGT Linux - Software 1 10-10-2005 02:57 AM
Multiple pages do not print in Slackware 9.1 with CUPS rsamurti Slackware 3 01-19-2004 05:58 AM


All times are GMT -5. The time now is 04:22 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration