LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   CUPS print jobs print 1st page OK, but all others are overwritten (http://www.linuxquestions.org/questions/slackware-14/cups-print-jobs-print-1st-page-ok-but-all-others-are-overwritten-865232/)

staus 02-26-2011 07:24 PM

CUPS print jobs print 1st page OK, but all others are overwritten
 
Not sure when CUPS started acting up. I have the latest 13.1 current software installed. The first page to print is always OK, but all succeeding pages are overwritten. The second page shows the first page on top of it, and the third shows the preceding pages on top of it - and so on.
Has anyone else seen this problem?
I guess the printer buffer is not getting flushed correctly. If my configurations were trashed in some way, I don't know where to look for a fix.

cwizardone 02-26-2011 07:49 PM

Yes, I have the same problem. The only solution I found was to print one page at a time. Hplip wasn't much better. At this point I'm running Xp in VirtualBox when I have to print, scan, Fax, or run Bluetooth. This means Xp is running on my desktop all day during business hours. :banghead:

staus 02-26-2011 07:52 PM

Thanks. At least I'm not the only one. The "CUPS forum" wasn't any help.

cwizardone 03-28-2011 06:28 PM

Quote:

Originally Posted by staus (Post 4272470)
Thanks. At least I'm not the only one. The "CUPS forum" wasn't any help.

Over this last rainy weekend I took the time to run through the various options for installing a printer. I tried using the HP utility and http://localhost:631 (in a browser).
Using the HP utility was not successful.
Using localhost:631 showed about 4 or 5 different drivers, e.g., hplip, gutenprint, and combinations of the two.
I went through each and then ran a test print and a multi-page document.
Success was achieved by using the straight hplip driver. Printing speed is reasonable and multi-page documents are
printing propery.
Just FYI.
:)

aikempshall 06-02-2011 02:10 PM

I've got the same problem with a Canon BJC-80. I've now reverted back to -

foomatic-filters-4.0.4-i486-1.txz
ghostscript-fonts-std-8.11-noarch-1.txz
gutenprint-5.2.4-i486-2.txz
cups-1.4.3-i486-3.txz
ghostscript-8.71-i486-2.txz

These were the packages that were used in 13.1. The BJC-80 prints all pages perfectly.

Will need to roll forward the packages to the versions used in 13.37 to see what package breaks printing. Though, due to lack of time, I won't be doing it in the next month or so.

Woodsman 06-02-2011 03:10 PM

I'm using 13.1, fully updated. cups-1.4.5-i486-2_slack13.1. I use an HP LaserJet 4200, connected to a parallel port.

I tried a few multipage documents and could not replicate the problem. My printer has a duplex tray but I disabled that option for my testing.

Unsure how to help. :( Some weak ideas:

There are files in /var/cache/cups, /var/run/cups, /var/spool/cups that can be deleted. Stop the service, delete the files, start the service.

Do you have any files named $HOME/.lpoptions or /etc/cups/lpoptions? Those files contain override and custom settings.

Are all files in /etc/cups chowned root:lp?

Keith Hedger 06-08-2011 06:12 AM

Quote:

Originally Posted by cwizardone (Post 4306889)
...
Using localhost:631 showed about 4 or 5 different drivers, e.g., hplip, gutenprint, and combinations of the two...

What is this?
I had the same problem with a HP Deskjet F2180, selecting the f2200 Driver ( the next one up ) seemed to fix the problem for the moment.

tronayne 06-08-2011 06:41 AM

You did not mention what brand of printer you have; if it's a Hewlett-Packard, I've found the "best" way to set it up is with HPLIP.

First, open CUPS in your browser and delete the existing printer (and if there's more than one of the same printer, delete those too!). Close CUPS.

Then make sure the printer is turned on and execute hp-setup; you'll get a set up window. You use that to find and identify the printer -- generally it's automagic for a USB printer, not so automagic for an Ethernet printer (and I don't know about parallel or serial connections). I have both a USB and Ethernet printers and I need to enter the fixed-IP address of the Ethernet one (and then hp-setup finds it likity-split).

hp-setup creates the entries in CUPS for you.

In Slackware 13.37 (both 32- and 64-bit) you can execute hp-setup as "you" and you'll be asked for the root password; I seem to recall that I had to actually log in as root in Slackware 13.1 to do the set up and that may be the case.

If you go look at http://hplipopensource.com/hplip-web/index.html there's a how-to use hp-setup along with a download of the current version of HPLIP. It may be useful to download the source and build it with the Slackbuild from the source directory on your distribution disk (edit the version number and there you go).

Hope this helps some.

Keith Hedger 06-08-2011 07:17 AM

Yes its a HP, tried the hp-setup and it created the printer fine but again got the over printing but again I selected the 2200 driver instead of the the 2100 driver ( via cups ) and problem solved, so must be a problem with the driver, thanks anyway

bl0tt0 06-08-2011 12:25 PM

I'm writing to confirm that I had the same problem on stock 13.37 with an Officejet 6500. I managed to fix it by upgrading hplip, foomatic, and ghostscript to the latest releases.

tobyl 06-10-2011 04:48 PM

I have suffered from the same issue on my new epson printer (sx425). I believe the problem at least in my case was ghostscript. This was the only package I upgraded, and early indications are that the problem is solved. I have seen bug reports on ghostscript 9.00 to support this.
I used the source slackbuild (commenting out the diff) on version 9.02

Perhaps Slackware devs might like to consider this as an update?

tobyl

MarcT 06-28-2011 11:32 AM

Same issue in 13.37 with HP DeskJet 843c
 
I recently upgraded from Slackware 13.0 64-bit to 13.37 64-bit (upgrading to 13.1 first).

Multi-page printing then broke on my HP DeskJet 843C printer. It was originally configured under Slack 13.0 with CUPS+GutenPrint and was working fine. Post upgrade, page 2 onwards of any document prints corrupted as described above.

I followed the earlier advice and deleted the printer in CUPS & re-created it by running hp-setup (as root) and it now uses the hpijs driver, and prints multi-page documents fine.

The strange thing is that I also just added an HP LaserJet 5N network printer from CUPS using CUPS+GutenPrint (hp-setup wouldn't detect it), and this prints multiple pages fine.

So, it looks like some printer/driver combinations cause multi-page documents to be printed corrupted (or perhaps it is ghostscript as per previous poster).

Anyway, just another data point to help track the problem down.

Thanks & Kind Regards,
Marc

tronayne 06-28-2011 11:56 AM

Quote:

The strange thing is that I also just added an HP LaserJet 5N network printer from CUPS using CUPS+GutenPrint (hp-setup wouldn't detect it), and this prints multiple pages fine.
I've found that hp-setup won't detect network printers all that well unless you
  • Choose Show Advanced Options
  • Choose Manual Discovery
  • Enter the IP address of the printer or USB Bus ID (either will work)
You can also (usually) find a network printer if you
  • Choose Show Advance Option
  • Select Network Discovery Method SLP
It generally is a good idea, if you're having problems, to go get the latest HPLIP from the web site http://hplipopensource.com/hplip-web...slackware.html, use the SlackBuild from your Slackware installation media (it's in the source directory in ap/hplip), change the version number, build the package and upgradepkg from there.

Hope this helps some.

bonixavier 06-28-2011 12:11 PM

I also have an HP and had the same problem, as well as getting weird colors. What fixed it for me was to change the driver from hplip to hpjips (or something like that). Works flawlessly now.

dive 06-28-2011 01:38 PM

The original problem of overwriting the 2nd+ page is caused by ghostscript. Reverting to a previous version is a workaround.


All times are GMT -5. The time now is 03:19 AM.