LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   CUPS finds printer, won't print (http://www.linuxquestions.org/questions/slackware-14/cups-finds-printer-wont-print-342681/)

esp 07-13-2005 12:14 AM

CUPS finds printer, won't print
 
Well, after recompiling a kernel, (and some other hassle) I now have a /dev/lp0 enltry for my parallel port Samsung ML-1430. Better yet, Cups detects it at the parallel port.

Code:

#: lpstat -p
printer Samsung is idle.  enabled since Jan 01 00:00
        Ready to print.

But, I request to print a test page, and according to the CUPS server, it immediately completes the job.

Nothing happens at the printer, not even a blinking light for data received. perhaps it is being spooled into the void, or /dev/lp0 is working as a dummy device?

Any ideas?

esp 07-13-2005 02:00 AM

ok.. just for fun, I switched it over to USB - again, it is detected on the USB, sets up fine, but all jobs sent to it are immediately shown as completed, and nothing is getting sent to the printer.

Code:

# lpstat -t
scheduler is running
system default destination: Samsung
device for Samsung: usb://Samsung/ML-1430
Samsung accepting requests since Jan 01 00:00
printer Samsung is idle.  enabled since Jan 01 00:00

man this sux. And I had this printer working with my desktop the other day. (this is re: my server)

>>esp

gbonvehi 07-13-2005 02:24 AM

Weird.. if you still have the config file on your desktop you could try copying it.

kencaz 07-13-2005 02:32 AM

Here is a good little article on Cups. Lot's of good admin information:

http://channels.lockergnome.com/it/a...and_line.phtml

KC

APB_4 07-13-2005 05:39 PM

lp-cups -d name_of_printer worked for me

esp 07-14-2005 03:28 AM

Quote:

Originally posted by gbonvehi
Weird.. if you still have the config file on your desktop you could try copying it.
Code:

#  cupsd.conf

ServerName design69.designnet
ServerAdmin esp@designthebest.com
User lp
Group sys
Listen 127.0.0.1:631
Listen 192.168.68.69:631
HostNameLookups On
Browsing On
BrowseAddress 192.168.68.255
BrowseShortNames Yes
BrowseAllow 127.0.0.0/8 192.168.68.*
BrowseDeny ALL
BrowseOrder allow,deny

<Location />
Order Deny,Allow
Deny From All
Allow From 127.0.0.1
Allow From 192.168.68.*
</Location>

<Location /admin>
AuthType Basic
AuthClass System
Order Deny,Allow
Deny From All
Allow From 127.0.0.1
Allow From 192.168.68.*
</Location>



All times are GMT -5. The time now is 05:43 AM.