LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-07-2010, 02:24 AM   #1
tridc
Member
 
Registered: Jan 2010
Distribution: Slackware 13
Posts: 30

Rep: Reputation: 15
Ctrl+Space not work on SCIM or IBus


Hi all,

The magic key Ctrl+Space doesnt always work with SCIM. Too tired with SCIM, I decided to remove it and install ibus, ibus-qt, ibus-unikey (for typing Vietnamese). Then, I start it with:
Code:
$ /usr/bin/ibus-daemon --xim &
 $ /usr/bin/ibus-setup
Then I try press Ctrl+Space to trigger but it doesnt work, even it quits itself sometimes.

The hotkey problem also occurs with KNotes. I have set Global Shortcut for some functions such as New Note, Show All Notes. And it works only once in that session. If restart machine, those shortcut is useless.

My system is Slackware 13.0 with KDE.

Hope for helps. Thanks for advance.
 
Old 03-07-2010, 04:26 AM   #2
gapan
Member
 
Registered: Feb 2007
Posts: 343

Rep: Reputation: 105Reputation: 105
Are the /etc/profile.d/scim.sh and/or /etc/profile.d/scim.csh files executable? If they are not, make them and reboot. SCIM works fine here in xfce, never tried in kde though.
 
Old 03-07-2010, 07:23 AM   #3
tridc
Member
 
Registered: Jan 2010
Distribution: Slackware 13
Posts: 30

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by gapan View Post
Are the /etc/profile.d/scim.sh and/or /etc/profile.d/scim.csh files executable? If they are not, make them and reboot. SCIM works fine here in xfce, never tried in kde though.
Yes, I chmod +x to them. SCIM still work well but many times trigger doesn't work. And even though I click on icon at system tray and choose my input method, I can't write properly. I have tested in both KDE and xfce there's still that error.
 
Old 03-07-2010, 11:28 PM   #4
grissiom
Member
 
Registered: Apr 2008
Location: China, Beijing
Distribution: Slackware
Posts: 419

Rep: Reputation: 45
Maybe you should reboot the system and like slackware do "update-gtk-immodule" stuff. Make sure they are not disabled in rc.M.
 
Old 03-08-2010, 02:13 AM   #5
tridc
Member
 
Registered: Jan 2010
Distribution: Slackware 13
Posts: 30

Original Poster
Rep: Reputation: 15
Thank for your helps.

Seem having a wrong configuration in Slackware that I dont know.
So, I have decided to reinstall Slackware and the problem has gone without any modification!
Then I install scim-unikey, now I can type Vietnamese in all applications: konsole, kwrite, openoffice, firefox, pidgin, ...
I hope it will work out-of-the-box (maybe somedays it breaks ).

Happy Women Day!
Cheers.
 
Old 03-08-2010, 07:14 AM   #6
tridc
Member
 
Registered: Jan 2010
Distribution: Slackware 13
Posts: 30

Original Poster
Rep: Reputation: 15
I have found the reason why SCIM doesnt work with OpenOffice, Firefox, Pidgin.

When I remove gtk+2-2.14.7 and install gtk+2-2.17.11, I get this problem. Maybe I will go back gtk+2 original.

Regards.
 
1 members found this post helpful.
  


Reply

Tags
cjk, scim


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
netbeans ctrl-space problem anillohchab007 Linux - Software 3 08-19-2009 04:36 AM
Ctrl+F2 & Ctrl+F7 won't work alkos333 Slackware 15 12-07-2007 03:44 AM
Ctrl+space couldn't activate scim Niceman2005 Linux - Software 0 03-14-2007 01:07 AM
startup SCIM fine but ctrl-space does nothing Mathsniper Linux - General 2 06-27-2006 12:25 AM
SCIM doesn't work Mathsniper Debian 8 03-02-2006 09:50 PM


All times are GMT -5. The time now is 04:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration