LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Ctrl+Space not work on SCIM or IBus (http://www.linuxquestions.org/questions/slackware-14/ctrl-space-not-work-on-scim-or-ibus-793739/)

tridc 03-07-2010 03:24 AM

Ctrl+Space not work on SCIM or IBus
 
Hi all,

The magic key Ctrl+Space doesnt always work with SCIM. Too tired with SCIM, I decided to remove it and install ibus, ibus-qt, ibus-unikey (for typing Vietnamese). Then, I start it with:
Code:

$ /usr/bin/ibus-daemon --xim &
 $ /usr/bin/ibus-setup

Then I try press Ctrl+Space to trigger but it doesnt work, even it quits itself sometimes.

The hotkey problem also occurs with KNotes. I have set Global Shortcut for some functions such as New Note, Show All Notes. And it works only once in that session. If restart machine, those shortcut is useless.

My system is Slackware 13.0 with KDE.

Hope for helps. Thanks for advance.

gapan 03-07-2010 05:26 AM

Are the /etc/profile.d/scim.sh and/or /etc/profile.d/scim.csh files executable? If they are not, make them and reboot. SCIM works fine here in xfce, never tried in kde though.

tridc 03-07-2010 08:23 AM

Quote:

Originally Posted by gapan (Post 3889024)
Are the /etc/profile.d/scim.sh and/or /etc/profile.d/scim.csh files executable? If they are not, make them and reboot. SCIM works fine here in xfce, never tried in kde though.

Yes, I chmod +x to them. SCIM still work well but many times trigger doesn't work. And even though I click on icon at system tray and choose my input method, I can't write properly. I have tested in both KDE and xfce there's still that error.

grissiom 03-08-2010 12:28 AM

Maybe you should reboot the system and like slackware do "update-gtk-immodule" stuff. Make sure they are not disabled in rc.M.

tridc 03-08-2010 03:13 AM

Thank for your helps.

Seem having a wrong configuration in Slackware that I dont know.
So, I have decided to reinstall Slackware and the problem has gone without any modification!
Then I install scim-unikey, now I can type Vietnamese in all applications: konsole, kwrite, openoffice, firefox, pidgin, ...
I hope it will work out-of-the-box (maybe somedays it breaks :D).

Happy Women Day!
Cheers.

tridc 03-08-2010 08:14 AM

I have found the reason why SCIM doesnt work with OpenOffice, Firefox, Pidgin.

When I remove gtk+2-2.14.7 and install gtk+2-2.17.11, I get this problem. Maybe I will go back gtk+2 original.

Regards.


All times are GMT -5. The time now is 09:03 AM.