LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-29-2003, 02:51 PM   #1
petarsabev
LQ Newbie
 
Registered: Sep 2003
Posts: 27

Rep: Reputation: 15
ctrl+alt+fn problem


X do nothing when presing ctrl+alt+fn - there is no console.
What's the problem ?
Using Slack 9.0
 
Old 09-29-2003, 03:05 PM   #2
clacour
Member
 
Registered: Sep 2003
Location: Dallas, Tx, USA
Distribution: Red Hat, Gentoo, Libranet
Posts: 98

Rep: Reputation: 16
First, just to cover all the bases:

ctrl-alt-Fn means hold down the "Ctrl" and "Alt" keys simultaneously and then press F1,2,3,4,5, or F6 once. (1-6 is usual, but it could be different.)

Don't get offended if you knew that (and I suspect you did). I guarantee, some people don't.

Also, double-check your capslock, numlock, etc.

The next thing to check is /etc/inittab

It should have several lines that look something like this:
Quote:
1:2345:respawn:/sbin/mingetty tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
(mingetty is the program on my Red Hat 9 system. There are a dozen different flavors of "getty". Any of them should be ok, so don't be too surprised if you see "getty", "agetty" or something like that.)

If these are missing, you won't have any virtual consoles. If they're not set to "respawn", you could use each one once, and then it would be gone forever.

I haven't run Slackware in quite a while, but I'd be very surprised if these lines were missing.

Next, run "ps -ef | grep getty". If you have several of them running, and capslock and so forth are off, I'm stumped. You might want to bounce your X server, in case it's gone slightly psycho. Beyond that, I'm out of ideas.

If you don't have any gettys running, and inittab does say "respawn" (which it's almost certain to do), then there's something wrong with your getty. Run (at a command line) "/sbin/mingetty tty4" and look for error messages. If you don't get any, try Ctrl-Alt-F4 and see if it lets you in.

One last thought -- have you loaded any unusual keymaps? It would be a very unusual one that change the Ctrl-Alt-Fn keys, but it's the only other answer I can think of.

Good luck,

CHL
 
Old 09-29-2003, 03:18 PM   #3
petarsabev
LQ Newbie
 
Registered: Sep 2003
Posts: 27

Original Poster
Rep: Reputation: 15
Hmm, everything is OK. I have 6 consoles working .
Inittab is ok. Getty is ok. My xf86config is ok (supporting this option). But still no result in ctrl+alt+fn.

Thank you anyway
 
Old 09-29-2003, 11:29 PM   #4
arakno
LQ Newbie
 
Registered: Jul 2003
Distribution: Slackware
Posts: 10

Rep: Reputation: 0
If you're at runlevel 4, you should have no text consoles.
 
Old 09-30-2003, 05:02 AM   #5
petarsabev
LQ Newbie
 
Registered: Sep 2003
Posts: 27

Original Poster
Rep: Reputation: 15
No I am on runlevel 3. I start X by "startx"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dark screen when pressing Ctrl + Alt + Backspace or Ctrl + Alt F1-F6 in Gnome or KDE trinoo Slackware 5 01-28-2005 08:13 AM
Switching window focus (like alt+tab in windows) and Ctrl+Alt+F1 X windows problem... DiZASTiX Linux - Software 3 01-20-2005 04:56 PM
Terminal change (Ctrl+Alt+F1 to F7) problem mehlkelm Debian 8 09-26-2004 05:11 PM
Lifebook S6210, ctrl+alt+F* problem Karasu Linux - Laptop and Netbook 0 05-24-2004 06:41 AM
ctrl/alt f1 solves my touchpad problem - why? tgarland Linux - Hardware 6 07-02-2003 09:43 AM


All times are GMT -5. The time now is 11:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration