LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-30-2005, 01:35 PM   #1
maginotjr
Member
 
Registered: Aug 2004
Location: BR - Floripa
Distribution: Ubuntu 9.10 - 2.6.x.x
Posts: 661

Rep: Reputation: 34
ctrl-alt-F<n> doesnt work


I think the topic say everything, when I press ctrl+alt+F2 or F3 or F4 and so on nothing happens.

Slackware 10.1 | kernel 2.6.12.1 | Gnome Dropline 10
 
Old 06-30-2005, 01:36 PM   #2
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Are you using runlevel 4 (straight into X)?
 
Old 06-30-2005, 01:44 PM   #3
maginotjr
Member
 
Registered: Aug 2004
Location: BR - Floripa
Distribution: Ubuntu 9.10 - 2.6.x.x
Posts: 661

Original Poster
Rep: Reputation: 34
yeah
runlevel 4 here...

inittab file:
Code:
# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:

# System initialization (runs when system boots).
si:S:sysinit:/etc/rc.d/rc.S

# Script to run when going single user (runlevel 1).
su:1S:wait:/etc/rc.d/rc.K

# Script to run when going multi user.
rc:2345:wait:/etc/rc.d/rc.M

# What to do at the "Three Finger Salute".
ca::ctrlaltdel:/sbin/shutdown -t5 -r now

# Runlevel 0 halts the system.
l0:0:wait:/etc/rc.d/rc.0

# Runlevel 6 reboots the system.
l6:6:wait:/etc/rc.d/rc.6

# What to do when power fails.
pf::powerfail:/sbin/genpowerfail start

# If power is back, cancel the running shutdown.
pg::powerokwait:/sbin/genpowerfail stop

# These are the standard console login getties in multiuser mode:
c1:1235:respawn:/sbin/agetty 38400 tty1 linux
c2:1235:respawn:/sbin/agetty 38400 tty2 linux
c3:1235:respawn:/sbin/agetty 38400 tty3 linux
c4:1235:respawn:/sbin/agetty 38400 tty4 linux
c5:1235:respawn:/sbin/agetty 38400 tty5 linux
c6:12345:respawn:/sbin/agetty 38400 tty6 linux

# Local serial lines:
#s1:12345:respawn:/sbin/agetty -L ttyS0 9600 vt100
#s2:12345:respawn:/sbin/agetty -L ttyS1 9600 vt100

# Dialup lines:
#d1:12345:respawn:/sbin/agetty -mt60 38400,19200,9600,2400,1200 ttyS0 vt100
#d2:12345:respawn:/sbin/agetty -mt60 38400,19200,9600,2400,1200 ttyS1 vt100

# Runlevel 4 used to be for an X window only system, until we discovered
# that it throws init into a loop that keeps your load avg at least 1 all
# the time. Thus, there is now one getty opened on tty6. Hopefully no one
# will notice. ;^)
# It might not be bad to have one text console anyway, in case something
# happens to X.
x1:4:wait:/etc/rc.d/rc.4

# End of /etc/inittab
 
Old 06-30-2005, 01:56 PM   #4
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
As you can see there:
Code:
# These are the standard console login getties in multiuser mode:
c1:1235:respawn:/sbin/agetty 38400 tty1 linux
c2:1235:respawn:/sbin/agetty 38400 tty2 linux
c3:1235:respawn:/sbin/agetty 38400 tty3 linux
c4:1235:respawn:/sbin/agetty 38400 tty4 linux
c5:1235:respawn:/sbin/agetty 38400 tty5 linux
c6:12345:respawn:/sbin/agetty 38400 tty6 linux
Consoles from 1 to 5 won't open on runlevel 4, change that lines to:
Code:
# These are the standard console login getties in multiuser mode:
c1:12345:respawn:/sbin/agetty 38400 tty1 linux
c2:12345:respawn:/sbin/agetty 38400 tty2 linux
c3:12345:respawn:/sbin/agetty 38400 tty3 linux
c4:12345:respawn:/sbin/agetty 38400 tty4 linux
c5:12345:respawn:/sbin/agetty 38400 tty5 linux
c6:12345:respawn:/sbin/agetty 38400 tty6 linux
 
Old 06-30-2005, 01:56 PM   #5
Genesee
Member
 
Registered: Dec 2002
Distribution: Slackware
Posts: 927

Rep: Reputation: 30

the numbers in the second column relate to runlevel in which each agetty is run - you can try adding a "4" in there.

EDIT: gbonvehi beat me to it

Last edited by Genesee; 06-30-2005 at 01:57 PM.
 
Old 06-30-2005, 02:05 PM   #6
maginotjr
Member
 
Registered: Aug 2004
Location: BR - Floripa
Distribution: Ubuntu 9.10 - 2.6.x.x
Posts: 661

Original Poster
Rep: Reputation: 34
but why ctrl-alt-f6 doesnt work too ?
 
Old 06-30-2005, 02:18 PM   #7
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
It's really hard to know that... did it work before dropline? Does ctrl+alt+backspace kills X?
 
Old 06-30-2005, 03:20 PM   #8
maginotjr
Member
 
Registered: Aug 2004
Location: BR - Floripa
Distribution: Ubuntu 9.10 - 2.6.x.x
Posts: 661

Original Poster
Rep: Reputation: 34
yeah.

Ctrl-backspace kills X and I have enable the other virtual consoles already and nothing... with runlevel 3 I can alternate and if I kill GDM I can alternate too

It means that I cant alternate using X ?

;/
 
Old 06-30-2005, 03:26 PM   #9
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
You should be able to alternate using X, try selecting another window manager while running in level 4, maybe there's some key binds overriding ctrl+alt+fX in dropline.
 
Old 07-01-2005, 08:06 AM   #10
ve2mrj
LQ Newbie
 
Registered: Nov 2003
Posts: 23

Rep: Reputation: 1
edit /etc/X11/xorg.conf and in the section:

Section "ServerFlags"
Option "DisableVidModeExtension" "false"
Option "DontZoom" "false"
Option "DisableModInDev" "false"
Option "HandleSpecialKeys" "Always"
EndSection

In some config, there is no Section "ServerFlags" you have to do that
section.

The most important is the:

Option "HandleSpecialKeys" "Always"

Richard
 
Old 07-01-2005, 08:22 AM   #11
piete
Member
 
Registered: Apr 2005
Location: Havant, Hampshire, UK
Distribution: Slamd64, Slackware, PS2Linux
Posts: 465

Rep: Reputation: 44
A friend of mine recently had a similar problem, VT switching wasn't happening. We spent months on the problem ... installing packages, uninstalling packages, playing with all sorts of things ...

It turned out that his keyboard wasn't set up properly in X, so the keymaps for the F keys just weren't right!

The moral of this story is to always make sure xorg.conf contains the proper (pc/104 compared to pc/102, I think his problem was) details for your keyboard!

- Piete.
 
Old 07-01-2005, 08:31 AM   #12
perfect_circle
Senior Member
 
Registered: Oct 2004
Location: Athens, Greece
Distribution: Slackware, arch
Posts: 1,783

Rep: Reputation: 52
DO you have a Microsoft keyboard?
Some of them have different key bindings for the F keys.
Did this work before or didn't this never work?
A friend of mine bought a new microsoft keyboard and the F keys did not work.
In the tutorial section there is a guide of how to fix this, if this is the case:
http://www.linuxquestions.org/questi...icle&artid=290
 
Old 07-01-2005, 09:38 AM   #13
maginotjr
Member
 
Registered: Aug 2004
Location: BR - Floripa
Distribution: Ubuntu 9.10 - 2.6.x.x
Posts: 661

Original Poster
Rep: Reputation: 34
yeah ... this worked before... I dont remember exactly what moment, but this is why Im searching some answers...

I use my notebook keyboard. I think this function stoped after installing Dropline Gnome 2.10 O_o
but Im not sure...


If someone knows where to make this functions keys works, some conf file I dont know.. ;///
 
Old 07-01-2005, 11:19 AM   #14
zborgerd
Member
 
Registered: Mar 2004
Distribution: Slackware / Dropline GNOME
Posts: 378

Rep: Reputation: 30
Quote:
Originally posted by gbonvehi
You should be able to alternate using X, try selecting another window manager while running in level 4, maybe there's some key binds overriding ctrl+alt+fX in dropline.
If it works in runlevel 3 then it is likely something that is happening after X11 is initialized. Does it happen if you start in runlevel 3 and then run "startx"?

I'm thinking keybindings here.

Create a new user account and then start GNOME. See if it happens then. Somethiing may be mucked in that particular account's keybinding settings.

Also, if you have this enabled in your /etc/X11/xorg.conf, then it will most certainly disable VT switching:
Code:
    Option     "DontVTSwitch"
Comment that out if it is uncommented.


Last edited by zborgerd; 07-01-2005 at 11:26 AM.
 
Old 07-01-2005, 11:26 AM   #15
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,454

Rep: Reputation: 96
[edit]
I misread the initial post

Maybe an interesting test would be to telinit 3 and
attempt to switch consoles from here

Quote:
with runlevel 3 I can alternate and if I kill GDM I can alternate too
If you kill GDM in runlevel 3 or 4 ?

Last edited by keefaz; 07-01-2005 at 11:29 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CTRL+ALT+F1....F6 don't work abd_bela Debian 4 02-03-2012 04:21 PM
CTRL+ALT+F* Terminals don't work sekelsenmat Mandriva 3 11-26-2005 03:46 AM
dark screen when pressing Ctrl + Alt + Backspace or Ctrl + Alt F1-F6 in Gnome or KDE trinoo Slackware 5 01-28-2005 08:13 AM
Ctrl+alt+F... don't work in X (Mandrake 9.1) ACMwizard Linux - Software 2 05-19-2003 01:20 PM
Alt+Ctrl+FX--doesn't work under KDE3 l_9_l Linux - General 1 04-29-2002 07:38 PM


All times are GMT -5. The time now is 04:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration