LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-14-2012, 12:36 PM   #1
thomasf
LQ Newbie
 
Registered: Oct 2012
Posts: 4

Rep: Reputation: Disabled
Crazy Problems with XkbLayout


Hello

I use Slackware64 14.0 with NVIDIA-Linux-x86_64-304.51

I have copied the 90-keybord-layout.conf from /usr/share/X11/xorg.conf.d to /etc/X11/xorg.conf.d and edit "XkbLayout" from us to "de"

The /etc/X11/xorg.conf(created from Nvidia-Installer) have copied in /etc/X11/xorg.conf.d/20-nvidia.conf and modified. Only Section Monitor, Device and Screen is in this file.

The Xorg.0.log says
8.534] (**) Option "xkb_rules" "evdev"
[ 1028.534] (**) Option "xkb_model" "evdev"
[ 1028.534] (**) Option "xkb_layout" "de"
[ 1028.534] (**) Option "xkb_variant" "qwertz"
[ 1028.534] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"

are it works absolutely not.

My Login Manager is Slim , here is false ... The Desktop is E17 and is false (Slackbuilds from slackbuilds.org)

In 13.37 its All OK for Slim and E17 and all Programs with the 90-keybord-layout.conf

I have no Idea more
Its Magic

Greetings and sorry for my chaotical English.
Thomas
 
Old 10-15-2012, 08:34 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,897

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
Quote:
[ 1028.534] (**) Option "xkb_variant" "qwertz"
Perhaps of the error (typo?) above?
It should read
Code:
Option "xkb_variant" "qwerty"
 
Old 10-16-2012, 03:00 AM   #3
thomasf
LQ Newbie
 
Registered: Oct 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thats right , here in Germany is qwertz

I have last tested with this option , but no change

I have Multilib installed .. maybe is this the Problem

Thomas
 
Old 10-16-2012, 05:21 AM   #4
lambo69
LQ Newbie
 
Registered: Sep 2012
Posts: 21

Rep: Reputation: Disabled
I had the same problem with xdm, putting
Code:
setxkbmap de
in its startup or setup script worked for me.
 
Old 10-16-2012, 06:19 AM   #5
jtsn
Member
 
Registered: Sep 2011
Location: Europe
Distribution: Slackware
Posts: 800

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
The XkbVariant option and the other stuff isn't needed, just put the following into /etc/X11/xorg.conf.d/keymap.conf:

Code:
Section "InputClass"
    Identifier      "Keyboard0"
    MatchIsKeyboard "True"
    Option          "XkbLayout" "de"
EndSection
 
Old 10-16-2012, 02:39 PM   #6
thomasf
LQ Newbie
 
Registered: Oct 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
@lambo69

Wondefull
I have edit (to test) the xinitrc.twm "usr/bin/setxkbmap de & " ... it works

@jtn
Thatīs the Problem ... the File for Keyboard in /etc/X11/xorg.conf.d/ is completely ignored.
I have tested with all Options (with/without qwertz,nodeadkeys XkbLayout with and without XkbVariant) ... in /etc/X11/xorg.conf and in the .d/Directory
Nothing ... completely ignored.

Maybe comes from the newest Nvidia-Driver.

Thanks all for the Help
Greating Thomas
 
Old 10-17-2012, 03:37 AM   #7
jtsn
Member
 
Registered: Sep 2011
Location: Europe
Distribution: Slackware
Posts: 800

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
Maybe it isn't ignored, but set to something different by your non-Slackware display manager or desktop environment. Try to revert to xdm and twm and post a complete xorg.conf and Xorg.0.log
 
Old 10-17-2012, 04:29 AM   #8
thomasf
LQ Newbie
 
Registered: Oct 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
I have new installed.
At the Moment , is SLim no installed. Is the same, only the Trick with setxkbmap de X-Start had helped. The 90-xkeyboard.conf brings no effect .... only the Trick with setxkbmap de in xinitrc had helped.

I use my Laptop in the Moment. I poste later the Xorg.log

Thomas
 
Old 10-19-2012, 09:16 AM   #9
jinnz
LQ Newbie
 
Registered: Oct 2012
Location: Ukraine
Distribution: Slackware
Posts: 2

Rep: Reputation: Disabled
Wink advice

Quote:
Originally Posted by thomasf View Post
Hello

I use Slackware64 14.0 with NVIDIA-Linux-x86_64-304.51

I have copied the 90-keybord-layout.conf from /usr/share/X11/xorg.conf.d to /etc/X11/xorg.conf.d and edit "XkbLayout" from us to "de"

The /etc/X11/xorg.conf(created from Nvidia-Installer) have copied in /etc/X11/xorg.conf.d/20-nvidia.conf and modified. Only Section Monitor, Device and Screen is in this file.

The Xorg.0.log says
8.534] (**) Option "xkb_rules" "evdev"
[ 1028.534] (**) Option "xkb_model" "evdev"
[ 1028.534] (**) Option "xkb_layout" "de"
[ 1028.534] (**) Option "xkb_variant" "qwertz"
[ 1028.534] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"

are it works absolutely not.

My Login Manager is Slim , here is false ... The Desktop is E17 and is false (Slackbuilds from slackbuilds.org)

In 13.37 its All OK for Slim and E17 and all Programs with the 90-keybord-layout.conf

I have no Idea more
Its Magic

Greetings and sorry for my chaotical English.
Thomas
Hello!
You needed write that also in /etc/X11/xorg.conf.
Also append Option "Device" "/dev/input/event0"
else attempt:
Option "xkb_variant" ",winkeys", comma needed.
Ukraine

Last edited by jinnz; 10-19-2012 at 09:45 AM.
 
Old 10-19-2012, 05:25 PM   #10
jinnz
LQ Newbie
 
Registered: Oct 2012
Location: Ukraine
Distribution: Slackware
Posts: 2

Rep: Reputation: Disabled
Section "InputDevice"
Identifier "Keyboard0"
Driver "evdev"
Option "AutoServerLayout" "on"
Option "Device" "/dev/input/event0"
Option "XkbRules" "evdev"
Option "XkbModel" "evdev"
Option "XkbLayout" "us,de"
Option "XkbVariant" ",winkeys"
Option "XkbOptions" "terminate:ctrl_alt_bksp,grp:alt_shift_toggle,grp_led:scroll"
EndSection
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Two More Crazy 12.2 Problems Woodsman Slackware 20 12-20-2008 07:42 PM
crazy soundcard problems zytsef Slackware 2 11-07-2007 01:34 PM
Is there an xkblayout for the systray ? Xeratul Linux - Software 0 05-05-2007 03:36 AM
apt-get Problems Going CrAzY timgerrlists Ubuntu 7 05-02-2006 08:52 AM
Can't ctrl+alt+f1-f6 out of X since setting xkblayout = eu boing Linux - Software 2 03-26-2005 12:24 PM


All times are GMT -5. The time now is 05:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration